Hallo!
Es kommt diese Meldung beim Aufruf:
The Install Tool is locked.
Fix: Create a file typo3conf/ENABLE_INSTALL_TOOL
This file may simply be empty.
For security reasons, it is highly recommended to rename
or delete the file after the operation is finished.
If the file is older than 1 hour TYPO3 has automatically
deleted it, so it needs to be created again.
Danach erstelle ich die Datei ENABLE_INSTALL_TOOL OHNE Endung!
Sobald ich dann wieder die typo3 Seite aufrufe, wird die eben erstellte Datei ENABLE_INSTALL_TOOL automatsich gelöscht und es kommt wieder die obige Meldung! Was mach ich denn da falsch???
Hi!
Versuch' mal folgende Alternative:
- Unter TYPO3 als Amdin anmelden
- Ins Modul "Benutzereinstellugnen" wechseln
- Dort den Reiter "Admin Funktionen" w#hlen
- Den Button "Install Tool Datei erzeugen" klicken
- Jetzt solltest Du das Install-Tool öffnen können, geht auch über die Modulleiste
CU
maxhb
P.S.: Die Bezeichnung sind aus dem Gedächtsnis, könnten leicht abweichen heissen...
Ich hatte das Problem auch. Ursache war ein zu altes File-Datum, da ich einfach ein altes File kopiert hatte. Aktualisierung von Datum und Zeit haben geholfen.
Gruß, Michael
Hallo,
TYPO3 löscht das File nach einiger Zeit automatisch.
Wenn es mit dem File-Datum Probleme gibt, wird das File u.U. direkt wieder gelöscht.
Du kannst aber in das File ENABLE_INSTALL_TOOL diesen Text reinschreiben:
KEEP FILE
Dann wird es nicht mehr gelöscht.
Grüße
Hallo,
ich hab noch eine Frage dazu. Es gibt ja in den Benutzereinstellungen den Button "Install Tool Datei erzeugen". Bei einer einzigen Installation von mir fehlt dieser Button jedoch. Der User ist aber Admin. Auch ein frisch angelegter Admin-User hat den Button nicht. Ich suche nun schon einige Zeit, finde aber keine Lösung.
Der Fehler trittt schon mindestens seit Version 4.4 auf, auch jetzt mit 4.5.2 ist er noch da.
Hat jemand einen Tipp?
Danke, Adino
@maxhb
Sag mal...hast Du überhaupt richtig gelesen ?
Es kommt diese Meldung beim Aufruf:
The Install Tool is locked.
Fix: Create a file typo3conf/ENABLE_INSTALL_TOOL
Und Du schreibst:
Versuch' mal folgende Alternative:
- Unter TYPO3 als Amdin anmelden
Wie soll er sich denn anmelden, wenn TYPO3 noch gar nicht installiert ist ?
Mann Mann Mann......
Hallo,
ich hänge mich mal an diesen Thread, weil ich das gleiche Problem habe....
- TYPO3 v4.5 auf dem lokalen PC entpackt (zip-Archiv)
- per FileZilla auf den Webspace hochgeladen
- Webseite aufgerufen
- es kommt die Meldung:
The Install Tool is locked.
Fix: Create a file typo3conf/ENABLE_INSTALL_TOOL
Also im Ordner "typo3conf" eine leere Datei mitr dem o.a. Namen angelegt (ohne Extension !)... wieder die Seite aufgerufen...und was kommt:
The Install Tool is locked.
Fix: Create a file typo3conf/ENABLE_INSTALL_TOOL
WTF ??????? ISt TYPO3 mittlerweile schon so userunfreundlich geworden ????
Hallo zusammen,
ich hoffe ich bin hier richtig mit meinem Problem und hoffe ihr könnt mir helfen.
Ich habe ein WebPack L 4.0 von HostEurope, welches laut HostEurope passend für Typo3 ist.
Ich habe die Typo3 4.6 Source + Dummy runtergeladen und in meinen Webspace hochgeladen. Kann auch über ...typo3/install/index.php auf die bekannte Seite mit der Meldung zum ENABLE_INSTALL_TOOL kommen.
Wenn ich dann die Datei erstelle und in den Ordner typo3conf einfüge und die Seite erneut aufrufe, kommt über Firefox nur eine leere Seite und beim IE
Die Website kann diese Seite nicht anzeigen.
HTTP 500
Ich kann mir diesen Fehler nicht erklären, vielleicht habe ich nur eine Kleinigkeit vergessen.
Über einen Tip würde ich mich freuen.
Vielen Dank im voraus und ein schönes Wochenende.
Schade, es scheint wohl niemand dieses Problem zu kennen, dann muß ich es wohl in einem anderen Forum versuchen.
Ein 500er kann viele Ursachen haben, z.B. falsche Rechte bei Dateien usw. Guck in die Error-Logs wenn du Zugriff drauf hast.
@Norman2k: Vielen Dank erstmal.
Leider muß ich zugeben, dass ich kein Profi bin.
Könntest du mir sagen, wo ich die finde?
Was ich seltsam finde, ist, dass vor dem Einfügen der ENABLE_INSTALL_TOOL alles normal aussieht und danach gar keine Reaktion kommt (habe auch nirgendwo einen solchen Fehler im Netz gefunden).
Ob du Zugriff auf die Error Logs hast und wo diese zu finden sind, kommt ganz auf den Provider an, da müsstest du bei dem nachfragen oder in der Doku gucken.
Es kann sein, dass z.B. die PHP Version zu alt ist oder das Speicherlimit zu gering ist. Eventuell funktioniert der Check auf die ENABLE_INSTALL_TOOL Datei trotzdem aber eben alles danach nicht mehr.
@kitsunet: Vielen Dank für die Info.
Ich habe an meinen Provider die Info gegeben, dem ist aufgefallen, dass falsche Dateiberechtigungen vorhanden waren.
Diese wurden geändert und nun kommt auch der nächste Schritt.
Vielen Dank für die Hilfe