Zum Inhalt springen

ERROR: Could not create extension directory

Erstellt am 20. November 2003 · 9 Antworten · letzte Antwort am 21. September 2008

Tags: Frage

jlkettwig ·

ich schaffe es leider nicht, eine extension aus dem repository upzuloaden. kann mir jemand helfen, bzw. sagen, was da nicht stimmen könnte? ich bekomme immer die fehlermeldung:
ERROR: Could not create extension directory '/home/www/web51/html/typo3web/typo3conf/ext/doc_tut_templselect/'

/ext/ ist mit allen rechten versehen (777)
/doc_tut_templselect/ existiert vor dem installationsversuch noch nicht.

was kann denn da schieflaufen?

jlkettwig ·

natürlich bin ich registriert.

Aber hier noch eine Frage:
unter Settings habe ich ja folgende Felder:
Enter repository username:
Enter repository password:
Enter default upload password:

die ersten beiden sind wohl mit den daten zu füttern, die ich bei der registrierung bei typo3.org angegeben habe. ABER: was ist das upload passwort? Ist das identisch mit dem repository password????

BITTE um HILFE

Julian ·

ERROR: Could not create extension directory '/home/www/web51/html/typo3web/typo3conf/ext/doc_tut_templselect/'

Die Fehlermeldung taucht übrigens auch auf, wenn du nicht mehr über genügend freien Webspace verfügst. Nur so am Rande mal angemerkt 😃

Julian

alias7x ·

Ich habe dasselbe Problem. Hat sich in den letzten zwei Monaten ne Lösung gefunden? Wenn ja, würd ich mich über ein Posting freuen.
grüße, Ali

magold ·

Hallo, habe das hierzu gefunden und es hat funktioniert...

In fact I had the same problem and leaving the last slashes before creating the dirs fixed it.

So I changed the following in file /typo3/mod/tools/em/index.php

Around line 1800:

// we go create...
@mkdir($extDirPath, 0777);
if (!is_dir($extDirPath))        return "ERROR: Could not create extension directory '".$extDirPath."'";

to

// we go create...
@mkdir(substr($extDirPath,0,(strlen($extDirPath)-1)), 0777);
if (!is_dir($extDirPath))        return "ERROR: Could not create extension directory '".substr($extDirPath,0,(strlen($extDirPath)-1))."'";

AND around line 1676

                                 while(list(,$dirParts)=each($allDirs))        {
                                        $root.=$dirParts."/";
                                        if (!is_dir($extDirPath.$root))        {
                                                @mkdir($extDirPath.$root, 0777);
                                                if (!@is_dir($extDirPath.$root))        {
                                                        return "Error: The directory '".$extDirPath.$root."' could not be created...";
                                                }
                                        }
                                }

to

                                while(list(,$dirParts)=each($allDirs))        {
                                        $root.=$dirParts;
                                        if (!is_dir($extDirPath.$root))        {
                                                @mkdir($extDirPath.$root, 0777);
                                                if (!@is_dir($extDirPath.$root))        {
                                                        return "Error: The directory '".$extDirPath.$root."' could not be created...";
                                                }
                                        }
                                        $root.="/"; 
                                }

So the root extension dir will be created without the slash and subdirectories also.

Hope this will work for every purpose...

Viel Glück
😃

franz ferdinand ·

hm... ich habe auf einmal auch dieses problem.

mein webserver kann nicht direkt eine verbindung zum repository aufbauen also muss ich extensions von hand hochladen.

mit jb_gd_resize_1.0.5.t3x und perfectlightbox_2.2.4.t3x hat vor zwei tagen alles problemlos geklappt.

und jetzt bekomme ich mit chgallery_1.2.0.t3x die meldung: "ERROR: Could not create extension directory".

an den rechten liegt es nicht.

hat irgendwer eine idee? das mit dem slash sollte mit typo 4.2.1 doch inzwischen auch gefixt sein?