Hallo,
ich bin neu hier.
Ich habe mm_forum installiert (Ver.: 01.4) und habe Probleme bei der Suche:
Beim Indizieren kommen folgende Meldungen
Warning: Missing argument 2 for fullquotestr() in /var/www/localhost/typo3/typo3_src-4.1.1/t3lib/class.t3lib_db.php on line 553
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WER'' AND pid='58'' at line 4
und
Konnte Topic-ID 1 nicht finden1 **
Konnte Topic-ID 2 nicht finden2 **
Konnte Topic-ID 3 nicht finden3 **
Konnte Topic-ID 4 nicht finden4 **
Konnte Topic-ID 5 nicht finden5 **
....
Die Wildcard- Suche funktioniert nicht
und
wenn ein Suchergebnis gefunden wurde und angeklickt wird kommt folgende Fehlermeldung:
Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /var/www/localhost/typo3/typo3_src-4.1.1/t3lib/class.t3lib_db.php on line 796
Warning: Cannot modify header information - headers already sent by (output started at /var/www/localhost/typo3/typo3_src-4.1.1/t3lib/class.t3lib_db.php:796) in /var/www/virtualdomains/kolleg/www/typo3conf/ext/mm_forum/pi1/class.tx_mmforum_postfunctions.php on line 338
Könnt ihr helfen. Da das Forum für eine Bildungseinrichtung ist, ist die Suchfunktion sehr wichtig.
Vielen Dank!!!
Hallo,
ich benutze Typo3 4.0.2 und mm_forum 0.1.4 und erhalte dieselben Fehlerhinweise:
Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/httpd/..../t3lib/class.t3lib_db.php on line 789
Warning: Missing argument 2 for fullquotestr() in /home/httpd/..../t3lib/class.t3lib_db.php on line 552
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'HALLO'' AND pid='545'' at line 4 (das Ganze rd. 50 mal mit anderen Worten für 'HALLO')
Warning: Cannot modify header information - headers already sent by (output started at /home/httpd/..../t3lib/class.t3lib_db.php:552) in /home/httpd/..../typo3/sysext/cms/tslib/class.tslib_fe.php on line 2830
und
Konnte Topic-ID 1 nicht finden1 **
Konnte Topic-ID 2 nicht finden2 **
3 **
4 **
Die Indizierung scheint aber zu funktionieren, da Begriffe aus einem neuen Eintrag nach der Indizierung gefunden werden.
Die Wildcard-Suche funktioniert aber bei mir ebenfalls nicht.
Hat jemand eine Idee, wie die Fehler abgestellt und die Wildcard-Suche aktiviert werden können?
Vielen Dank auch von mir.
Hallo,
die SQL-Fehler konnte ich jetzt beheben (s. BugTracker http://bugs.typo3.net/view.php?id=277).
Geblieben sind die Hinweise:
Konnte Topic-ID 1 nicht finden1 **
Konnte Topic-ID 2 nicht finden2 **
3 **
4 **
Auch die Wildcard-Suche geht immer noch nicht.
Ich bin immer noch für Tipps dankbar.
Die Hinweise
Konnte Topic-ID 1 nicht finden1 **
Konnte Topic-ID 2 nicht finden2 **
Sind keine Fehler.
Das kommt von verschobenen oder gelöschten Themen.
Wenn man diese Hinweise nicht mehr haben möchte, muss man im Listmodul einerseits die ID's suchen und löschen und ebenso in der DB, zum Beispiel per phpMyAdmin, die Einträge ebenfalls löschen. Dann erscheint dies nicht mehr.
Sind keine Fehler.
Das kommt von verschobenen oder gelöschten Themen.
Soll das heissen wenn ich ein Thema lösche muss ich es per Hand aus der DB löschen?
Wenn es also keine automatische Löschroutine gibt, hört sich das für mich sehr wohl nach einem Fehler an!
Ist dir das bekannt das ziermlich viel nicht gelöscht wird, sondern nur einen delete-Flag bekommt?
Ich habe in mühsamer Kleinarbeit per phpMyAdmin die gelöschten Einträge (delete=1) in allen Tabellen des Forums gelöscht. Die Hinweise
Konnte Topic-ID 1 nicht finden1 **
Konnte Topic-ID 2 nicht finden2 **
sind dadurch tatsächlich verschwunden. Die Hinweise
3 **
4 **
erscheinen immer noch ohne dass ich weiß, woher sie stammen.
Ein weiterer Fehler in der Suche ergibt sich bei Umlauten. So wird z.B. das vorhandene Word "durchgeführt" nicht gefunden. In der Tabelle tx_mmforum_wordlist ist das Word als "DURCHGEFÜHRT" enthalten. In der Tabelle tx_mmforum_searchresults ist dagegen unter search_string nur "durchgef hrt" enthalten, das "ü" fehlt einfach. Ebenso geht es mit anderen Umlauten. Offensichtlich fehlt der Umlaut im Suchbegriff (search_string).
Außerdem funktioniert die Wildcard-Suche nicht:
Suche nach "vorgestellt" ergibt ein korrektes Ergebnis während die Suche nach "vorgest*" ohne Ergebnis bleibt.
Kann mit da jemand weiter helfen?
Vielen Dank schon jetzt.
Das sind keine Fehler. Das sind einfach nur die ID's die bei der Suche abgelaufen werden. Diese werden dann aufgelistet. 3** = ID 3 wurde gefunden und indiziert.
Danke für die Hinweise.
Kannst Du auch was zu den Fehlern?? bei den Umlauten und der Wildcard-Suche sagen?
Die Wildcardsuche funktioniert bei mir ebenfalls nicht. Soll ich es in den Bugtracker eintragen, oder machst du das selbst?
Ist dir das bekannt das ziermlich viel nicht gelöscht wird, sondern nur einen delete-Flag bekommt?
@SLAng: jupp ist mir bekannt! Daher bin ich der Meinung, diese Topics sollten bei der Auflistung auch nicht erscheinen...oder der Hinweistext sollte eindeutiger sein!
Z.B. "Konnte Topic-ID 1 nicht finden, da das Thema gelöscht oder verschoben wurde"
Gruß, Daniz
Eventuell steht das in der locallang.xml, dann kannst du es doch selbst umschreiben. Wie gewohnt eben. Außerdem sieht das sowieso nur der Admin
Der Bug bei der Indizierung
Konnte Topic-ID 1 nicht finden1 **
Konnte Topic-ID 2 nicht finden2 **
wird lt. Bugtracker in der Version Beta 0.1.5 gelöst (http://bugs.typo3.net/view.php?id=278).
Der Fehler bei der Wildcard-Suche und den deutschen Umlauten steht im Bugtracker unter http://bugs.typo3.net/view.php?id=279, ist aber derzeit noch nicht gelöst.