Zum Inhalt springen

Crawler - Authentication required

Erstellt am 12. September 2007 · 1 Antwort · letzte Antwort am 13. September 2007

Tags: Frage

Unbekannter Benutzer · · Beste Antwort

Hallo!!

habe jetzt einige Zeit lang versucht die crawler Extension anständig ans Laufen zu bekommen ... leider ohne Erfolg.

Wenn ich den Crawler installiere und konfiguriere sieht alles noch sehr gut aus. Er findet die Seiten und erstellt mir auch die URL's dazu. Diese füge ich dann zum Crawlen hinzu und über "CLI-Status" starte ich den Crawlvorgang aus dem Backend heraus. Danach braucht er zwischen 50 und 55 Sekunden bis dieser Vorgang beendet ist.
Im crawler log finde ich dann allerdings folgende Fehlermeldung:

Error: Authentication required! Authentication required! This server could not verify that you are authori...

[weiter lässt sie sich nicht lesen, weil die Spalte zu Ende ist!?]
Habe leider absolut keine Ahnung, woran das liegen könnte und hoffe dass mir jemand helfen kann ...

Noch eine kleine Anmerkung: Besuche ich die Seiten im Frontend, werden sie ohne Problem indexiert.

Grüße

Unbekannter Benutzer ·

Okay ... bin mal von den typo3 internen Dingen weggegangen und dabei ist mir das von mir eingebundene SSPI Modul für den Apache wieder eingefallen. Habe dieses dann mal nicht mitladen lassen und siehe da ... es funktioniert. Eigentlich auch ein wenig logisch ... die Seite verweigert ohne Authentifizierung jeglichen Zugriff.

Gibts da eventuell eine Möglichkeit MIT SSPI-Modul die Extension ans laufen zu bekommen!? Kann ich vielleicht irgendwo einen Benutzer mitgeben, den der Crawler dann benutzt!?