Zum Inhalt springen

RealURL

Erstellt am 11. August 2007 · 28 Antworten · letzte Antwort am 15. Dezember 2009 · Seite 2 von 2

Tags: Frage

Unbekannter Benutzer ·

Und weiter geht's:

Problem:

Wenn ich eine Seite nehme (etwa kontakt/kontakt.html) und sie verschiebe unter die Seite impressum, dann müsste sie ja zu finden sein unter impressum/kontakt.html.

An dieser Stelle bekomme ich allerdings (manchmal) einen 404er Fehler.
Stattdessen ist die Seite (manchmal) noch unter kontakt/kontakt.html erreichbar. Manchmal geht aber auch das nicht.

Den Browsercache hab ich gelehrt, den FE-Cache in Typo3 auch.

Lösung:

Speaking-Url-Management-Cache beim Löschen des "normalen" Caches mitlöschen lassen.
Mittels folgender Zeile in der ext_localconf geht das:
$TYPO3_CONF_VARS['SC_OPTIONS']['t3lib/class.t3lib_tcemain.php']['clearAllCache_additionalTables']['tx_realurl_pathcache'] = 'tx_realurl_pathcache';

Das löst das Problem insofern, als dass die Seiten jetzt alle unter ihrem richtigen (=aktuellen) Pfad und Namen gefunden werden.

(Für den Hinweis, das Problem in dieser Art zu lösen, danke ich Sebastian Fuchs.)

Es bleibt die Frage, wie clever es generell ist, diese Tabelle automatisch mitlöschen zu lassen.
Dadurch, dass sie auch alte Verweise enthält, werden Seiten ja auch an Orten gefunden, von denen ich sie eigentlich wegverschoben habe.
Ist das nicht für Google besser, als sie kommentarlos an der alten Stelle zu entfernen? (Oder schlechter, Stichwort duplicate content?)
Jedenfalls, dass es ohne die Tabelle zu leeren weder an der einen, noch an der anderen Stelle richtig funktioniert, ist schon nervig...

stephan_bauer ·

Hallo act,

ich habe es nur hiermit geschafft:

http://lists.netfielders.de/pipermail/typo3-at/2005-August/006746.html

Grüße

Stephan

actraiser schrieb

hallo, danke für die anleitung!

Kann man auch einen Ordner überspringen in der Anzeige?

Ich habe folgende Struktur

seiten (als Knoten quasi zur Strukturierung im Backend)
seiten/kontakt
seiten/impressum
seiten/feedback

Seit dem Update von RealURL 0.3.0 auf die aktuelle Version 1.1.4 rendert RealURL die Seiten folgendermassen:

http://www.website.de/seiten/kontakt.html

Mit RealURL 0.3.0 wird das gewünschte Ergebnis ausgebeben:

http://www.website.de/kontakt.html

Ich bin mir jetzt nicht sicher ob hier die Konfiguration das Problem ist oder ob RealURL 0.3.0 das Ganze einfach anders gehandhabt hat.

Grüße
-act

Gjergj ·

#angry# #angry# #angry# #angry# #angry# #angry# #angry# #angry# #angry# #angry# #angry# #angry#

...ich habe es geschaft der T_STRING-Fehler kommt nicht mehr, dafür aber jetzt

*****************************************************************************************************
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete
your request.
Please contact the server administrator, [no address given] and inform them of the
time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
*****************************************************************************************************

Gruß

Gjergj

Gjergj ·

HILFE!!! HILFE!!! HILFE!!! HILFE!!! HILFE!!! HILFE!!! 😢 HILFE!!! HILFE!!! HILFE!!! HILFE!!! HILFE!!!

Unbekannter Benutzer ·

Tut mir leid, meine Wahrsagerkugel ist leider gerade nicht da.

Aber vielleicht könntest du wirklich (also mein ich jetzt echt!) (noch)mal überprüfen, ob du ALLES genau so gemacht hast, wie ich es hier beschrieben habe.

Bitte bei POST 1 anfangen!

Ich sag nur: In meiner ext_localconf fehlte keine Klammer... #angry#

Gjergj ·

Hallo Leute, also das ist meine .htaccess-datei!

RewriteEngine On
Options +FollowSymLinks

RewriteBase /

RewriteRule ^typo3$ - [L]
RewriteRule ^typo3/.*$ - [L]

RewriteRule ^(typo3|banner|typo3temp|typo3conf|t3lib|tslib|fileadmin|uploads|showpic\.php)/ - [L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

RewriteRule (\.html|/)$ index.php

RewriteRule .* index.php

PATH_thisScript: /kunden/kundenummer/FTP-Ordner/typo3/typo3/install/index.php

Der Fehler:
*****************************************************************************************************
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete
your request.
Please contact the server administrator, [no address given] and inform them of the
time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
*****************************************************************************************************

...also wenn ich diese funktionen ausschalte, kommt der fehler nicht mehr!!!
RewriteBase /
RewriteRule ^(typo3|banner|typo3temp|typo3conf|t3lib|tslib|fileadmin|uploads|showpic\.php)/ - [L]

es muss also am Pfad liegen!!

PATH_thisScript: /kunden/kundenummer/FTP-Ordner/typo3/typo3/install/index.php

..und glaubt mir ich habe schon so gut wie alle pfad-variationen ausprobiert!!

kann mir jemand helfen, bevor ich mir einen headshot gebe?

Unbekannter Benutzer ·

Wenn ich mir deinen Pfad anschaue, dann hast du auf deinem Webspace einen Ordner typo3 erstellt.
Darein hast du dann alle Dateien aus typo3 installiert, richtig?

Wo liegt denn die .htaccess-Datei, deren Inhalt du gepostet hast?
Wo sie liegen muss siehe Post vom 24.8. 3:33 Uhr.

In deinem TypoScript muss der Eintrag für den base-Tag angepasst werden und zwar auf folgenden Wert:
http://www.example.com/typo3/

Weiter: Ins Backend einloggen kannst du dich aber?
Dann lösch da beide Caches.

Gjergj ·

OOOOOOOOOOOOOOO GGGGGGGGGGGGGOOOOOOOOOOOOOTTTTTTTTTTTTTT, ich werden verrückt

Chrissitopher my Friend ich brauche deine Hilfe,

....also meine domain zeigt auf: /FTP-Ordner/typo3

Bsp.: PATH_thisScript: /kunden/kundenummer/FTP-Ordner/typo3*/typo3/install/index.php

in diesem typo3 ordner befindet sich die .htaccess*-Datei

.htaccess_________________________________________________
RewriteEngine On
Options +FollowSymLinks

RewriteBase /

RewriteRule ^typo3$ - [L]
RewriteRule ^typo3/.*$ - [L]

RewriteRule ^(typo3|banner|typo3temp|typo3conf|t3lib|tslib|fileadmin|uploads|showpic\.php)/ - [L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

RewriteRule (\.html|/)$ index.php

#RewriteRule .* index.php
_____________________________________________________________

Typoscript___________________________________________________
# RealURL aktivieren
config.simulateStaticDocuments = 0
config.baseURL = http://meinedomain.com/typo3/
config.tx_realurl_enable = 1
config.prefixLocalAnchors = all

# Default PAGE object:
page = PAGE
page.10 = TEXT
page.10.value = HELLO WORLD!
_______________________________________________________________

ext_localconf.php______________________________________________

<?php
$TYPO3_CONF_VARS['SC_OPTIONS'] ['t3lib/class.t3lib_tstemplate.php'] ['linkData-PostProc'] []
= 'EXT:realurl/class.tx_realurl.php:&tx_realurl->encodeSpURL';
$TYPO3_CONF_VARS['SC_OPTIONS'] ['tslib/class.tslib_fe.php'] ['checkAlternativeIdMethods-PostProc'] []
= 'EXT:realurl/class.tx_realurl.php:&tx_realurl->decodeSpURL';
$TYPO3_CONF_VARS['SC_OPTIONS'] ['t3lib/class.t3lib_tcemain.php'] ['clearAllCache_additionalTables'] ['tx_realurl_urldecodecache']
= 'tx_realurl_urldecodecache';
$TYPO3_CONF_VARS['SC_OPTIONS'] ['t3lib/class.t3lib_tcemain.php'] ['clearAllCache_additionalTables'] ['tx_realurl_urlencodecache']
= 'tx_realurl_urlencodecache';
$TYPO3_CONF_VARS['FE'] ['addRootLineFields'] .=
',tx_realurl_pathsegment,alias,nav_title,title';
$TYPO3_CONF_VARS['EXTCONF'] ['realurl'] ['_DEFAULT'] = array(
'init' => array(
'enableCHashCache' => 1,
'enableUrlDecodeCache' => 1,
'enableUrlEncodeHash' => 1,
// 'postVarSet_failureMode' => 'redirect_goodUpperDir',
),
'rewrite' => array(
),
'preVars' => array(
/*
array(
'GETvar' => 'L',
'valueMap' => array(
'de' => '0',
'en' => '1',
),
'valueDefault' => 'de',
),
*/
),
'pagePath' => array(
'type' => 'user',
'userFunc' => 'EXT:realurl/class.tx_realurl_advanced.php:&tx_realurl_advanced->main',
'spaceCharacter' => '-',
'languageGetVar' => 'L',
'expireDays' => 3,
'rootpage_id' => '1'
),
'fileName' => array (
'defaultToHTMLsuffixOnPrev' => 1,
'index' => array(
'page.html' => array(
'keyValues' => array (
'type' => 1,
),
),
),
),
'fixedPostVarSets' => array(
),
'postVarSets' => array(
'_DEFAULT' => array(
//archive
'period' => array (
array (
'condPrevValue' => -1,
'GETvar' => 'tx_ttnews[pS]',
//'valueMap => array()
),
array (
'GETvar' => 'tx_ttnews[pL]',
//'valueMap => array()
),

array (
'GETvar' => 'tx_ttnews[arc]',
'valueMap' => array(
'non-archived' => -1,
),
),
),

'browse' => array (
array (
'GETvar' => 'tx_ttnews[pointer]',
),
),
'select' => array (
array (
'GETvar' => 'tx_ttnews[cat]',
'lookUpTable' => array (
'table' => 'tt_news_cat',
'id_field' => 'uid',
'alias_field' => 'title',
'addWhereClause'=> 'AND NOT deleted',
'useUniqueCache'=> 1,
'useUniqueCache_conf' => array (
'strtolower' => 1,
'spaceCharacter' => '-',
),
),
),
),
'article' => array( 
array (
'GETvar' => 'tx_ttnews[backPid]',
// 'valueMap => array(
// ),
),
array (
'GETvar' => 'tx_ttnews[tt_news]',
'lookUpTable' => array (
'table' => 'tt_news',
'id_field' => 'uid',
'alias_field' => 'title',
'maxLength' => 12,
'addWhereClause'=> 'AND NOT deleted',
'useUniqueCache'=> 1,
'useUniqueCache_conf' => array (
'strtolower' => 1,
'spaceCharacter' => '-',
),
),
),
),
),
), 
);
?>

PS: Ich bin bei domainfactory.de, falls es hilft.

Gruß

Gjergj

Darthstar ·

gobt es denn mittlerweile eine Lösung?
Ich bekomme nur 404 seit installation (und konfiguration nach diesem Script) von RealURL

laymore ·

HALLO Freunde!!! *Strahl*

Ne jetzt mal im ernst:
Ich habe mich lange daran aufgehalten, dass ich nicht gecheckt habe was manch anderem wohl selbstverständlich erscheint. Ich bin eine ganze Weile gaaaaanz nah an der Lösung dran gewesen und habs einfach nicht gecheckt:
Die _.htaccess muss in .htaccess umbenannt werden. Ohne die Umbenennung gibts bei mir auch einen 404 Fehler, da die _.htaccess nicht zurate gezogen wird sondern für den Server nur irgendeine Datei ist.

Dabei ist vielleicht folgende Randinformation für Anfänger (wie mich) ganz hilfreich:
Dateien die mit einem Punkt im Namen beginnen, werdem von manchen Systemen versteckt. Das kann bei der Umbenennung wie oben beschrieben natürlich dazu führen, dass es zu Verwirrungen kommt. Dies ist einerseits eine serverseitige konfiguration ABER kann auch durch die üblichen Optionen im Dateimanager (FTP-Programm) beeinflusst werden.

Hoffentlich bringts jemandem was. Für mich waren genau diese Infos von Bedeutung .

Wizard2003 ·

Hallo,

habe Typo3 4.0.8 und realUrl 1.3.1 und einen komischen Effekt.

root (ID=1)
|- Startseite (ID=7)
|- Seite2
|- Menü unten
| |- Kontakt (ID=3)
| |- Impressum

Die Seiten in der ersten Ebene (Startseite, Seite2) werden richtig angezeigt:
also http://www.bla.de/startseite.html

Die Seiten in dem Untermenü leider nicht (also Kontakt, etc.). Diese werden folgendermaßen angezeigt:
http://www.bla.de/.html

In der config habe ich 'rootpage_id' => '1' gesetzt

Was mach ich falsch?

laymore ·
Chrissitopher schrieb

[...]
Meine .htaccess:

RewriteEngine On
Options +FollowSymLinks

RewriteBase /

RewriteRule ^typo3$ - [L]
RewriteRule ^typo3/.*$ - [L]

RewriteRule ^(typo3|banner|typo3temp|typo3conf|t3lib|tslib|fileadmin|uploads|showpic\.php)/ 	- [L] 

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

RewriteRule (\.html|/)$ index.php

#RewriteRule .* index.php

[...]

So nachdem es bei mir ja offenkundig funktionierte hab ich hier und da doch einen Fehler feststellen müssen:

Ich in meinem Projekt intern eine Verschachtelung vorgesehen, die einen Ordner "Hauptmenue" und einen Ordner "Untermenue" vorsieht. Diese Ordner sind ja nun Teil der URL (z.B.: www.meineseite.de/hauptmenue/unterpunkt1.html)
Wenn ich den entsprechenden Link im Hauptmenue betätige, der intern im Ordner Hauptmenue liegt, wird folgende URL erzeugt: www.meineseite.de/null/unterpunkt1.html
Diese Seite kann natürlich nicht gefunden werden also läuft irgendwo was schief.
Mir ist bei der Fehlersuche das Hash in der letzten Zeile des Zitats aufgefallen. Ist das eine mögliche Ursache?

saschasch ·

Moin moin,

ich habe heute auch mal RealURL installiert. Aber ich bekomme das noch nicht ganz so hin.
Meine URLs sehen jetzt so auch:
www.url.de/meintyp/{ID} aber ich bekomme die Seiten Title nicht mit rein und auch kein .html

....

vllt. habt ihr ja ein Tipps für mich... Danke