Zum Inhalt springen

LDAP Sync

Erstellt am 15. Juli 2006 · 1 Antwort · letzte Antwort am 20. Juli 2006

Tags: Frage

briem ·

Hallo ich bekomme beim Versuch der Synchronisierung von FE Usern mit unserem AD den Fehler

Unable to bind Server.

Weiß jemand rat?

Mein System: w2k3, php 5, typo3 3.8.1

#angry#

briem ·

Problem ist gelöst,

allerdings habe ich nun das nächste.

Der automatische FE Login geht noch nicht, die User müssen sich noch mit Ihrem AD Login einloggen.

Habe aber folgende Extensions installiert

ldap_lib
ldap_server
ldap_sync
eu_ldap

Mein TS

FEusers = LDAP_SYNC
FEusers {
enable = 1
table = fe_users
basedn = OU=Benutzer, OU=Basis, DC=test, DC=local
handleNotFound = 1
handleNotFound {
markHidden = 1
hiddenField = disable
markDeleted = 0
deletedField = deleted
delete = 0
identField = username
}
pid = 33
filter = (&(objectClass=person))
uniqueField = tx_ldapserver_dn
fields {
username = MAP_OBJECT
username.attribute = sAMAccountName
username.userFunc = tx_ldapserver->getSingleValue

tx_ldapserver_dn = MAP_OBJECT
tx_ldapserver_dn.special = DN

usergroup = MAP_OBJECT
usergroup {
attribute = memberOf
userFunc = tx_ldapserver->getFEGroups
userFunc.pid = 33
}
}
}

FEgroups < FEusers
FEgroups {
table = fe_groups
handleNotFound = 0
filter = (&(objectClass=group))
fields {
username >
usergroup >
title = MAP_OBJECT
title.attribute = cn
title.userFunc = tx_ldapserver->getSingleValue
}
}

BEusers < FEusers
BEusers {
table = be_users
pid = root
handleNotFound = 0
filter = (&(objectClass=person)(description=BE_USER))
fields.usergroup.userFunc = tx_ldapserver->getBEGroups
}

BEgroups < FEgroups
BEgroups {
table = be_groups
pid = root
filter = (&(objectClass=group)(description=BE_GROUP))
}

FEauth = LDAP_AUTH
FEauth {
enable = 1
table = fe_users
SSO = 1
SSO.10.userFunc = tx_ldapauth_sv1->authFromGet
sync < FEusers

}

BEauth < FEauth
BEauth {
table = be_users
sync < BEusers
}

Bitte um Hilfe