Zum Inhalt springen

CLI Mode und BE-User

Erstellt am 20. April 2006 · 2 Antworten · letzte Antwort am 20. April 2006

Tags: Frage

Newtyp ·

Hallo,

Ich versuche das einlesen neuer Dokumente der danp_documentdirs – Extension per externen Script anzustoßen.
Dazu betreibe ich die Extension im CLI-Mode wie hier beschrieben:
http://typo3.org/documentation/document-library/core-documentation/doc_core_inside/current/view/3/5/

Wie beschrieben hab ich folgende Zeilen in die index.php dieser Extension geschrieben:

define('TYPO3_cliMode', TRUE);
define('PATH_thisScript', "/var/www/…");
require(dirname(PATH_thisScript).'/conf.php');
require(dirname(PATH_thisScript).'/'.$BACK_PATH.'init.php');

Weiters muss in der conf.php $MCONF[„NAME“] der Name eines nicht Admin BE users mit _CLI_ davor zugewiesen werden.
Wie aus der Doku hervorgeht muss der Name des BE Users gleich dem Extensionkey sein, also in meinem Fall wäre das dann $MCONF["name"]="_CLI_danp_documentdirs";
Nur kann ich leider im Typo3 BE keinen BE-User mit so einem langen Namen anlegen.
Offenbar darf der Name eines BE-Users nicht länger als 20 Zeichen sein.
Kann man das irgendwo änder?

Erstelle ich einen „CLI-BE-user“ mit andern Namen als der Extensionkey, z.B. _CLI_danp kommt folgende Fehlermeldung:

Fatal Error

This module "_CLI_danp" is not enabled in TBE_MODULES

Also muss der Name des Users gleich dem Extensionkey sein, nur leider ist dieser Name dann zu lang.

Kann die max. Länge des BE-Usernamens geändert werden, hat jemand Erfahrung mit so was, oder bin ich vielleicht überhaupt am falschen Dampfer?

Vielen Dank!

mfg

just2b ·

die suche im Repository wäre EINIGES schneller gewesen als hier den Text zu schreiben.

such mal nach: be user longer

lg georg

Newtyp ·

Danke das war was ich brauchte!
Wäre wirklich schneller gewesen :-), wäre aber nicht auf die Idee gekommen das es dazu einen Extension gibt.

Nur leider hat das doch nicht mein Problem mit dem CLI-Mode gelöst.
Hab jetzt einen BE User mit folgeden Namen angelegt:
_cli_danp_documentdirs
In der conf.php hab ich folgendes:
$MCONF["name"]="_CLI_danp_documentdirs";

Wenn ich jetzt die index.php aus der shell aufrufe kommt dennoch wieder der Fehler:
Fatal Error

This module "_CLI_danp_documentdirs" is not enabled in TBE_MODULES

Hat jemande einen Idee was ich da falsch mache? Was sagt mir die Fehlermeldung?

Danke!

mfg