Zum Inhalt springen

AW Stats Problem

Erstellt am 3. Dezember 2005 · 9 Antworten · letzte Antwort am 19. September 2006

Tags: Frage

tschinschiri ·

Ich weis ich bin nicht der erste, doch habe ich auch mit hilfe der anderen Beiträge das Tool nicht zum laufen gebracht.

Also ich habe folgendes:

in localconf:

$TYPO3_CONF_VARS["FE"]["logfile_dir"] = 'fileadmin/';

$TYPO3_CONF_VARS["BE"]["unzip_path"] = '/usr/bin/'; 
$TYPO3_CONF_VARS["BE"]["warning_email_addr"] = 'root@localhost'; 
$TYPO3_CONF_VARS["FE"]["tidy"] = '1'; 
$TYPO3_CONF_VARS["FE"]["publish_dir"] = 'publish/';

im Template:

# für AWstats - Einträge
config.stat = 1
config.stat_apache = 1
config.stat_apache_logfile = fileadmin/access.log
config.stat_mysql = 0
#------------------------------
# Darstellung der Seite

Die Datei access.log ist im Fileadmin Ordner angelegt und Chmod 777 gesetzt.

AW Stats gibt mir aber jezt keine Bewegungen zurück. Wo liegt mein Fehler?

Komme da nicht mehr weiter. #angry#

PS Im BE habe ich die Datei access.log auch editirt und meine Homepage angegeben.

seve1980 ·

Hallo,
ich hoffe folgendes Hift dir weiter. Ich habe folgenden Code in mein Tamplate eingefügt:

config.stat = 1
config.stat_apache = 1
config.stat_apache_logfile =logfile.txt

Dann muss man nur noch eine Datei in einem Verzeichnis erstellen wo er die Infos hinschreiben soll. Bei mir was das "fileadmin\log\logfile.txt" Wenn man dann das AW Stat anklickt, dann den Pfad eintippt den wo das Logfile ligt, dann müsste es funktionieren. Um dann noch ergebnise zu bekommen musst du dich aus dem Backend abmelden denn wenn du eingeloggt bist, dann werden keine Statistiken geschrieben. oder nimm einfach wenn du mit IE eingeloggt bist denn Firefox, dann schreibt er auch was rein.

Ich hoffe es hilft dir weiter wenn nicht, dann melde dich einfach nochmal

Focus3 ·

Hi,
ich habe ähnlich Probleme mit awstats - folgenden Fehler bekomme ich:

Perl was not found at '/usr/local/bin/perl'. The awstats.pl script can't be executed!

Ich kann sogar das Logfile auswählen und die Domain eintragen, aber wenn ich mir die Statistik anschauen will kommt obiger Fehler.

Habe sowas auch ausprobiert, nur danach zeigt er mir eine leere weiße Seite #paralyzed#
#320004

Kann jemand helfen???

tschinschiri ·

Hallo Seve 1980

Leider hat dein Tip nichts geholfen. Ich hab nur noch ein zusätzliches Logfile erhalten, welches ebenfals keine Daten auswirtft. Bin etwas am verzeiveln, denn ich müsste den Traffic auf der Seite verfolgen können um meine Werbun besser Vermarkten zu können. Vieleicht hat aber noch jemand verständnis für meine Frage und weis auch eine Antwort darauf.

Also ich bekomme mit meinen Einstellungen die Logfiles und kann auch die Page definieren, welche verfolgt werden soll. Wenn ich mich nun aus dem BE auslogge und auf der Seite rum klicke und danach das File wieder anschaue und auch aktualisiere bekomme ich keine Infos nur den ausdruck:

No qualified records found in log (0 corrupted, 0 dropped)

Weis da keiner ABhilfe? hab so ziehmlich alles versucht...

Danke ihr seid Helden #giggle#

steffenk ·
Focus3 schrieb

Hi,
ich habe ähnlich Probleme mit awstats - folgenden Fehler bekomme ich:

Perl was not found at '/usr/local/bin/perl'. The awstats.pl script can't be executed!

Ich kann sogar das Logfile auswählen und die Domain eintragen, aber wenn ich mir die Statistik anschauen will kommt obiger Fehler.
...Kann jemand helfen???

Dann hast Du eine ungewöhnliche Konstellation 🙂

öffne das Perlfile (awstats.pl o.ä.) und trag in die erste Zeile den richtigen Pfad zu perl ein.

tschinschiri ·

Hab mein Problem gelöst!

Hab die Extension nochmals entfernt und zuerst alles Konfiguriert im TS gemacht. dnn die dateien anlegen und erst dann die Extension installieren.

Hoffe das kann weiter helfen...

Grüsse Tschinschiri

Focus3 ·

Hallo Steffen,
danke für die Hilfe, nur leider klappt es nicht so richtig. Habs geändert auf /usr/local/bin/perl, /usr/bin/perl oder /usr/bin/perl leider immer die gleiche Meldung. Habs sogar im Confixx Perl außerhalb ausgewählt - klappt auch nicht. Vielleicht liegt es ja auch an der Php version 5.0.4 oder am open_basedir set.

Sailor ·

Hallo zusammen,

hatte auch Probleme mit Awstat aber der folgende Link:
http://www.kyt.ch/190.html
hat meine Probleme gelöst. Auf der Seite ist eine super Erklärung, insbesondere wenn man Fehlermeldungen bekommt....hatte sogut wie alle dabei. #angry# :p
Insbeondere der Hinweis:
----------------------------
2. Datei 'cc_awstats/mod1/index.php' anpassen

Die Datei lokal in einem Editor öffnen oder via Typo3-Backend editieren (dazu ev. im Bereich der Installation die Berechtigung für das Editieren aktivieren [noEdit =0])

Die Zeilen 242 - 264 auskommentieren (nachfolgend rot dargestellte Zeichen einfügen):
------------------------------

Gruß Sailer Kim