Zum Inhalt springen

index.php

Erstellt am 12. November 2005 · 14 Antworten · letzte Antwort am 22. November 2005

Tags: Frage

Norman2k ·

Lokalen Server installiert und gestartet? So wie sich es anhört arbeitest du ja lokal oder?
-> http://localhost/ -> Herzlich Wilkommen ... bla bla

Das Windows Dummy Paket (Zip-Datei!!!) in C:\Programme\xampp\htdocs\ entpackt?

Die "die-Funktion" in C:\Programme\xampp\htdocs\dummy-3.8.0\typo3\install\index.php auskommentiert? Braucht man aber eigentlich nicht machen wenn man lokal arbeitet.

<?php
	// This checks for my own IP at home. You can just remove the if-statement.
if (1==0 || (substr($_SERVER['REMOTE_ADDR'],0,7)!='192.168' && $_SERVER['REMOTE_ADDR']!='127.0.0.1'))		{
//	die("In the source distribution of TYPO3, the install script is disabled by a die() function call.<br /><b>Fix:</b> Open the file typo3/install/index.php and remove/out-comment the line that outputs this message!");
}
?>

Dann http://localhost/dummy-3.8.0/typo3/install/ im Browser aufrufen und gucken was passiert

Die Pfade können bei dir natürlich etwas anders aussehen!

Norman

virus1963 ·

leider fehlanzeige! es erscheint:
Objekt nicht gefunden!

Der angeforderte URL konnte auf dem Server nicht gefunden werden. Sofern Sie den URL manuell eingegeben haben, überprüfen Sie bitte die Schreibweise und versuchen Sie es erneut.

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
Error 404
localhost
13.11.2005 19:36:16
Apache/2.0.55 (Win32) mod_ssl/2.0.55 OpenSSL/0.9.8a PHP/5.0.5 mod_python/3.1.3 Python/2.3.5 mod_autoindex_color mod_jk2/2.0.4 mod_perl/2.0.1 Perl/v5.8.7

mehr tut sich leider nicht

Norman2k ·

Läuft der Server, d.h. siehst du eine Willkommens-Seite wenn du http://localhost/ aufrufst?
Bitte ankreuzen: []Ja []Nein

Guck in den Ordner htdocs, da sollte ein Ordner drin sein wo dein Typo3 enthalten ist. Klick dich solange durch bis du eine "index.php" findest.
Bitte ankreuzen []..\xampp\htdocs\dummy-3.8.0\index.php []..\xampp\htdocs\typo3\dummy-3.8.0\index.php []..\xampp\htdocs\Irgend ein Ordner wo deine Typo3-Installation drin ist\index.php

Wenn dein Pfad z.B. so aussieht "..\xampp\htdocs\dummy-3.8.0\index.php", dann ruf im Browser mal folgende Adresse auf: http://localhost/dummy-3.8.0/
Was siehst du dann:
Bitte ankreuzen: []Fehlermeldung "Objekt kann nicht gefunden werden" []Typo3-Fehlermeldung "Error! No pages are found on the rootlevel!" (oder so ähnlich)

Norman

Bebbi ·

...dann wird wohl der Pfad nicht stimmen.

Kommt die gleiche Meldung, wenn du nur "http://localhost" in den Browser eingibst?

-> Wie sieht deine Struktur auf dem Laufwerk aus?
- apache
- htdocs
--> Typo3 Ordner

Gruss

Bebbi

virus1963 ·

Läuft der Server, d.h. siehst du eine Willkommens-Seite wenn du http://localhost/ aufrufst?
Bitte ankreuzen: [X]Ja []Nein

Guck in den Ordner htdocs, da sollte ein Ordner drin sein wo dein Typo3 enthalten ist. Klick dich solange durch bis du eine "index.php" findest.
Bitte ankreuzen []..\xampp\htdocs\dummy-3.8.0\index.php []..\xampp\htdocs\typo3\dummy-3.8.0\index.php []..\xampp\htdocs\Irgend ein Ordner wo deine
[x]..\xampp\htdocs\dummy-3.8.0\typo3\install
Typo3-Installation drin ist\index.php

Wenn dein Pfad z.B. so aussieht "..\xampp\htdocs\dummy-3.8.0\index.php", dann ruf im Browser mal folgende Adresse auf: http://localhost/dummy-3.8.0/
Was siehst du dann:
Bitte ankreuzen: []Fehlermeldung "Objekt kann nicht gefunden werden" [x]Typo3-Fehlermeldung "Error! No pages are found on the rootlevel!" (oder so ähnlich)

FEHLERMELDUNG:
Wenn ich den Pfad http://localhost/dummy-3.8.0/ im Browser eingebe erscheint in der Adressleiste:
http://localhost/dummy-3.8.0/typo3/install/index.php?mode=123&step=1&password=joh316

und die Fehlermeldung
Parse error: parse error, unexpected '/' in K:\SERVER\xampp\htdocs\dummy-3.8.0\typo3\install\index.php on line 2

liebe grüße

Wolfi (virus1963)

Bebbi ·

das sieht doch schon viel besser aus...

ist "index.php" die Datei, welche du vorgängig verändert hast? (die()funktion) Falls ja, versuche es mal mit der alten, original Version. Eventuell hast du was falsches ausgeklammert.

Gruss

Bebbi

virus1963 ·

Jetzt komm ich schon zur Anmeldemaske!!!
Aber er nimmt den User"admin" und das Password "password" nicht!

Warning: mysql_pconnect() [function.mysql-pconnect]: Access denied for user 'admin'@'localhost' (using password: YES) in K:\SERVER\xampp\htdocs\dummy-3.8.0\typo3\t3lib\class.t3lib_db.php on line 831

Warning: mysql_list_tables(): supplied argument is not a valid MySQL-Link resource in K:\SERVER\xampp\htdocs\dummy-3.8.0\typo3\t3lib\class.t3lib_db.php on line 892

Warning: mysql_pconnect() [function.mysql-pconnect]: Access denied for user 'admin'@'localhost' (using password: YES) in K:\SERVER\xampp\htdocs\dummy-3.8.0\typo3\t3lib\class.t3lib_db.php on line 831
TYPO3 3.8.0 Install Tool
Site: Blank DUMMY

Database

There is no connection to the database!
(Username: admin, Password: password, Host: localhost).

Go to Step 1 and enter a proper username/password!

NOTICE: Install Tool is running in '123' mode. Click here to disable.

Norman2k ·

Das lesen übernehme ich aber nicht für dich! Da stand doch bestimmt "Type in your database parameters here:". Das sind die Zugangsdaten zu deiner Datenbank, nicht für Typo3. Hast du schon eine Datenbank angelegt? Sagt dir phpMyAdmin etwas?

Norman

Frankenfurter ·

Hallo Liebe Leute,
bitte könnt ihr mir helfen.

Habe Typo3 installiert, den apache gestarte, mysql gestartet,
meinen Browser gestartet... localhost eingegeben und .....nix
Gehe ich im Programmverzeichnis Typo3 .Installtool und rufe es auf

Bekomme ich folgende Meldung: wollen sie diese index.php
auf der festplatte speichern ?

Ich weis bald nicht mehr weiter. Ichbe sicherlich alles eindutzendmal
installiert und deinstalliert.

Würde mich über hilfe freuen

LG

Frankenfurter

hamoda108 ·

Ich stand auch lange vor dem 1-2-3 Tool und kam nicht in die Datenbank rein. Mir war nicht klar, dass das Formular für Benutzername/Passwort auf der ersten Seite des Tools dafür da ist, die bereits bei der Einrichtung der Datenbank (geschieht z.B automatisch beim Einrichten von XAMPP/WAMP/LAMP) vergebenen Zugangsdaten lediglich anzugeben, 1-2-3 sozusagen über diese Daten zu informieren.

Also einfach dieselben Daten eingeben, die man für den Datenbankzugriff bereits bei der Einrichtung des Datenbankservers (z.B. mySQL) vergeben hat.

Ich hatte fälschlicherweise immer angenommen, dass man diese Daten hier erst neu festlegt. Hinterher erscheint es natürlich logisch, aber auch angesichts der häufigen Einträge zu diesem Thema im Forum ist das im Installationsmanual von TYPO3 bzw. im 1-2-3 Tool einfach nicht eindeutig genug beschrieben. Ein einfacher Satz zu diesem Login würde viel Kopfzerbrechen sparen.

Alles Gute
hamoda