Zum Inhalt springen

Problem mit Fehlerseiten

Erstellt am 6. Oktober 2004 · 1 Antwort · letzte Antwort am 6. Oktober 2004

Tags: Frage

JMS ·

Hallo zusammen,

heute abend habe ich mir meine Webseitenstatistik angeguckt und festgestellt, dass Seiten aufgerufen worden sind, die eigentlich garnicht mehr existieren. (Ursprüngliche Dateien wurden nach Umstellung auf typo gelöscht, ich schätze, dass der Aufruf aus einer veraltete Bookmarkliste resultiert, oder ein Robot?)
Jedenfalls habe ich diese vermeintlichen Seiten dann direkt aufgerufen und festgestellt, dass die in der htaccess als Ziel definierte HTML-Datei nicht mehr aufgerufen wird. Stattdessen kommt die eigentliche Startseite mit falschen Pfaden zum css und den Grafiken... sieht ganz toll aus!

Nun denn.. ich habe die htaccess noch mal geprüft, im Backend das Error-Handling geändert, gemacht und getan, immer wieder den Cache gelöscht.... immer ohne Erfolg.

Nun habe ich folgendes festgestellt:

Rufe ich eine Seite auf, die laut URL direkt auf dem Root liegt
(z.B. http://www.meine-domain.de/kkdgs87998d.htm), so erscheint die gewünschte Fehlerseite,

sobald aber ein Unterverzeichnis in der URL steht,
(z.B. http://www.meine-domain.de/SUBDIR/kkdgs87998d.htm),

dann baut typo die eigentliche Startseite (Home) auf, allerdings mit fehlerhaften Pfaden. Ihr könnt Euch vorstellen, wie bescheiden das aussieht....

Achso...
ich verwende typo370, simulate static ist aktiviert und funzt einwandfrei...

Kann mir jemand helfen?

Grüße aus KA

JMS

JMS ·

Tja... nun muss ich mir schon selbst antworten 😉

Also... das Problem ist gelöst... die im 370-Dummy-Paket enthaltene htaccess funzt nicht!

Hab' nun die htaccess wie folgt geändert:

RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule   ^typo3$  typo3/index_re.php
RewriteRule   ^[^/]*.html$  index.php


ErrorDocument 300  http://www.meine-domain.de/
ErrorDocument 401  http://www.meine-domain.de/
ErrorDocument 403  http://www.meine-domain.de/
ErrorDocument 404  http://www.meine-domain.de/
ErrorDocument 500  http://www.meine-domain.de/

AddHandler php-fastcgi .php .php4

Und nun tut's wieder... wer nun eine Seite besuchen will, die nicht mehr existiert, kommt nun automatisch auf den Root zurück. 😃

Und nochmal....Grüße aus KA

JMS