Die Dateiattribute (chmod) liegen beim Verzeichniss und den drei Dateien combine, convert und identify momentan auf 777. Ich habe da schon sehr viele chmod-Einstellungen ausprobiert.
Wie ist "not gesetzt werden" gemeint?
BTW: ich habe aus lauter Verzweiflung IM auf einen Schlund-Server gepackt. Dort habe ich die Image Gallery laufen und er konnte IM mit dem dortigen Pfad finden. Allerdings beim Verkleinern der Bilder kommt die Meldung "Fehler beim Konvertieren der Bild-Datei!"
ups, sollte "noch" statt "not" heissen....
Ansonsten weiss ich dann auch nicht mehr weiter...
Jochen Weiland
Trotzdem danke. 😉 Ich hoffe, ich bekomme weiter Hilfe.
Grüße aus Lübeck
Dirk
Hast du den Pfad im IM-Wrapper-Skript unter ./bin/wrapper.sh angepaßt? Voreingestellt ist nämlich "/usr/local/image...", was auf deinem webspace sicher nicht der Installationspfad ist.
Du müßtest also /is/htdocs/meine_Kundennummer/www.meine_domain.de/IM_Verzeichnis/
eintragen.
Bei mir hat zumindest Typo3 nach dieser Anpassung das Imagamagick erkannt.
Beste Grüße,
Oliver
Hallo Oliver,
ich gebe es zu, ...an den Pfad in der wrabber.sh habe ich nicht gedacht. Jetzt ist aber auch das geändert, brachte nur leider auch nicht den Erfolg.
Ist chmod 777 denn auf jeden Fall okay?
EDIT:
Ich habe IM jetzt auch noch auf einen anderen Server mit der Image Gallery getestet: erkannt wird IM von dem Programm, nur kommt es z.B. beim verkleinern der Bilder zum Fehler. Leider ist die Fehlermeldung nicht gerade sehr aussagekräftig: "Fehler beim Konvertieren der Bild-Datei!"
Gruß Dirk
Ja, mit CHMOD 777 gibt du Allen Lese, Schreibe und v.a. Ausführungsrechte. Daran sollte es also nicht liegen.
Hast du Shell-Zugang zu dem Server? Dann könntest du mal im bin-Verzeichnis von Imagamagick direkt z.B. ./convert aufrufen. Vielleicht gibt es dann eine aussagekräftige Fehlermeldung.
Oliver
Hallo,
auf http://typo3.sunsite.dk/software/linux/ findest Du im Verzeichnis 'old/' noch die alte Version, die noch ohne den Wrapper arbeitete.
Funktionierts damit?
Gruss, michael
Hallo Michael,
mit dieser Version hat es endlich geklappt. 🙂 Danke für den Tipp!
Hier noch ein Auszug aus meiner localconf.php
.
.
.
$TYPO3_CONF_VARS["GFX"]["im"] = '0';
$TYPO3_CONF_VARS["GFX"]["im_combine_filename"] = 'combine';
$TYPO3_CONF_VARS["GFX"]["im_path"] = '/is/htdocs/xxx/www.xxxxx.de/imagemagick-4.2.9/';
$TYPO3_CONF_VARS["GFX"]["im_path_lzw"] = '';
.
.
.
$TYPO3_CONF_VARS["GFX"]["im_path_lzw"] = '/is/htdocs/xxx/www.xxxxx.de/imagemagick-4.2.9/';
$TYPO3_CONF_VARS["GFX"]["im_path"] = '/is/htdocs/xxx/www.xxxxx.de/imagemagick-4.2.9/';
$TYPO3_CONF_VARS["GFX"]["im_combine_filename"] = 'combine';
$TYPO3_CONF_VARS["GFX"]["im"] = '1';
// Updated by TYPO3 Install Tool 11-05-2004 10:30:41
?>
Ist das alles so korrekt?
Achja, passt zwar hier nicht rein, aber beim austesten von IM ist mir aufgefallen, dass Typo3 mir nicht die Thumbs vergrößern wollte. Er vermisst die showpic.php. Diese habe ich jetzt ins Root-Verzeichnis gepackt. Wohl nicht so klasse von mir gelöst...!?
@Oliver: Shell-Zugang habe ich nicht, ...denke ich.
Gruß Dirk
Hallo Dirk,
-Dirk- schriebmit dieser Version hat es endlich geklappt. 🙂 Danke für den Tipp!
Naja, bitteschön, aber das freut mich nicht besonders, denn eigentlich hatte ich gedacht, dass der Wrapper keine Probleme bereiten sollte. Kannst Du mir helfen, diesen Fehler bei Dir trotzdem zu lokalisieren?
-Dirk- schriebHier noch ein Auszug aus meiner localconf.php
.
.
.
$TYPO3_CONF_VARS["GFX"]["im"] = '0';
$TYPO3_CONF_VARS["GFX"]["im_combine_filename"] = 'combine';
$TYPO3_CONF_VARS["GFX"]["im_path"] = '/is/htdocs/xxx/www.xxxxx.de/imagemagick-4.2.9/';
$TYPO3_CONF_VARS["GFX"]["im_path_lzw"] = '';
.
.
.
$TYPO3_CONF_VARS["GFX"]["im_path_lzw"] = '/is/htdocs/xxx/www.xxxxx.de/imagemagick-4.2.9/';
$TYPO3_CONF_VARS["GFX"]["im_path"] = '/is/htdocs/xxx/www.xxxxx.de/imagemagick-4.2.9/';
$TYPO3_CONF_VARS["GFX"]["im_combine_filename"] = 'combine';
$TYPO3_CONF_VARS["GFX"]["im"] = '1';
// Updated by TYPO3 Install Tool 11-05-2004 10:30:41
?>
Ist das alles so korrekt?
Könnte man stark vereinfachen. Mach mal das daraus:
$TYPO3_CONF_VARS["GFX"]["im"] = '1';
$TYPO3_CONF_VARS["GFX"]["im_path"] = '/is/htdocs/xxx/www.xxxxx.de/imagemagick-4.2.9/';
$TYPO3_CONF_VARS["GFX"]["im_path_lzw"] = '';
$TYPO3_CONF_VARS["GFX"]["im_combine_filename"] = 'combine';
-Dirk- schriebAchja, passt zwar hier nicht rein, aber beim austesten von IM ist mir aufgefallen, dass Typo3 mir nicht die Thumbs vergrößern wollte. Er vermisst die showpic.php. Diese habe ich jetzt ins Root-Verzeichnis gepackt. Wohl nicht so klasse von mir gelöst...!?
Also bei den Site-Packages von http://typo3.sunsite.dk/unix-archives/ ist die showpic.php im gleichen Verzeichnis wie fileadmin/ und typo3conf/ als Symlink dabei. Reicht das denn nicht?
Gruss, michael
Chip schrieb... eigentlich hatte ich gedacht, dass der Wrapper keine Probleme bereiten sollte. Kannst Du mir helfen, diesen Fehler bei Dir trotzdem zu lokalisieren?
Klar, können wir gerne machen. Ich werde mir die Version mit Wrapper noch mal auf den Server laden und sage dir dann bescheid. Bevor es aber hier ausufert, ...wollen wir dies dann lieber per PN weiter beschnacken? Wenn wir die Fehlerursache gefunden haben, können wir ja hier immer noch berichten...
Chip schriebKönnte man stark vereinfachen. Mach mal das daraus:
$TYPO3_CONF_VARS["GFX"]["im"] = '1';
$TYPO3_CONF_VARS["GFX"]["im_path"] = '/is/htdocs/xxx/www.xxxxx.de/imagemagick-4.2.9/';
$TYPO3_CONF_VARS["GFX"]["im_path_lzw"] = '';
$TYPO3_CONF_VARS["GFX"]["im_combine_filename"] = 'combine';
hab es vereinfacht. dankeschön.
Chip schrieb
Also bei den Site-Packages von http://typo3.sunsite.dk/unix-archives/ ist die showpic.php im gleichen Verzeichnis wie fileadmin/ und typo3conf/ als Symlink dabei. Reicht das denn nicht?
Na, da sagst du was. 🙂 Wie sieht so ein Symlink aus bzw. wie sollte der heißen?
Gruß Dirk
-Dirk- schriebKlar, können wir gerne machen. Ich werde mir die Version mit Wrapper noch mal auf den Server laden und sage dir dann bescheid. Bevor es aber hier ausufert, ...wollen wir dies dann lieber per PN weiter beschnacken? Wenn wir die Fehlerursache gefunden haben, können wir ja hier immer noch berichten...
Jep, ist ok.
-Dirk- schriebNa, da sagst du was. 🙂 Wie sieht so ein Symlink aus bzw. wie sollte der heißen?
http://linuxwiki.de/SymLink
Gruss, michael
Ich hab das ImageMagick-Archiv etwas erweitert und wieder auf Sunsite [1] hochgeladen.
Einzige Änderung: Man muss den Wrapper jetzt nicht mehr manuell ändern wenn man ImageMagick nicht (so wie vorgeschlagen) nach /usr/local/imagemagick-4.2.9/ installiert hat.
Das bringt zwar keine neue Funktionalität, doch ich bin mir ziemlich sicher, dass dies die Fehlerquelle war (falsch angegebene Pfade) warum das neue Script bei einigen nicht mehr lief...
Bitte um Feedback, ansonsten gehe ich davon aus, dass das Script jetzt fehlerfrei funktioniert!
[1] http://typo3.sunsite.dk/software/linux/
Gruss - michael