wt_directory - Search - Results - Details Ausgabe unterschiedliche seiten 1.Suchanfrage Löschen

  • skydivematy skydivema...
    Jedi-Meister
    0 x
    276 Beiträge
    1 Hilfreiche Beiträge
    28. 04. 2010, 19:04

    Hallo Forum,
    meine Frage bezieht sich auf folgendes Scenario.

    WT-Directory Suchbox als Plugin auf Startseite 1. Results List Ausgabe auf Seite 2 und Details Ausgabe auf Seite 3.

    Das Template (tmpl_search.html) für Die Suchbox auf Seite 1 habe ich soweit geändert um die Suchresultate auf Seite 2 (list) auszugeben.

    1. <!-- ###WTDIRECTORY_FILTER_SEARCH### begin -->
    2. <div class="wtdirectory_filter wtdirectory_filter_search">
    3. <h2 class="wtdirectory">###WTDIRECTORY_SEARCH_TITLE###</h2>
    4. <form action="http://www.mydomain/seite2.com/" method="###WTDIRECTORY_SEARCH_METHOD###">
    5. <!-- ###CONTENT### --><!-- ###ITEM### -->
    6. <div class="###WTDIRECTORY_SEARCH_NAME###">
    7. <label for="###WTDIRECTORY_SEARCH_NAME###">###WTDIRECTORY_SEARCH_LABEL###</label>
    8.  
    9. <input type="###WTDIRECTORY_SEARCH_TYPE###" name="tx_wtdirectory_pi1[filter][###WTDIRECTORY_SEARCH_NAME###]"
    10. id="###WTDIRECTORY_SEARCH_NAME###" autocomplete="off" class="wtdirectory_filter_###WTDIRECTORY_SEARCH_TYPE###
    11. wtdirectory_filter_###WTDIRECTORY_SEARCH_TYPE###_###WTDIRECTORY_SEARCH_NAME###" value="###WTDIRECTORY_SEARCH_VALUE###"
    12. onclick="if(this.value=='###WTDIRECTORY_SEARCH_VALUE###'){this.value='';}" />

    Ok, das funktioniert soweit auch wie es soll. Weiter (more-link) von den Suchresultaten zu Details auch ok. Back to list von den Details auch ok.

    Wenn jetzt eine Suchanfrage aus der Listenansicht ( List View Suche ist Aktiviert) erfolgt werden Die Such Resultate auch perfekt aufgelistet.

    Nun kommt das Problem. Geht man jetzt wieder zur Startseite zurück und beginnt mit einer Neuen Suchanfrage wird die zuvor getätigte Suchanfrage auf Seite 2
    mit der List Ansicht nicht gelöscht und das Ergebnis der Ersten Suchanfrage wird Aufgelistet.

    Hab jetzt Versucht das ganze mit folgendem zusatz im Search Template zu beheben.

    1. onunload="if(this.value=='###WTDIRECTORY_SEARCH_VALUE###'){this.value='';}" />

    und

    1. onblur="if(this.value=='###WTDIRECTORY_SEARCH_VALUE###'){this.value='';}" />

    Jedoch beides führt zu kein Ergebnis.

    Hat jemand einen Tipp wo oder wie ich noch ansetzen kann

    Gruß
    maty

    Maty


  • 1
  • 1