Mittwald und CronJob für Extension

  • id31 id31
    T3PO
    0 x
    31 Beiträge
    0 Hilfreiche Beiträge
    01. 02. 2010, 19:23

    Hallo

    Ich habe auf einem Mittwald Server eine Typo3 Seite gehostet. Hier betreibe ich die Extension Realty Manager, diese Extension bietet mir die Möglichkeit über einen Cronjob einen zeitlich gesteuerten Immobilienimport vorzunehmen.

    Laut Tutorial der Extension muss ein Cronjob mit folgendem Inhalt angelegt werden:

    Hier ein Auszug aus dem Tutorial: [i]/[absolute path of the TYPO3 installation]/typo3/cli_dispatch.phpsh openImmoImport[/i]

    Das Problem ist das der Cronjob mit dem Aufruf "openImmoImport" am Ende sich bei Mittwald sich nicht einrichten lässt. An Stelle dessen habe ich versucht zwecks Parameterübergabe über das Mittwald Tutorial vorzugehen:

    [i]Parameter Übergabe bei Cronjobs

    Wenn Sie einen Cronjob einrichten möchten, bei dem an die aufzurufende Datei Parameter übergeben werden, so können Sie dies durch den Einsatz eines Shell Scripts realisieren.

    Legen Sie zunächst das Shellscript mit einem Texteditor an und speichern dieses unterhalb des html/ Ordners in einem Verzeichnis Ihrer Wahl.

    Bash Scripte werden mit der Fileendung .sh (z.B. script.sh) angelegt und sehen wie folgt aus:

    #!/bin/bash
    Tragen Sie hier den Befehl mit Parameter ein

    Nach der einleitenden Zeile #!/bin/bash geben Sie den Befehl den Sie zusammen mit einem Parameter aufrufen möchten an, beispielhaft:

    #!/bin/bash
    php datei.php parameter[/i]

    Folglich sieht meine Datei welche ich im normalen Texteditor erstellt habe ja dann wie folgt aus:

    #!/bin/bash
    cli_dispatch.phpsh openImmoImport

    Leider gibt er mir in der Cronjobbestätigung via e-Mail folgende Fehlermeldung aus:

    /html/typo3/script.sh: line 2: cli_dispatch.phpsh: command not found

    Was mache ich falsch, wer kann mir helfen?


  • 1
  • oliverklee oliverkle...
    Sternenflotten-Admiral
    0 x
    174 Beiträge
    1 Hilfreiche Beiträge
    24. 02. 2010, 17:05

    Hi,

    du musst den kompletten Pfad zum CLI-Dispatcher angeben.

    Oliver

  • danaron danaron
    R2-D2
    0 x
    78 Beiträge
    0 Hilfreiche Beiträge
    29. 09. 2011, 10:55

    Hi oliverklee
    hat das geklappt mit dem Pfad?
    Habe ein ähnliches Problem und wäre froh, wenn du mir kurz beschreiben könntest, wie du den Cronjob bei Mittwald eingerichtet hast:

    Grundsätzlich gibst du ja im Kundencenter den Pfad zum php_cli und zum Script an. Mein Script sieht so aus:

    #!bin/bash
    /usr/local/bin/php_cli /html/typo3/typo3/cli_dispatch.phpsh scheduler

    Scheint aber nicht zu funktionieren.

    Frage: Was ist der unterschied zwischen den Methoden, resp wann welche wählen?
    Serverseitiger Aufruf
    Browserbasierter Aufruf
    Benutzerdefinierter Aufruf

    Bei Benutzerdefiniertem Aufruf wählst du welche Methode?
    a)user/local/php/bin/php_cli
    b)bin/bash
    c)user/bin/perl

    Hast du mir ein Link, wo das mit dem Cron etwas detailierter erklärt ist?
    Danke Dir!
    Grüsse

    Danke für deine Hilfe. Cool wenn du dich mit mir auf den Social Media verbindest!

  • danaron danaron
    R2-D2
    0 x
    78 Beiträge
    0 Hilfreiche Beiträge
    29. 09. 2011, 15:22

    Hi oliverklee
    Habe es hinbekommen mit dem Planer.
    [url=]http://www.typo3.net/forum/beitraege/diverse_sonstige_module/107550/[/url]
    Danke fürs hinhören und für Tipps, welche zum besseren Verständnis beitragen, bin ich immer offen ;-)

    Danke für deine Hilfe. Cool wenn du dich mit mir auf den Social Media verbindest!

  • 1