templavoila! und wrap in einem attr -> bild

  • server server
    T3PO
    0 x
    9 Beiträge
    0 Hilfreiche Beiträge
    02. 07. 2009, 20:50

    Hallo Gemeinde,
    folgendes Problem plagt mich und trotz stöbern und wühlen der TSref liegt die Lösung fern:

    Ich arbeite mit der Extension Templavoila!
    Hier möchte ich, bei einem Bild das Rendering in einem Attribut eines DIV- Tags schreiben, das macht Typo3 an sich auch vorerst ganz OK, raus kommt:
    <div id="main" style="typo3temp/GB/fd47caf1a9.gif">

    Diese Styleangabe ist klarer weise noch nicht vollständig, also dachte ich an einen simplen wrap, der aber nicht akzeptiert wird:
    wrap = background-image:url(|);

    Dieses wrap oder stdWrap habe ich auf vielen Wegen ausprobiert. Den Cache All auch immer gemacht, jedoch leider keine Erfolge gehabt, hier nochmal der TypoScript aus dem TV XML:

    type attr

    tx_templavoila

    title Bild

    TypoScript
    10 = IMG_RESOURCE
    10.wrap = background-image:url(|);
    10.stdWrap = background-image:url(|);
    10.file = GIFBUILDER
    10.file {
    wrap = background-image:url(|);
    stdWrap = background-image:url(|);
    XY = 200,150
    10 = IMAGE
    10.wrap = background-image:url(|);
    10.stdWrap = background-image:url(|);
    10.file.wrap = background-image:url(|);
    10.file.stdWrap = background-image:url(|);
    10.file.import = uploads/tx_templavoila/
    10.file.import.current = 1
    10.file.import.listNum = 0
    10.file.maxW = 200
    10.file.minW = 200
    10.file.maxH = 150
    10.file.minH = 150
    }

    Danke, danke, danke.


  • 1
  • froemken froemken
    Jedi-Ratsmitglied
    0 x
    811 Beiträge
    1 Hilfreiche Beiträge
    07. 07. 2009, 13:39

    IMG_RESOURCE hat kein wrap:
    http://typo3.org/documentation/document-library/core-documentation/doc_core_tsref/4.2.0/view/1/8/#id4250904

    Also fällt das schon mal weg.

    Zu aller erst wickelst du dein TS bitte ein in:
    <![CDATA[
    Dein TS
    ]]>

    wenn du das nicht machst gibt es immer wieder Probleme mit Klammern in deinem Quellcode.

    Mach das mal und teste.

    Wenn's immer noch nicht geht, müssen wir uns ein COA Objekt bauen:

    [TS]<![CDATA[
    10 = COA
    10.10 = TEXT
    10.10.value = background-image:url(

    10.20 = IMG_RESOURCE
    10.20.file = GIFBUILDER
    10.20.file {
    ...hier kommen deine GIFBUILDER-Settings rein...
    }

    10.30 = TEXT
    10.30.value = );
    ]]>
    [/TS]

    froemken

  • 1