Seltsame Fehlermeldung bei update auf 4.2.0 bzw. 4.2.1 [Gelöst]

  • 0 x
    63 Beiträge
    0 Hilfreiche Beiträge
    11. 06. 2008, 20:59

    Hallo,

    beim Update Versuch von TYPO3 4.1.6 auf 4.2.0 erhalte ich nach dem Austausch des SymLinks folgende Fehlermeldung:

    1. Parse error: syntax error, unexpected '<' in /.../dummy-4.1/typo3conf/temp_CACHED_ps0caa_ext_localconf.php on line 1432

    Danach erhalte ich weder Zugriff auf Frontend, Backend oder Installtool.

    Ich hatte alle temp*.* gelöscht (sowohl in /typo3conf als auch in /typo3temp).

    (Update von 4.1.6 nach 4.1.7 war völlig problemlos, auch vorherige Updates waren ohne Probleme; Beim Updateversuch von 4.1.7 auf 4.2.1 erscheint wieder die gleiche Fehlermeldung)

    Habt Ihr eine Idee woran das liegen kann?

    Danke

    Peter


  • 1
  • extension22 extension...
    Sternenflotten-Admiral
    0 x
    208 Beiträge
    0 Hilfreiche Beiträge
    11. 06. 2008, 23:54

    4.2 setzt PHP 5.2.x voraus.

  • 0 x
    63 Beiträge
    0 Hilfreiche Beiträge
    12. 06. 2008, 08:20

    [quote="extension22"]
    4.2 setzt PHP 5.2.x voraus.
    [/quote]

    Ich setze PHP 5.2.4 ein... Also das sollte nicht das Problem sein.

  • extension22 extension...
    Sternenflotten-Admiral
    0 x
    208 Beiträge
    0 Hilfreiche Beiträge
    12. 06. 2008, 09:09

    [quote="matthesius"]
    [quote="extension22"]
    4.2 setzt PHP 5.2.x voraus.
    [/quote]

    Ich setze PHP 5.2.4 ein... Also das sollte nicht das Problem sein.
    [/quote]
    dann ist es wohl eine Extension in Deinem "dummy-4.1", die nicht PHP5-kompatibel ist. Kannst ja mal die ext_localconf.php, in verdächtigen Extensions umbenennen. Wenn Du die richtige erwischt hast, bekommst Du keinen error mehr, sondern nur noch eine Warnung, daß die Datei nicht gefunden wurde.
    Diese Extension dann deinstallieren.

  • saschae saschae
    Jedi-Meister
    0 x
    263 Beiträge
    0 Hilfreiche Beiträge
    12. 06. 2008, 09:52

    was steht denn hier an der stelle in der datei. Kopier mal ein paar zeilen raus...

    [HTML]/.../dummy-4.1/typo3conf/temp_CACHED_ps0caa_ext_localconf.php on line 1432[/HTML]

  • 0 x
    63 Beiträge
    0 Hilfreiche Beiträge
    12. 06. 2008, 14:26

    Fehler gefunden:

    Schuld war scheinbar die ext "package_manager"

    Die angemeckerte Stelle sah so aus: (Hier jetzt Zeile 9)

    1. ###########################
    2. ## EXTENSION: package_manager
    3. ## FILE: /www/pm-web-consult.com/webseiten/matthesius.de/dummy-4.1/typo3conf/ext/package_manager/ext_localconf.php
    4. ###########################
    5.  
    6. $_EXTKEY = 'package_manager';
    7. $_EXTCONF = $TYPO3_CONF_VARS['EXT']['extConf'][$_EXTKEY];
    8.  
    9. <?
    10. if (!defined ("TYPO3_MODE")) die ('Access denied.');
    11. if ((TYPO3_MODE == 'BE'))
    12. {

    Extension deinstalliert und siehe da: das update auf 4.2.1 klappt!

    Danke für Eure Tips.

    Peter

  • extension22 extension...
    Sternenflotten-Admiral
    0 x
    208 Beiträge
    0 Hilfreiche Beiträge
    12. 06. 2008, 14:33

    1. <?

    Ist shortopentag.
    Kann man in der php.ini erlauben oder besser stattdessen <?php schreiben.

  • 1