ve_guestbook erstellt doppelte Einträge [Gelöst]

  • josh josh
    T3PO
    0 x
    27 Beiträge
    0 Hilfreiche Beiträge
    16. 12. 2007, 04:56

    Hallo allerseits,

    ich bin gerade dabei eine kleine Seite zu erstellen, auf der unter anderem auch ein Gästebuch enthalten sein soll.
    Es gab ja nun schon des Öfteren die Variante, dass überhaupt keine Einträge erstellt wurden, bei mir ist es genau umgekehrt: ich bekomme doppelt soviele wie gewünscht.

    Im Manual wurde erwähnt, dass zur Vermeidung dieses Problems der Redirect eingeführt wurde, aber egal welche Einstellungen ich vornehme, bleibt das Problem bestehen.

    Ich nutze zur Zeit noch das Original-Template und -CSS auf einem lokalen XAMPP-Server mit PHP 5.2.4 und TYPO3 4.1.4.

    Für jeden Tipp der zur Ergreifung des Fehlerteufels führt bin ich ewig dankbar :) .

    edit 17.12.2007: Das Problem habe ich jetzt gelöst (leider nicht behoben). Meine ve_guestbook-Version war 2.3.1 (die derzeit Neueste). Hier erstellte es mir trotz Neuinstallation und den üblichen Versuchen immer wieder doppelte Einträge.
    Ich habe jetzt auf 1.2.0 "aktualisiert" ;). Das Template wurde durch ein tabellenfreies ersetzt. Resultat: Keine Doppelposts mehr - funktioniert soweit einwandfrei. :D


  • 1
  • 0 x
    15 Beiträge
    0 Hilfreiche Beiträge
    30. 01. 2008, 14:56

    Hallo,

    wollte nur mal wissen ob hier zu eigentlich schon eine konfiguierte Lösung gibt.
    Eine andere Version oder gar eine ältere Version zu installieren erscheint mir leider nicht als Lösung ausreichend...

    Weiss hierbei schon jemand mehr?

    Grüsse

  • thomas_vienna thomas_vi...
    Padawan
    0 x
    47 Beiträge
    0 Hilfreiche Beiträge
    10. 05. 2008, 13:22

    HI!
    ICH HABE DA SELBE PROBLEM UND KOMME NICHT AUF DIE Lösung!!!

  • inu inu
    Jedi-Ratsmitglied
    0 x
    694 Beiträge
    0 Hilfreiche Beiträge
    02. 04. 2010, 09:41

    Hallo josh,

    ich habe selbiges Problem, dass ich bei eigentlich einmaligen Einträgen ins Gästebuch diese immer doppelt werhalte. Hattest Du - auch wenn es schon lange her ist - eine Lösung gefunden?

    Gruß
    David

  • josh josh
    T3PO
    0 x
    27 Beiträge
    0 Hilfreiche Beiträge
    02. 04. 2010, 15:18

    Wie geschrieben habe ich eine ältere Version installiert. Die Lösung ist sicherlich nicht optimal, funktioniert aber...

  • toifel toifel
    Jedi-Ratsmitglied
    0 x
    831 Beiträge
    96 Hilfreiche Beiträge
    14. 07. 2010, 10:55

    Hatte das selbe Problem.. bei mir lag es scheinbar an einer fehlenden/alten sr_freecap Version (im Formular-Setup war freecap eingestellt).

    Meine Versionen sind jetzt:
    sr_freecap 1.2.2
    ve_guestbook 2.8.1

    Klappt alles wunderbar, vielleicht ist das ja auch bei Euch die Lösung.

  • notenexperte notenexpe...
    Padawan
    0 x
    49 Beiträge
    0 Hilfreiche Beiträge
    07. 01. 2011, 15:26

    Hallo,

    auch bei mir werden doppelte Einträge erstellt (Version 2.8.1), die Seite ist noch nicht online. Ich habe alle Lösungsvorschläge probiert, bei mir funktioniert nichts davon. Andere Seiten mit den gleichen Einstellung fürs Gästebuch funktionieren einwandfrei, die Seite liegt auf dem gleichen Server wie die anderen (Mittwald)...

    Weiß jemand Rat?

    Grüße

    Uli

  • mke mke
    Typ im Roten Hemd
    0 x
    2 Beiträge
    0 Hilfreiche Beiträge
    13. 01. 2011, 11:02

    Hallo,

    class.tx_veguestbook_pi1.php bearbeiten und hinter Zeile 810 einfach ein [b]die();[/b]

    1. header('Location: '.t3lib_div::getIndpEnv('TYPO3_REQUEST_DIR').$this->getUrl($this->config['redirect_page']));
    2. die();

    Gruß
    mke

  • notenexperte notenexpe...
    Padawan
    0 x
    49 Beiträge
    0 Hilfreiche Beiträge
    14. 01. 2011, 09:47

    Super, hat funktioniert!

  • 1