Die Text Inhalten können nicht ausgelesen werden. [Gelöst]

  • gempi gempi
    T3PO
    0 x
    10 Beiträge
    0 Hilfreiche Beiträge
    30. 11. 2007, 14:53

    #angry#
    Ich versuche seit Tagen directmail 2.5.2 zum Laufen zu bringen. Leider scheitere ich jedesmal beim fetchen des Mails:

    [b]Die Text Inhalten können nicht ausgelesen werden.
    Die HTML Inhalten können nicht ausgelesen werden.[/b]

    Ich habe das ganze Web durchsucht aber eine richtige Lösung für diese Problem habe ich nicht gefunden.

    Habt ihr mir einen Tipp was ich noch versuchen könnte?

    Gibt es eventuel andere Newsletter Tools für typo3 in ähnlichem Umfang wie Direct Mail?

    Bin langsam aber sicher am Verzweifeln! #angry#

    Vielen Dank!


  • anj anj
    Jedi-Meister
    0 x
    320 Beiträge
    0 Hilfreiche Beiträge
    12. 07. 2009, 21:07

    Hallo,

    habe mich gerade eben damit auch rumgequält, mein Problem konnte ich lösen bei den Einstellungen von Direct Mail (HTTP-Benutzername, HTTP-Passwort), ich hatte leider vergessen, daß mein Server mit einer HTTP Authentifizierung betrieben wird (htaccess), wodurch die Inhalte ebenfalls nicht ausgelesen werden konnten.

  • nat nat
    Jar Jar Binks
    0 x
    1 Beiträge
    0 Hilfreiche Beiträge
    19. 07. 2009, 21:37

    Es könnte einfacher sein als man denkt.

    Also bei mir stand auch, dass der Text etc. nicht ausgelesen werden konnte. Da ich bereits vor einem Jahr ein DirectMail aufgesetzt habe, habe die beiden Installationen (der verschiedenen Auftritte) verglichen.

    Mein "Fehler":
    In dem Tutorial, das ich diesmal benutzt habe stand: "Klicken Sie mit der rechten Maustaste auf den Sysordner Direct Mail Newsletter und wählen Sie aus dem angezeigten Kontextmenü den Befehl Neu aus; in der rechts angezeigten Spalte Datensatz wählen Sie dann Template aus."
    Das habe ich gemacht und habe ein anderes Template-Icon gehabt als bei dem root-Template.

    Lösung:
    - Listenansicht auswählen
    - dann die Seite, wo ihr das Newsletter-Template eingefügt habt auswählen
    - Template löschen
    - Templatemodul (linke Spalte) auswählen
    - Create Template for a new site
    - Alle Schritte nochmal durchgehen (Constanten auswählen, TypoScript einsetzen...)
    - fertig!

    Danach kam die Meldung nicht mehr und ich konnte problemlos versenden.

    Ich hoffe, ihr habt das selbe Problem, weil die Lösung ein Witz ist. ;-)

    Viele Grüße
    Nat

  • Paralex Paralex
    Typ im Roten Hemd
    0 x
    3 Beiträge
    0 Hilfreiche Beiträge
    30. 07. 2009, 09:22

    Kommt "Die Text Inhalten können nicht ausgelesen werden. Die HTML Inhalten können nicht ausgelesen werden" bedeutet das direct_mail kann die absolute URL des Newsletters nicht aufrufen. Prüft das als erstes:

    Lässt sich der NL von Typo3 aus per Lupe aufrufen?
    Dann URL kopieren, Browser zumachen, neu aufmachen (session wech) -> URL noch mal testen.

    In meinem Fall führte das zur Lösung: ich hatte htaccess Passwortschutz drauf. Somit kam direct_mail selbst nicht drauf.
    (Konfiguration des Direct Mail-Moduls: HTTP-Benutzername/HTTP-Passwort)

    Das [SYS][curlUse]= 1 ist übrigens nicht zwangsläufig nötig.
    Fehlen die Boundaries führt das zwar zu folgendem Fehler, aber das Auslesen funktioniert erst mal:
    "The plain text content does not contain any direct mail boundaries.
    The HTML content does not contain any direct mail boundaries."

  • Seneca Seneca
    Sternenflotten-Admiral
    0 x
    230 Beiträge
    0 Hilfreiche Beiträge
    04. 09. 2009, 12:13

    Hallo,

    bei mir kommt auch die Meldung "Die Text Inhalten können nicht ausgelesen werden."
    Ich habe die drei static templates (plain text, news plain text, content boundaries) eingebunden.
    Ich komme trotz Durcharbeitung aller Forenbeiträge nicht weiter.

    Wenn ich den oberen Rat befolge:
    [quote="danaron"]
    1. Direct Mail anklicken
    2. Wählen Sie Quelle des Newsletters aus: -> Interne Seite
    3. Neuen Versand anhand eines Newsletters erstellen -> auf das Symbol "H mit Lupe" klicken -> der HTML Newsletter wird im Browser angezeigt[\quote="danaron"]

    Bei Punbkt 3 hängt es bei mir:
    Typo3 öffnet ein neues Fenster und meldet "Non template found".
    Hat jemand Ahnung, woran das liegen kann?

    Seneca

    Abitur für Spätzünder!
    http://www.sankt-matthias.de

  • xdtera xdtera
    T3PO
    0 x
    15 Beiträge
    0 Hilfreiche Beiträge
    23. 09. 2009, 18:37

    Hallo, also erstmal vorweg: ich habe die Anleitung [url]http://www.muenster-webdesign.net/typo3/newsletter_mit_direct_mail_einrichten-1.php[/url] zu fast 100% vollständig ausgeführt - die ausnahme ist, dass ich Direct Mail Subscription benutze. :)

    mein problem ist der versand einer "[b]internen seiten[/b]". wenn ich dann hier mein newsletter auswähle, dann lädt der browser ne ganze weile und danach ist die rechte seite in typo3 einfach [b]leer[/b]. normalerweise müsste doch der assistent starten mit den 1-5 schritten.......

    nun nahm ich an, das müsste am template liegen. ich hab das template korrekt angelegt mit ts, haken bei wurzel+constants+setup, sowie den Statische Templates einschließen(CSS Styled Content, Direct Mail Plain text sowie Direct Mail Content Boundaries).

    und alles andere auch wie in dieser anleitung.

    bitte um rat

  • xdtera xdtera
    T3PO
    0 x
    15 Beiträge
    0 Hilfreiche Beiträge
    28. 09. 2009, 15:37

    ich hab nun nochmal alle schritte gemacht - zu 100% nach anleitung.

    frische typo3 installation, keine anderen seiten/extensions/templates ausser denen im tutorial.

    nun komme ich recht fix zu Schritt 2, aber hier erhalte ich dann diese fehlermeldungen:

    [b]FEHLER
    Die TEXT Inhalten können nicht ausgelesen werden
    Die HTML Inhalten können nicht ausgelesen werden[/b]

    hab auch schon gegooglet, dass man cache löschen soll usw hat aber nichts geholfen.

    das ganze läuft nun auf einem [b]Webpack L 2.0 Hosteurope[/b]

    bin am verzweifeln :(

  • Mannimedia Mannimedi...
    Padawan
    0 x
    56 Beiträge
    0 Hilfreiche Beiträge
    02. 03. 2010, 15:32

    [quote="Paralex"]

    In meinem Fall führte das zur Lösung: ich hatte htaccess Passwortschutz drauf. Somit kam direct_mail selbst nicht drauf.
    (Konfiguration des Direct Mail-Moduls: HTTP-Benutzername/HTTP-Passwort)

    [/quote]

    Daran lag es bei mir. Danke für den Hinweis!!!

  • googol googol
    Padawan
    0 x
    47 Beiträge
    0 Hilfreiche Beiträge
    02. 03. 2010, 16:07

    hallo,

    Ich habe mal alle Probleme hier beschrieben:

    [url]http://bugs.typo3.org/view.php?id=12199[/url]

    If you create an external newsletter with an URL that requires HTTP Authentication the following error is displayed:

    AN ERROR WAS ENCOUNTERED.

    The HTML content could not be fetched.

    One could specify more precisely why it could not be fetched.

    - The URL you provided is secured with HTTP Authentication so please provide the username and password here ...

    - The URL you provided does not exist.

    - The URL you provided could not be resolved. Maybe you use a local DNS entry to access a website
    during development. Please use the IP address of the server instead or connect a domain to the webspace so direct_mail can access the Newsletter content of this webspace.

    - The URL you provided ...

    - neither allow_url_fopen in PHP.INI is ON nor cURL is installed. I think the extension should warn the user if one of them is not enabled and especially when none is enabled.

    - if you selected "Plain text" in the setting "Format of mail content" and don't provide plain text content. The same applies to "HTML".

    Format of mail content:
    Plain text
    HTML

    Gruss,

    Philipp

  • Gernott Gernott
    Jedi-Meister
    0 x
    271 Beiträge
    3 Hilfreiche Beiträge
    23. 06. 2010, 15:53

    Ich hatte soeben das selbe Problem.
    Die Lösung war bei mir einfach:
    Im T3-Backend unter Direckt Mail / Konfiguration alle Felder bei "SETZE STANDARDWERTE DES DIRECT MAIL-HEADERS:" ausfüllen und speichern. Dann verschwand diese Meldung.

    lg
    Gernot