Redakteur kann sich nicht ins BE einloggen [Gelöst]

  • Floater Floater
    Jedi-Ratsmitglied
    0 x
    516 Beiträge
    0 Hilfreiche Beiträge
    21. 11. 2007, 09:37

    Hallo,

    ich habe eine Typo3-Seite mit der Version TYPO3 4.1.2 erstellt, auf der BE-Editing und FE-Editing möglic ist.

    Als Admin kann ich mich von allen PCs (mit unterschiedlicher IP) und mit allen Browsern (Opera, FF, IE, NS) einloggen.

    Ich habe einen Redakteur angelegt, mit dessen Zugangsdaten ich mich auch von überall und mit o.g. Browsern einloggen kann.

    Ich habe dem Redakteur seine Zugangsdaten geschickt. Wenn er sich für das BE einloggen will, dann kommt eine Fehlermeldung:

    Login-error or session timed-out.
    No user logged in!..... (You muist have cookies enabled!)

    Der Redakteur benutzt den IE und hat Cookies und JS aktiviert. Er hat sich auch mal Opera installiert. Dort tritt das gleiche Problem auf.

    Ich habe keine Idee mehr, was man da machen kann, um dieses Problem zu beheben.

    Muss man in TYPO3 noch irgendwas konfigurieren?

    Bei anderen von mir erstellten Typo3-Seiten ist dieses problem noch nie aufgetreten.

    Vielen Dank für eure Tipps und Hilfe,
    Floater


  • 1
  • surf surf
    R2-D2
    0 x
    71 Beiträge
    0 Hilfreiche Beiträge
    21. 11. 2007, 10:01

    Ich habe einen Redakteur angelegt, mit dessen Zugangsdaten ich mich auch [b]von überall [/b]und mit o.g. Browsern einloggen kann.

    Wenn Du bei Deinen nicht vorher als Admin eingeloggt warst bzw. alle Cookies gelöscht hast, muss der Login ja laufen.

    Würde daher entweder auf falsche Einstellungen bei Deinem Redakteur (Cookie, JS) schliessen oder

    er soll die Zugangsdaten mal per copy/paste in die Felder übertragen. Hört sich zwar unwahrscheinlich an aber oft wird 0 (Null) mit O usw verwechselt bzw. [b]Kennwort[/b] eingegeben obwohl Du Ihm [b]kennwort [/b]mitgeteilt hast.

  • Floater Floater
    Jedi-Ratsmitglied
    0 x
    516 Beiträge
    0 Hilfreiche Beiträge
    21. 11. 2007, 10:19

    Er gibt die Zugangsdaten ja richtig ein.
    Würde er es nicht machen, so würde er auf der Seite mit dem Login-Formular bleiben.
    Er wird aber ins BE geleitet. Das erkennt man daran, dass sich das BE-Frame aufbaut, allerdings mit den Fehlermeldungen in jedem Frame.

  • Floater Floater
    Jedi-Ratsmitglied
    0 x
    516 Beiträge
    0 Hilfreiche Beiträge
    21. 11. 2007, 11:17

    FEHLER GEFUNDEN.

    Das heißt eigentlich ist es kein Fehler, sondern eine Konfigurationssache gewesen.

    Durch die Suche im Forum bin ich auf folgende Konfigurations-Variablen gestossen:

    $TYPO3_CONF_VARS["FE"]["lockIP"]
    und
    $TYPO3_CONF_VARS["BE"]["lockIP"]

    Die Definition dieser Variablen ([url]http://www.typo3.net/backendkonfiguration/frontend_konfiguration/#lockIP[/url]), die Werte und die Tatsache, dass der Redakteur sich ins FE aber nicht ins BE einloggen konnte haben zur Lösung geführt:

    Folgende Einstellungen waren bei mir:

    $TYPO3_CONF_VARS["FE"]["lockIP"] = 2
    und
    $TYPO3_CONF_VARS["BE"]["lockIP"] = 4

    Nachdem ich $TYPO3_CONF_VARS["BE"]["lockIP"] ebenfalls auf 2 gesetzt habe, konnte sich der Redakteur einloggen.

  • 1