newloginbox - Hilfe zu zwei gesucht..

  • inu inu
    Jedi-Ratsmitglied
    0 x
    694 Beiträge
    0 Hilfreiche Beiträge
    25. 09. 2007, 17:49

    Hallo Leute,

    ich möchte gern folgendes umsetzen:

    1.
    Innerhalb meines Menüs benötige ich einen Punkt "Anmelden" sowie "Abmelden". In Abhängigkeit eines Login-Logoff-Status soll entweder nur "Anmelden" oder nur "Abmelden" angezeigt werden. Das so umzusetzen erscheint mir nciht schwierig.

    A-Bär: Klickt der Benutzer auf "Abmelden" soll er sich gleich abmelden und nicht erst auf eine Seite springen, die wiederrum (newlogin-plugin-bedingt) eine Schaltfläche anbietet, wo der Benutzer sich abmelden kann. Nach diesem Gleich-Abmelden sollte der Benutzer wieder auf die Anmeldeseite springen.

    Wie kann man das umsetzen?

    2.
    Ist ein Benutzer angemeldet, wird der Marker ###USER### mit dem Benutzernamen (Loginnamen) gefüllt und angezeigt. Ich möchte jedoch nicht den login-Namen anzeigen lassen, sondern lieber den Klarnamen des Benutzers.

    Gibt es hierfür auch einen Marker?

    Vielen Dank


  • steffenk steffenk
    Obi-Wan Kenobi
    0 x
    4666 Beiträge
    0 Hilfreiche Beiträge
    11. 02. 2008, 18:26

    ja - das ist nicht richtig integriert.

    Wenn Du php5 hast kannst Du meine Version von felogin nehmen (BT) oder aus der 4.2beta, da gehts

  • Andrea_Herzog Andrea_He...
    Jedi-Meister
    0 x
    432 Beiträge
    0 Hilfreiche Beiträge
    12. 02. 2008, 09:38

    Hi,

    Du findest mich verwirrt, welche Version von was und woher?

    Gruß
    Andrea

  • steffenk steffenk
    Obi-Wan Kenobi
    0 x
    4666 Beiträge
    0 Hilfreiche Beiträge
    12. 02. 2008, 09:58

    Die ext heisst felogin
    Ich habe die newloginbox umgeschrieben und die Extension ist zukünftig eine sysext von TYPO3 ab Version 4.2
    entweder Du holst sie Dir hier
    http://bugs.typo3.org/view.php?id=6784

    oder do holst die die 4.2beta1 und in typo3/sysext ist sie dabei.

  • Andrea_Herzog Andrea_He...
    Jedi-Meister
    0 x
    432 Beiträge
    0 Hilfreiche Beiträge
    21. 02. 2008, 15:45

    Hallo Steffen,
    so, ein PHP 5 habe ich jetzt und deine Extension installiert.
    Daraufhin habe ich die berühmte Fehlermeldung mit dem zu kleinen Memory-Limit erhalten. Nicht dumm, habe ich den Speicher in der php.ini hochgesetzt. Das hilft aber leider nicht. Dann habe ich mich an den Hoster gewendet und filgende Antwort erhalten:

    Die entsprechende Extension scheint ein Memory Leak zuhaben und egal wieviel Speicher man einräumt. Die Extension überschreitet den Wert. Nutzen Sie bitte eine andere Extension.

    Hast du eine Idee dazu?

    Beste Grüße
    Andrea

  • steffenk steffenk
    Obi-Wan Kenobi
    0 x
    4666 Beiträge
    0 Hilfreiche Beiträge
    21. 02. 2008, 19:14

    ne, das hat nix mit der Extension zu tun, die braucht keinen speziellen Speicher.

    Da ist irgendwas anderes faul.
    Eigentlich braucht Typo3 nur beim fetchen der Extensionliste so viel Speicher, sonst nicht.

    Wenn Du willst kannst mir ja mal einen zugang schicken, dann schau ichs mir an

  • Andrea_Herzog Andrea_He...
    Jedi-Meister
    0 x
    432 Beiträge
    0 Hilfreiche Beiträge
    22. 02. 2008, 19:42

    Hallo Steffen,
    mein Fehler. Es liegt nicht an deiner Extension. Es liegt am CAL 16.2 nach einem Update auf PHP5. Wenn ich das gelöst habe, versuche ich mich noch mal an deinem Login.

    Danke,

    Andrea

  • Andrea_Herzog Andrea_He...
    Jedi-Meister
    0 x
    432 Beiträge
    0 Hilfreiche Beiträge
    29. 02. 2008, 13:57

    Da bin ich wieder.

    Ich möchte fe_login über Marker installieren. Aber das klappt nicht.

    Im Haupttemplate habe ich

    marks.LOGIN < plugin.tx_felogin_pi1

    aber das wird nicht angesprochen. Der Marker wird im FE angezeigt, sonst nichts.
    Auf das entsprechende Template wird dementsprechend auch nicht zugeriffen.

    Was mache ich falsch?

    Gruß

    Andrea

  • Nuevo78 Nuevo78
    TYPO3-Anwärter
    0 x
    7 Beiträge
    0 Hilfreiche Beiträge
    29. 02. 2008, 15:45

    Hi Steffen,
    kann es sein, dass felogin nicht mit typo3 4.1.5 kompatibel ist?
    Ich bekomme diese Fehlermeldung:
    Parse error: parse error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /srv/www/htdocs/web10/html/online/KUNDE/typo3conf/ext/felogin/pi1/class.tx_felogin_pi1.php on line 57

    Gruß
    Tobi

  • Nuevo78 Nuevo78
    TYPO3-Anwärter
    0 x
    7 Beiträge
    0 Hilfreiche Beiträge
    29. 02. 2008, 16:40

    Hat sich erledigt.. auf dem Server war php4 installiert.. #angry#