[Frage] Serverumzug von Webhoster auf lokalen Server TYPO3-Version: 8.7.17

  • M-Tech M-Tech
    Sternenflotten-Admiral
    0 x
    153 Beiträge
    0 Hilfreiche Beiträge
    12. 09. 2018, 18:11

    HAllo Zusammen,

    ich möchte eine fertig erstellte TYPO3-Seite (inkl. Plugins etc) von einem Webhoster auf meinen lokalen Windows 2012 Server umziehen. Meine Frage nun..was ist hier zu tun?

    Ich habe auf meinem Server XAMPP installiert und werde auch noch einen MySQL-Server installieren. GraphicsMagic ist auch schon installiert.

    Was sind die weiteren Schritte? Muss ich zuerst auf meinem lokalen Server ein neues TYPO3-System installieren oder kann ich einfach den kompletten FTP-Ordner kopieren? Wie sieht es denn mit Symlinks aus? Hat jemand einen oder mehrere Tipps für mich?

    Viele Grüße
    Sascha


  • 1
  • pstranghoener pstrangho...
    Die Macht
    0 x
    503 Beiträge
    22 Hilfreiche Beiträge
    19. 09. 2018, 09:55

    Hallo,

    ich mache hier schon mal den Anfang, andere haben bestimmt noch mehr Tipps für dich:

    Eines schon mal vorab: lege Backups an! Von allen Daten und am besten der kompletten Datenbank.

    Dann solltest du die Ordnerstruktur per ssh packen:

    tar cfvz archiv.tar.gz *

    Im nächsten Schritt die Dateien auf den neuen Server per wget (ssh) übertragen:

    wget --no-check-certificate http://domain.tld/archiv.tar.gz

    Folgend die Dateien per ssh entpacken:

    tar xfvz archiv.tar.gz

    Unabdingbar ist das Erstellen eines Datenbank Dump:

    mysqldump -u[username]-p[password]-h[host][database_name] > dump.sql

    Du musst natürlich auch das Ganze auf den neuen Server übertragen, per wget (ssh):

    wget --no-check-certificate http://domain.tld/dump.ssh

    Nun musst du noch die Datenbank einspielen:

    mysql -u[username]-p[password]-h[host][database_name] < dump.sql

    Du musst bestimmt die Datenbank Zugangsdaten in der localconf.php entsprechend den neuen Daten anpassen und uU auch im TypoScript die baseURL anpassen, sollte sich deine Domain ändern.

    VG

  • Teisinger Teisinger
    Jedi-Meister
    0 x
    249 Beiträge
    13 Hilfreiche Beiträge
    19. 09. 2018, 20:38

    ich würde die Ordner vorher aufräumen, sprich alles was *temp* ist bzw. _processed_ etc. löschen / gar nicht erst zippen.

    Datenbank dump - und darauf achten was du eingestellt hast, general/latin/sonstwas

    Für den eigentlichen Umzug brauchst du mindestens:
    fileadmin
    uploads
    typo3conf

    Für gewöhnlich noch:
    .htaccess
    robots.txt
    humans.txt

    sonst wie oben schon erwähnt, die Ordner auf den neuen Server hochladen, Datenbank einspielen - Datenbankzugänge anpassen.
    TYPO3 source hochladen und Symlinks einrichten.
    (https://wiki.typo3.org/Symlinks_on_Windows)

    Auf windows ist glaub ich noch die systemLocale anders als unter linux.

    Alles weitere wären "nur" optimierungen, mit dem oben genannten sollte es aber schon laufen. :)

  • M-Tech M-Tech
    Sternenflotten-Admiral
    0 x
    153 Beiträge
    0 Hilfreiche Beiträge
    20. 09. 2018, 11:27

    Hallo Zusammen,

    vielen Dank für eure Antworten. Also es läuft schon soweit, aber es gibt noch vereinzelt Fehler.

    DirectMail funktioniert irgendwie nicht. Entweder gibt es hier noch Zugriffsprobleme oder es liegt an anderen Dingen. Ich habe DirectMail schon deaktiviert und entfernt (inkl. DB) und wieder aktiviert bzw. installiert, aber der Fehler ist immer noch da, siehe Screenshot. Dann habe ich, während der Generierung noch eine Warnung erhalten. Vielleicht liegt das an Zugriffsrechten? DAnn habe ich im Installtool noch ein paar FEhler/Warnungen. Habt ihr da noch Tipps?

    Viele Grüße
    Sascha

  • M-Tech M-Tech
    Sternenflotten-Admiral
    0 x
    153 Beiträge
    0 Hilfreiche Beiträge
    20. 09. 2018, 11:29

    Ich kann leider keine Screenshots anhängen, keine Ahnung wieso.

    Anbei ein paar Links.

    http://p469648.webspaceconfig.de/fileadmin/allg/error_typo3.JPG
    http://p469648.webspaceconfig.de/fileadmin/allg/error2_typo3.JPG
    http://p469648.webspaceconfig.de/fileadmin/allg/error3_typo3.JPG
    http://p469648.webspaceconfig.de/fileadmin/allg/error4_typo3.JPG

    Viele Grüße
    Sascha

  • 1