[Frage] loginproblem ins backend - php fatal error TYPO3-Version: -

  • efgrib efgrib
    TYPO3-Anwärter
    0 x
    6 Beiträge
    0 Hilfreiche Beiträge
    11. 04. 2014, 20:00

    Hallo,

    ich habe ein Problem mit meinem Hoster (bluehost). Typo3 lässt sich installieren, aber anschliessend ist kein Login möglich. Der Hoster schiebt es auf Typo3, aber da ich das selbe Package (6.2 lts) schon mehrmals woanders installiert habe und auch mit 6.1 das gleiche Problem auftritt, sehe ich das anders.
    Installation läuft ohne Probleme, Datenbanken werden auch korrekt angelegt, nur Login scheitert anschliessend.

    Fehlermeldung bei Typo 6.2:

    PHP Fatal error: Call to a member function fetch() on a non-object in /mydomain/public_html/typo3/sysext/core/Classes/Database/PreparedStatement.php on line 428

    Kann mir irgendwer sagen was das bedeutet oder welche Ursache das haben kann, das ich dem Provider mehr Info geben kann?

    Vielen Dank!

  • Hilfreichster Beitrag

  • prajuritbs prajuritb...
    TYPO3-Anwärter
    1 x
    4 Beiträge
    1 Hilfreiche Beiträge
    12. 11. 2014, 13:49 - Hilfreichster Beitrag

    Hi, es ist ein Fehler deines Hosters. Unter var/lib/php muss das Verzeichniss session 1. vorhanden sein und 2. beschreibbar sein.

    Da du wohl keinen Root-Zugriff hast muss das dein Hoster fixen.


  • 1
  • fab1en fab1en
    Jar Jar Binks
    0 x
    1 Beiträge
    0 Hilfreiche Beiträge
    29. 04. 2014, 09:31

    I stumbled upon this error as well. It turned out the database had some missing tables which made the prepared statements fail silently. After visting the "Install Tool" > "Compare database" tool and updating the schema, everything went as normal.

  • prajuritbs prajuritb...
    TYPO3-Anwärter
    1 x
    4 Beiträge
    1 Hilfreiche Beiträge
    12. 11. 2014, 13:49

    Hi, es ist ein Fehler deines Hosters. Unter var/lib/php muss das Verzeichniss session 1. vorhanden sein und 2. beschreibbar sein.

    Da du wohl keinen Root-Zugriff hast muss das dein Hoster fixen.

  • brainstuff brainstuf...
    TYPO3-Anwärter
    0 x
    4 Beiträge
    0 Hilfreiche Beiträge
    14. 11. 2014, 19:31

    Ich ahtte auch ein Problem mit dem Login ..das kam aber nicht von PHP Einstellungen sondern davon, dass TYPO viel mehr Speicherplatz braucht wie es anzeigt ... ich habe dann den Speicherplatz hochgesetzt ... und dann ging es plötzlich mit dem Einloggen.

  • efgrib efgrib
    TYPO3-Anwärter
    0 x
    6 Beiträge
    0 Hilfreiche Beiträge
    14. 11. 2014, 20:10

    Zitiert von: prajuritbs
    Hi, es ist ein Fehler deines Hosters. Unter var/lib/php muss das Verzeichniss session 1. vorhanden sein und 2. beschreibbar sein.

    Da du wohl keinen Root-Zugriff hast muss das dein Hoster fixen.

    haben mittlerweile den hoster gewechselt deswegen, da bluehost darauf bestand das es nicht an ihnen sondern an typo liegen muss.. (ja klar.... )

  • Flussreiter Flussreit...
    TYPO3-Anwärter
    0 x
    5 Beiträge
    0 Hilfreiche Beiträge
    17. 04. 2015, 19:47

    Zitiert von: efgrib
    Hallo,

    ich habe ein Problem mit meinem Hoster (bluehost). Typo3 lässt sich installieren, aber anschliessend ist kein Login möglich. Der Hoster schiebt es auf Typo3, aber da ich das selbe Package (6.2 lts) schon mehrmals woanders installiert habe und auch mit 6.1 das gleiche Problem auftritt, sehe ich das anders.
    Installation läuft ohne Probleme, Datenbanken werden auch korrekt angelegt, nur Login scheitert anschliessend.

    Fehlermeldung bei Typo 6.2:

    PHP Fatal error: Call to a member function fetch() on a non-object in /mydomain/public_html/typo3/sysext/core/Classes/Database/PreparedStatement.php on line 428

    Kann mir irgendwer sagen was das bedeutet oder welche Ursache das haben kann, das ich dem Provider mehr Info geben kann?

    Vielen Dank!

    Bei uns war es die [b]mysql "be_sessions" Tabelle, diese war beschädigt[/b]. Nachdem wir diese repariert haben konnten wir uns wieder ohne Probleme einloggen.

  • 1