Powermail und Powermail_cond, keine Frontend-Ausgabe + selectbox-filter geht nicht

  • astrula astrula
    Padawan
    0 x
    34 Beiträge
    0 Hilfreiche Beiträge
    23. 04. 2013, 13:34

    Hallo,
    jetzt bin ich wirklich am verzweifeln, ich suche seit mehreren Tagen nach einer Lösung und finde keine!
    Also:
    ich habe Typo3 6.0.4, Powermail 2.0.6 und Powermail_cond 2.0.0 installiert.

    1. Wenn ich eine Bedingung mit Selectbox machen will, dass heisst, wenn in einer Selectbox Affe ausgewählt ist, soll in der anderen Selectbox Banane und Apfel auswählbar sein, verschwindet dieser Auswahl-filter im Backend nachdem ich die Bedingung/Regel speichere.

    2. Wenn ich das Template der Powermail_cond einfüge, wird im Frontend das Formular verschleiert dargestellt und ein Fehler angezeigt: "Error in PowermailCond.js in checkCondtions function by opening the given url"

    Ich habe alle anderen JavaScriptquellen ausgeschaltet.

    Kann mir jemand helfen??????????

    Danke im Voraus

    Astrid


  • 1
  • Gunnarsson Gunnarsso...
    TYPO3-Anwärter
    0 x
    3 Beiträge
    1 Hilfreiche Beiträge
    26. 04. 2013, 11:30

    Hallo Astrid,
    ich kann leider auch nicht helfen, habe aber dasselbe Problem mit derselben Konfiguration.

  • nce nce
    T3PO
    0 x
    16 Beiträge
    0 Hilfreiche Beiträge
    23. 05. 2013, 14:39

    Ich reihe mich zum Punkt "verschleiert" mal ein :( Ich bekomme zwar keine Fehlermeldung, aber wenn das Template included ist, wird das Mailformular praktisch unsichtbar ausgegeben - obwohl im Quelltext alles da ist.

    Template weg -> Formular da, aber natürlich ohne die Funktionen von powermail_cond.

    Vermutlich beißen sich irgendwelche js?

    Im Einsatz befinden sich:
    powermail 2.0.6
    powermail_cond 2.0.0
    und Typo3 6.0.4

  • nce nce
    T3PO
    0 x
    16 Beiträge
    0 Hilfreiche Beiträge
    24. 05. 2013, 23:12

    Kleiner Selbsthelferbericht: Bei einem Update auf Typo3 6.1.1 habe ich [url=http://forge.typo3.org/attachments/23719/realurl_6.1.patch]RealURL gepatscht[/url] und alle [url=http://forge.typo3.org/issues/47686]cf_-Tabellen geleert[/url] - eins von beiden (vermutlich letzteres) hat den Schleier weggezogen und das Formular ist jetzt auch dann normal sichtbar, wenn das powermail_cond Template included ist.

  • Hoge Hoge
    Jedi-Ritter
    0 x
    130 Beiträge
    0 Hilfreiche Beiträge
    28. 05. 2013, 09:11

    Hi, ein wenig kann ich vielleicht zur Lösung beitragen.

    Mit Powermail_Cond wird eine css-Datei (ext/powermail_cond/Resources/Public/Css/PowermailCond.css) eingebunden. Dort wird die opacity erzeugt und kann entsprechend ausgeschaltet werden.

    Auf der Suche bin ich noch nach der Lösung füpr die Fehlermeldung:
    Error in PowermailCond.js in checkCondtions function by opening the given url

    Grüße
    Hoge

  • 1