Ich bekomme folgende Fehlermeldung,...
tx_filelist_pi1 ERROR:
Could not open directory "eadmin/templates/muster/"
wenn ich versuche die Extension auf einer Seite anzuzeigen.
Aus einem nicht nicht bekannten Grund verkürzt sich der Pfad zum Verzeichnis um die ersten 3 Buchstaben "fil"
Richtiger Pfad = "fileadmin/templates/muster/"
Hat jmd ne Idee?
Keiner ne Hinweis/Idee in welche Richtung ich suchen muss?
Hallo beatcasino!
Ich habe seit kurzem ein ähnliches Problem, bei mir wird auch der Pfad abgeschnitten allerdings nicht erst bei "fileadmin":
Could not open directory "ww/typo3/fileadmin/Intranet/Aktuell/Pressespiegel/"
wahrscheinlich liegt es an der neuen Version 1.0.1 von file_list, bei der Sicherheitslücken geschlossen wurden. Ich habe diese vor kurzem installiert. Verwendest du auch die Version 1.0.1?
Ich habe Versucht im TS Setup etwas zu ändern, hat aber nichts geholfen.
Standardeinstellung: plugin.tx_filelist_pi1.root = fileadmin/
Ich bin nächste Woche auf Urlaub, wenn du inzwischen etwas herausfindest wäre das super. Ab 9. Februar kümmere ich mich auch wieder um das Thema.
LG Manfred
Hallo,
ich habe auch ein problem mit der file_list.
bei mir schneidet er allerdings nichts ab, sondern es wird nur das fileadmin-verzeichnis aufgelistet. Sobald ich einen tiefergehendes verzeichnis auflisten möchte, gibt es die fehlermeldung "could not open...".
Geht es bei euch denn, wenn ihr fileadmin listen wollt?
Na bei mir zeigt er neben Dem
halt noch den Abgehackten Pfad an.
Ich bin mit meinem Latein auch am Ende.
hast du schonmal die neue version 1.0.2 ausprobiert? Die ist am samstag released worden. vielleicht löst das ja schon dein problem.
Edit: bei mir hat sich da leider nichts verändert.
Keine Ahnung was geändert wurde, aber seit der Version 1.0.2 hab ich kein Problem mehr!
@jasperr: Vielleicht ein Rechte Problem? Hat Typo3(der Benutzer) Zugriff?
beatcasino schrieb
@jasperr: Vielleicht ein Rechte Problem? Hat Typo3(der Benutzer) Zugriff?
hi,
die idee hatte ich auch schon. allerdings sind die rechte aufgrund früherer rechteprobleme schon auf ein minimun an sicherheit gesetzt (ist auch nur im intranet).
Merkwürdig ist auch die fehlermeldung:
tx_filelist_pi1 ERROR:
Could not open directory "fileadmin\files/"
Der Backslash irritiert mich hier ein bisschen. Ist der richtig? Im backend, in der plug-in-maske ist der pfad richtig angegeben (fileadmin/files/ ).
Im TS ist der standard-pfad vom root (fileadmin/) unangetastet.
Gleiche ich beide pfade an, erscheint der error (egal in welcher kombination):
tx_filelist_pi1 ERROR:
Could not open directory "/"
Zeigen beide pfade auf "fileadmin/" geht es ohne probleme.
EDIT: ich habe auch schon versucht die absoluten pfade auf dem server anzugeben, allerdings auch ohne erfolg...
So richtig hab ich nicht verstanden was dein Problem ist?
Was machst du im TS?
In der Plugin Maske hab ich einfach
/fileadmin/templates/.../.../ stehen. Funkt ganz normal!
beatcasino schrieb
So richtig hab ich nicht verstanden was dein Problem ist?
Was machst du im TS?
In der Plugin Maske hab ich einfach
/fileadmin/templates/.../.../ stehen. Funkt ganz normal!
Mein problem ist, das ich nur den pfad "fileadmin/" auflisten kann. alles andere endet mit einer fehlermeldung ("could not open...")
Ich will aber nicht das ganze verzeichnis fileadmin listen sondern ensprechend dem seitenbaum eine verzeichnisstruktur im fileadmin abbilden. Sprich, der admin stellt das einmal ein und die user können dateien in die verzeichnisse drücken und das FE listet die automatisch.
Im TS hab ich testweise (in meiner verzweifelung) plugin.tx_filelist_pi1.root = fileadmin/ geändert. in diverse werte, die aber alle wieder nur fehlermeldungen gebracht haben.
Also wenn du den Pfad so
/fileadmin/templates/.../.../
in der Plugin Maske eingegeben hast und die Fehlermeldung kommt, würde ich zu nächst die Rechte Situation klären.
Versuch mal unter filadmin/ einen Ordner zu erstellen und zwar über Dateiliste links im Backend Menü.
Dann müssten ja die gleichen Rechte gelten wie für den Zugriff vom Plugin. Weil der Ordner vom Typo3 User erstellt wurde.
beatcasino schrieb
Also wenn du den Pfad so
/fileadmin/templates/.../.../
in der Plugin Maske eingegeben hast und die Fehlermeldung kommt, würde ich zu nächst die Rechte Situation klären.
Versuch mal unter filadmin/ einen Ordner zu erstellen und zwar über Dateiliste links im Backend Menü.
Dann müssten ja die gleichen Rechte gelten wie für den Zugriff vom Plugin. Weil der Ordner vom Typo3 User erstellt wurde.
Hi,
habe deine tip auch mal versucht. leider vergeblich. 🙁
trotzdem danke.
Jasper
Am 30.01.2010 ist die Version 1.0.2 von file_list herausgekommen, die den Bug #6214 behebt. Siehe http://forge.typo3.org/issues/show/6214
Bei mir funktioniert file_list jetzt wieder :-)
Hallo,
ich habe selbiges Problem wie jasperr, dass nur bei fileadmin/ Auswahl im Backend PlugIn die Ansicht korrekt ist und bei Auswahl eines Subfolders die ominöse Fehlermeldung kommt. Ich habe allerdings noch ein weiterführendes Problem, was eventuell Hinweis auf die ursache geben könnte:
Bei Klick auf einen der aufgelisteten fileadmin Ordner im Frontend bekomme ich wiederum die Fehlermeldung "tx_filelist_pi1 ERROR". Die Fehlerhafte Linkstelle im Quellcode befindet sich bei der Extension file_list version 1.0.2 in der Datei /pi1/class.tx_filelist_pi1.php in Zeile 162:
$markers['###FILENAME###'] = '<a href="' . $this->getLink(array('path' => substr($directories[$i]['path'], strlen($this->settings['path'])))) . '">' . $directories[$i]['name'] . '</a>';
Wenn ich z.B. a href="../../fileadmin/downloads" eingebe, funktioniert der Link, auch wenn die Ansicht nachher grausam und ohne Menuleisten etc. daherkommt, da ja die /index.php?id=103&... Angaben fehlen.
Leider fange ich gerade erst mit php und Typo3 an, insofern wäre ich supermega froh, wenn uns jemand helfen könnte, die file_list Extension zum Laufen zu bekommen.
Viele Grüsse
Karin
Hi,
hatte das gleiche Problem mit den "Cannot access"-Fehlern und Backslashes in der URL, die in der Fehlermeldung angegebeben war (ver. 1.0.2).
Das Problem scheint in class.tx_filelist_helper.php zu stecken: in Zeile 175 steht
"$path = realpath($path);"
realpath setzt die Slashes in Backslashes um. Im Anschluss wird dann einfach mit dem entstandenen 'Windows-Pfad' weitergemacht, am Ende wieder ein Slash angehängt...
Ich habe versuchsweise mal die ganze Zeile 175 auskommentiert, jetzt klappt es (weiß aber nicht, ob ich damit jetzt was anderes Wichtiges abgeschaltet habe o.O)
Grüße
Uli