Zum Inhalt springen

Probleme mit init.php bei cli-modulen

Erstellt am 22. Februar 2009 · Noch keine Antworten

Tags: Frage

fatalerror15 ·

Hallo,

ich habe Probleme mit jeglichen cli-Modulen von Typo3. Immer wenn ich eines dieser Module usführen will erhalte ich folgende Fehlermeldung:

X-Powered-By: PHP/5.2.0-8+etch13 Content-type: text/html Error in init.php: Path to TYPO3 main dir could not be resolved correctly.

This happens if the last 6 characters of this path, / ($temp_path), is NOT "typo3/" for some reason.
You may have a strange server configuration. Or maybe you didn't set constant TYPO3_MOD_PATH in your module?

If you want to debug this issue, please edit typo3/init.php of your TYPO3 source and search for the die() call right after this line (search for this text to find)...

If you expect any help from anybody on this issue, you should save this page as an html document and send it along with your request for help!
--------------------------------------------------------------------------------

Array
(
[TYPO3_OS] =>
[PATH_thisScript] =>
[php_sapi_name()] => cgi-fcgi
[TYPO3_MOD_PATH] => ../typo3/ext/dam_cron/cron/
[PATH_TRANSLATED] =>
[SCRIPT_FILENAME] =>
)

Diese Fehlermeldung ist jetzt von dam_cron. Aber auch die extetion "crawler" bringt diese Fhlermeldung (natürlich mit einem anderen Array).
Das Problem tritt bei allen von mir installierten Webservern auf. Ich hatte jetzt schon mehrere Konstellationen (Debian, RHEL5 und RHEL5 mit XAMPP fallen mir auf anhieb ein). Wie kann ich denn die module zum laufen bekommen? Hat soetwas schon mal jemand gefixt???

Danke für eure Hilfe!