hallo alle zusammen,
bevor ich mit meinem problem los lege möchte ich mich dafür entschuldigen falls ich einen mehraufwand durch meinen post mache, aber nach zahlreichen google suchen bin ich einfach nicht fündig geworden. so sehe ich die letzte möglichkeit auf heilung nur noch in euch. 🙂
also kommen wir nun zu meinem problem:
undzwar bin ich der admin für einen server in einem verein. es ist so, dass wir nun uns von unseren jetztigen webspace anbieter trennen wollen und uns unseren eigenen server aufstellen wollen. soweit so gut.
um das wechseln der server, bzgl typo3, etwas leichter zu machen habe ich mir gedacht, ich lade mir die komplette typo3 ordner incl. datenbank dump runter und spiele mir das auf das neue server auf.
sooo ganz falsch lage ich auch nicht mit meinem gedanken.
bis auf das eine problem, dass die links nicht richtig vom typo3 aufgelöst werden läuft das alles schon. auf dem alten server werden die links (urls) richtig vom typo3 erkannt und aufgelöst. auf dem neuen server leider nicht.
ein beispiel:
alter server: www.domain.de/123.0.html wird richtig erkannt und angezeigt
neuer server: www.domain.de/123.0.html wird nicht richtig erkannt und es erscheint die fehlermeldung vom apache
Not Found The requested URL /123.0.html was not found on this server.
probiere ich jedoch www.domain.de/index.php?id=123 aus wird die seite richtig angezeigt...
die extensions sind auf beiden systemen identisch.
vielleicht noch ein paar randinformationen:
- typo3 versionen:
-- alter server ist 3.8.0
-- neuer server: 4.2.4
- php version 5.2.4
- das ganze läuft auf einem linux system
ich hoffe ihr könnt mir weiterhelfen
vielen dank im voraus
Hallo nEwTaTToo,
Dein Beispiel:
alter server: www.domain.de/123.0.html wird richtig erkannt und angezeigt
neuer server: www.domain.de/123.0.html wird nicht richtig erkannt und es erscheint die fehlermeldung vom apache
Not Found The requested URL /123.0.html was not found on this server.
probiere ich jedoch www.domain.de/index.php?id=123 aus wird die seite richtig angezeigt...
sagt uns nicht, wo und wie die Seite auf dem neuen Server erreicht wird.
Betreibst Du einen eigenen DNS-Server?
Ist der neue Server im Internet erreichbar?
Oder steht der erst mal nur im Verein (lokal erreichbar)?
Mit ein paar Infos läßt sich Deine Problem 8wahrscheinlich) leicht lösen.
Gruss
Hi,
nEwTaTToo schrieb
ein beispiel:
alter server: www.domain.de/123.0.html wird richtig erkannt und angezeigt
neuer server: www.domain.de/123.0.html wird nicht richtig erkannt und es erscheint die fehlermeldung vom apache
Not Found The requested URL /123.0.html was not found on this server.
probiere ich jedoch www.domain.de/index.php?id=123 aus wird die seite richtig angezeigt...
Dir ist wahrscheinlich bei kopieren die .htaccess "verloren" gegangen,
weil es eine versteckte Datei ist. Also einfach mal im Hauptverzeichnis
eine neue, z.B. mit folgendem Inhalt anlegen:
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^typo3$ typo3/index_re.php
RewriteRule ^[^/]*\.html$ index.php
Gruss Tom
hallo zusammen,
sorry das ich erst jetzt schreibe.
@tandem:
der server steht bei einem webhosting betreiber und ist aus dem netz erreichbar.
@tom:
das lag wirklich an der htaccess datei.
die hatte ich zwar mit kopiert, bin jedoch davon ausgegangen das diese auch vom apache server akzeptiert und bearbeitet wird, war jedoch nicht so 🙁
nachdem ich das nun gefixt habe kommt leider die fehlermeldung von typo3:
Error!
Reason: File "123.0.html" was not found!
habt ihr vielleicht noch so einen glorreiche idee? 🙂
kann das was damit zu tun haben, dass die so einen riesen sprung gemacht habe, von version 3.8.0 auf 4.2.4?
viele grüße
Hallo nEwTaTToo,
hast Du alle Caches geleert?
Auch die temp* Dateien in typo3conf?
Gruss
Hallo,
Du hast die Version 4.2.4 installiert.
Da war doch irgendwas??? - ist zügig (nach Problemen) durch 4.2.5 ersetzt worden.
Nimm auf jeden Fall die 4.2.5
Gruss
hallo,
ein update hat leider auch nichts gebracht. 🙁
immer noch die selbe fehlermeldung von typo3:
Error!
Reason: File "123.0.html" was not found!
mal eine andere frage am rande:
ist es eigentlich ratsam das verhalten von typo3 immer noch bei v3.8 zu lassen?
ich hab nämlich schon beides ausprobiert, hat jedoch auch nichts gebracht!
hallo alle zusammen,
ich hab es endlich geschaft.
natürlich auch mit eurer hilfe... 😉
ich hatte auch mal RealURL extension installiert und nachdem ich das ding jetzt entfernt habe tut es dat ding auch 🙂
danke auch
super forum hier
vielen dank 🙂
Hallo nEwTaTToo,
schön - dann kannst Du das Problem ja (auch hier) abhaken 😃
Gruss