Zum Inhalt springen

Ausgabe von Lauftext enthält HTML Code

Erstellt am 13. August 2008 · 3 Antworten · letzte Antwort am 30. August 2008

Tags: Frage

genua ·

Hallo

Wir haben mehrere Websites bei einem Hoster auf dem gleichen Server laufen. Seit Ende letzter Woche werden auf den Seiten plötzlich im "Fliesstext" HTML Tags oder Teile davon ausgegeben. Dies geschieht aber fast willkürlich. Die Einträge in der Datenbank sind korrekt d.h identisch mit den Einträgen deren Ausgabe keine Fehler aufweisen. Fehlerhafte Ausgaben können so von anderen nicht unterschieden werden. Besonders betroffen sind die HTML Tags für Links (in der DB mit dem Tag <link> -> wird bei der Ausgabe zu einem <a> geparst), Listen (<ul> und <li>), Bold (<b> ) wie auch der Zeilenumbruch (<br>).

Beispiel einer fehlerhaften Anzeige:
Homepage: target="_blank" class="external-link-new-window" >ww.peterglauser.ch

Wenn ich im Backend die PhpMyAdmin Extension aufrufe, so bekomme ich solche Fehlermeldungen:
Warning: mb_ereg() [function.mb-ereg]: mbregex compile err: premature end of char-class in /home/httpd/vhosts/xxx.xx/subdomains/www.xxx./httpdocs/typo3conf/ext/phpmyadmin/res/phpMyAdmin-2.11.7-all-languages/libraries/check_user_privileges.lib.php on line 67

einpraegsam.​net ·
genua schrieb

Beispiel einer fehlerhaften Anzeige:
Homepage: target="_blank" class="external-link-new-window" >ww.peterglauser.ch

Warum gibt es so eine Ausgabe? Wie ist der Quelltext hierzu? Was sagt Tidy? Gibt es Fehler im HTMl?

genua ·

Der HTML Code vom unteren Beispiel sieht wie folgt aus:

Homepage: <a href="http://www.peterglauser.ch" title="Öffnet externen Link in neuem Fenster"> target="_blank" class="external-link-new-window">www.peterglauser.ch</a>

Der Tag wird bereits nach dem Attribut title wieder geschlossen. Die weiteren Attribute sind dann auf der Website sichtbar.

Wenn ich auf den betroffenen Sites den FE Cache lösche, kann dies für eine temporäre Beruhigung der Situation führen, später wird der Fehler wieder produziert. Es scheint, dass das Auslesen aus der DB nicht richtig vollzogen wird, und diese Seiten dann im Cache mangelhaft abgelegt sind. Es sind immer wieder andere Seiten einer Website betroffen.

genua ·

Das Problem hat sich "gelöst". Auf Bitte wurde ein PHP Downgrade von der Version 5.2.x auf 5.1.6 vorgenommen. Nun laufen die Instanzen wieder fehlerfrei.