Zum Inhalt springen

Fehlermeldung mit cache_hash Tabelle

Erstellt am 22. Juni 2008 · 3 Antworten · letzte Antwort am 18. Februar 2010

Tags: Frage

Roger08 ·

Hallo,

bei einem DB-Dump erscheint diese Fehlermeldung:
Got error: 1016: Can't open file: 'cache_hash.MYI' (errno: 145) when using LOCK TABLES

Ein DB-Compare bringt folgenden Hinweis:
Add tables
CREATE TABLE cache_hash (
hash varchar(32) NOT NULL default '',
content mediumblob NOT NULL,
tstamp int(11) unsigned NOT NULL default '0',
ident varchar(20) NOT NULL default '',
PRIMARY KEY (hash)
) TYPE=InnoDB;

Das Neuschreiben der Tabelle misslingt aber wohl - es wird immer noch vorgeschlagen.

Es ist nicht s am Code geändert worden. Wie bekomme ich das wider hin ?

Roland

Roger08 ·

... ein offensichtliches MySQL-Problem.

errno: 145 bedeutet:
MySQL error code 145: Table was marked as crashed and should be repaired.

Mit PHPMyadmin kann ich die Tabelle cache_hash nicht öffnen. Fehlermeldung:

Bild: ctrl.mynetcologne.de/fehlermeldung.jpg

Was steht in der Tabelle cache_hash ? Kann ich die bedenkenlos löschen ?

Ich hätte das Problem gerne schnellstens gelöst. Die errorlog-Datei ist zuletzt bis auf 17 GB angeschwollen, bis ich's gemerkt habe. Da ging nix mehr. Immer die gleiche Zeile:
PHP Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /srv/www/xxx/httpdocs/typo3_src-4.1.1/t3lib/class.t3lib_db.php on line 796

Roland

junges ·

Hi,

da würde ich mal mit den Mysql Tools die Tabelle reparieren...

# mysqlcheck --all-databases --auto-repair -u root -p

ggf. musst du den User root durch Deinen MySQl Benutzer ersetzen und dann natürlich ein Passwort (falls benötigt)