Hallo.
Seit heute sehe ich bei drei verschiedenen separaten TYPO3 Installationen folgende Fehlermeldung im Backend auftauchen (und auch teils von selbst wieder verschwinden!):
ERROR: Input filepath "/home/bla/bla/bla/typo3temp/llxml/_6b38bd813c.default.iso-8859-1.cache" was generally invalid!
Googlen nach dem Fehler brachte folgendes zutage:
-- eventuell wird der Fehler unter bestimmten Bedingungen auch im FE ausgegeben, man findet entsprechende Treffer.
-- es kommt aus function writeFileToTypo3tempDir in t3lib/class.t3lib_div.php.
Hacks workarounds soweit:
-- touch /home/...../_blabla.cache (genau den file eben)
Ursache scheint zu sein, dass pathinfo in der Zeile:
$fI = pathinfo($filepath);
folgendes leer laesst:
$fI['basename'] und
$fI['filename']
Folgender uebler hack scheint das Problem fuer mich zunaechst mal zu loesen, um die zeile 2500:
$fI = pathinfo($filepath);
$fI['dirname'].= '/';
// start hack
if($fI['basename']=='') {
$pi=explode('_',$filepath);
if(preg_match('/llxml/s',$pi[0])) {
$fI['basename']='_'.$pi[1];
$jjjfn=explode('.',$pi[0]);
$fI['filename']=$jjjfn[0].'.'.$jjjfn[1].'.'.$jjjfn[2];
}
}
// end hack
Aber das ist ja kein Zustand. Hat jemand das schon mal gesehen, jemand einen Tipp fuer mich?
Zu den Installationen: TYPO3 4.1.5, PHP 5.2, an sich laeuft alles rund, Updates habe ich in letzter Zeit keine laufen gelassen, zum ersten mal habe ich den Fehler bei der Arbeit mit rs_userimp gesehen. Ich logge PHP Fehlermeldungen - aber wenn dieser Fehler auftritt im BE landet kein PHP Fehler im Log.