Hallo star,
*EDIT*
Thomas Mammitzsch hat eine neue Version (0.0.9) ins Repository geladen, somit sollten die Probleme gelöst sein & der Rest des Postings hinfällig.
/Resolved
*/EDIT*
ich habe die selbe Shoutbox in den letzten Tagen bei mir installiert, und habe es tatsächlich geschafft.
In dem Manual sind leider einige Fehler (insb. ist der name falsch geschrieben), und auch die Extension ist halt noch "alpha" - so ist sie zb. anscheinend nicht mit mysql 4.x kompatibel.
Ich habe nun einige Änderungen vorgenommen und mich mit dem Autor der Extension in Verbindung gesetzt, und hoffe das er Zeit findet sich das ganze anzusehen.
Falls meine Änderungen übernommen werden sollten, wäre die neue Version nicht abwärtskompatibel zu der alten, dafür aber mit mysql 4.x lauffähig.
Falls du die Extension dennoch installieren möchtest, hier meine vorgehensweise:
Diese "Anleitung" bezieht sich auf die Version 0.0.8 der tx_vxxajaxshoutbox.
-----
1.
Nach dem install erstmal prüfen, ob die Änderungen in der Datenbank ausgeführt wurden. Hier war bei mir das erste Problem.
Es sollte eine neue Tabelle Namens "tx_vxxajaxshoutbox_messages" angelegt worden sein, falls nicht, musst du das manuell tun. Ich gehe davon aus das es dieses problem nur unter mysql4 oder früher vorkommt.
Der sql-befehl:
CREATE TABLE tx_vxxajaxshoutbox_messages (
uid int(11) NOT NULL auto_increment,
cr_date timestamp NOT NULL default NULL,
name tinytext NOT NULL,
text tinytext NOT NULL,
PRIMARY KEY (uid)
);
Falls das nicht klappt, lösch die Zeile mit cr_date und erstell das feld nachher einzeln, wichtig ist in der öffentlichen version das default null, so wird die eintrags-zeit von mysql eingefügt.
-----
2. Um die Extension auf allen Seiten anzuzeigen, erstelle in deinem Haupt-Template einen neuen Marker, bei mir ist's ###SHOUTBOX###
Nun folgenden Code ins Template-Setup:
# in diesem Stylesheet sind auch die Formatierungen für die Shoutbox
# untergebracht, da die im Template vorhandenen nicht ausgelesen werden,
# sondern andere, unter _CSS_DEFAULT_STYLE gespeicherte.
page.stylesheet = fileadmin/templates/default/style.css
plugin.tx_vxxajaxshoutbox_pi1 {
templateFile = fileadmin/templates/default/template_shout.html
useSmilies = 0
useFadeEffect = 0
_CSS_DEFAULT_STYLE =
_LOCAL_LANG {
de {
message = Nachricht
name = Name
noscript = Bitte JavaScript aktivieren
submit_button_label = send
messageError = Bitte einen Text eingeben
nameError = Bitte einen Namen eingeben
}
}
}
page.10.marks.SHOUTBOX < plugin.tx_vxxajaxshoutbox_pi1
Natürlich muss weiterhin vx_xajax_shoutbox in die Include static.
Den Setup-code hab ich von mir kopiert, den _local_lang teil kannst du ggf. weglassen, insb. da dort schon einige übersetzungen drin sind, die ich selbst eingefügt habe.
Die Pfade zu dem template und stylesheet musst du natürlich noch an deine umgebung anpassen.
So sollte es, denke ich, laufen 🙂
MfG Happy
PS: Mein erster Eintrag *g*