Fatal error: Failed opening required '../init.php' (include_path='.:/usr/share/php') in /home/www/web1/html/cms/htdocs/testsite35/index.php on line 52
...beim Seitenaufruf der FE-Startseite.
Die Datei index.php in testsite35 ist ja da. nur die init.php ist eben nicht in testsite35, sondern hier /htdocs/typo3_src-3.5.0/typo3
Also ein Symlinkproblem(?)
Kann ja nicht einfach den init.php-Pfad in der index.php ändern.
Ist doch nicht der Sinn der Sache, oder?
Safemode ist schon off, ohne Erfolg.
*help*help*help*help*help*help*help*help*
picrasso schriebDie Datei index.php in testsite35 ist ja da. nur die init.php ist eben nicht in testsite35, sondern hier /htdocs/typo3_src-3.5.0/typo3
Also ein Symlinkproblem(?)
Wenn Du alles richtig gemacht hast, dann ist in deinem Testsite-Verzeichnis ein Symlink auf typo3 aus der Source-Distribution.
Ansonsten: http://typo3.sunsite.dk/unix-archives/ und Infos lesen!
Gruss - michael
Also in meinem Testsiteverzeichnis /htdocs/testsite35 ist der symlink typo3, welcher auf /htdocs/typo3_src-3.5.0/typo3 zeigt.
Habe mal in der Index.php von der testsite35 in der entsprechenden Zeile (siehe oben Fehlermeldung) aus
../init.php
typo3/init.php
gemacht.
Dann kam nicht mehr diese Fehlermeldung, sondern diese hier:
Error in init.php: sitepath not specified correctly.
This happens if the last 6 characters of this path, /home/www/web1/html/cms/htdocs/testsite35/, ($temp_path) is NOT 'typo3/' for some reason.
Or did you set constant TYPO3_MOD_PATH in your module?
If you expect any help from anybody on this issue, you should save this page as an html document and send it along with your request for help!
--------------------------------------------------------------------------------
Array
(
[TYPO3_OS] =>
[PATH_thisScript] => /home/www/web1/html/cms/htdocs/testsite35/index.php
[php_sapi_name()] => apache
[TYPO3_MOD_PATH] => install/
[PATH_TRANSLATED] => /home/www/web1/html/cms/htdocs/testsite35/index.php
[SCRIPT_FILENAME] => /home/www/web1/html/cms/htdocs/testsite35/index.php
)
Verwendest Du open-basedir? Das macht soweit ich weiss einige Probleme...
Gruss
hi chip,
open was?
sorry, kenne mich in unix nicht besonders aus. eigentlich ist hier jemand anderes dafür zuständig und dieser ist im moment nicht anwesend.
Das ist eine PHP-Option. Siehe dazu www.php.net und erstelle (zum Prüfen) mal eine Datei info.php mit folgendem Inhalt:
<?php
phpinfo();
?>
Dann rufst Du dieses File im Browser auf und siehst alle PHP-Einstellungen.
Gruss - michael
hab einfach mal die php.info aufgerufen. also der local value für open_basedir ist gesetzt /home/www/web1/ und für master value ist kein wert eingetragen.
Versuch das mal auszuschalten!
Such mal deinen Webroot nach .htaccess-Files ab, die "basedir" enthalten. Evtl. steht auch etwas in deiner php.ini (da musst Du nachher aber den Apache neu laden).
Gruss - michael
habe den fehler gefunden.
im ordner testsite mußte ich noch nen symlink setzen
tslib/index_ts.php --> index.php
nun gehts......! yeah!