Zum Inhalt springen

Problem mit pdf generator!

Erstellt am 9. Oktober 2003 · 13 Antworten · letzte Antwort am 17. Februar 2004

Tags: Frage

Dagsta ·

Hi

Ich wollte den pdf generator benutzen!

links wurden auch angezeit und so aber die pdf die erzeugt wurde enthielt nur den seitennamen und ne sietenzahl
aber nicht meinen inhalt!

Also habe ich folgendes probiert:
pdf_generator = PAGE
pdf_generator < page
pdf_generator.typeNum = 125
danach kam aber anstelle einer pdf folgende meldung:

Error while executing (or trying to execute) htmldoc
Maybe the gen_pdf.php script was not executed at all.

Wenn ich das jetzt wieder auskommentiere kommt eine leere html seite!

was kann ich tun?

THX

Dagsta

timzim ·

Soweit ich weiß, ist htmldoc doch Voraussetzung für den pdf-generator, oder!? Ist htmldoc denn vorhanden/aktiv? Leider hab' ich den pdf-generator auch noch nicxht am laufen, mich würde aber interesseiren wie es funzt. Gelesen hab' ich aber, dass htmldoc Voraussetzung ist.

32BitOptimist ·

Hallo Leutz,

dann sitzen wir ja alle im gleichen boot 🙂

muss das ding auch noch zum laufen bringen.

habt ihr die eigenarten von htmldocs beachtet, der kann wohl noch kein richtiges html 4.0.

evtl. mal mit ner dummyseite probieren, die nur text enthält?!

htmldocs hat als windows-GUI saube funktioniert. wahrscheinlich isses ein config-problem.

32BitOptimist ·

Ok, hab den Generator mit HTMLDochs halbwegs zum laufen gebracht. Was mir allerdings aufgefallen ist, dass der Generator nur die Content-Inhalte umwandelt. Alles was nich im Seiteninhalt steht, wird ignoriert (Plugins, Inhaltsobjekte...)

:/

JensE ·

@Dagsta:
htmldoc scheint ja schonmal zu laufen (sonst hättest Du überhaupt kein PDF erhalten).
Das Problem bei Dir könnte sein, daß USER_INT Objekte (d.h. dynamische Plugin-Inhalte die nach dem cachen eingesetzt werden) z.Zt. noch nicht dargestellt werden. (Ich arbeite daran.....) normale statische Elemente sind jedoch problemlos verwendbar.
Ein anderes Problem könnte sein, daß Du Inhalt darstellen wills der nicht im main Content sondern in der rechten, linken oder einer anderen Spalte ist. In diesem Fall mußt Du die vordefinierte PDF-Seite erweitern z.B. (aus dem Kopf, ohne Garantie):

pdf_generator.60 = CONTENT
pdf_generator.60 < styles.content.getLeft

Gruß, Jens

outdoor ·

Habe ein ähnlices Problem wie dagsta, sprich die gleiche Error-Msg:

Der Link wird erstellt und sieht meines Erachtens ganz passabel aus:
http://test.server.com/index.php?id=43&no_cache=1&type=123&uid

Das Resultat:
Error while executing (or trying to execute) htmldoc
Maybe the gen_pdf.php script was not executed at all.

Hmmm...htmldoc funktioniert im Terminal-Mode einwandfrei und auch via php-test-script, denn:

<?php
 system("/opt/home3/outdoor/apps/bin/htmldoc --webpage -f dummy.pdf dummy.html");
?>

...generiert mir ein wunderhübsches pdf....
auch die Permissions von gen_pdf.php stimmen

TS kommt folgendermassen daher:

temp.PDFGEN = IMAGE
temp.PDFGEN.file = fileadmin/pix/icons/pdf.jpg
temp.PDFGEN.imageLinkWrap = 1 
temp.PDFGEN.imageLinkWrap.enable = 1
temp.PDFGEN.plugin.pdf_generator.typeNum = {$extension.pdf_generator.typeNum}
temp.PDFGEN.plugin.pdf_generator.config.pageGenScript = EXT:pdf_generator/gen_pdf.php
temp.PDFGEN.plugin.pdf_generator.config.additionalHeaders = Content-Type: application/pdf
temp.PDFGEN.plugin.pdf_generator.config.admPanel = 1
temp.PDFGEN.imageLinkWrap.typolink{
  target = _new
  parameter.data = field:uid
  #parameter.wrap = |,123
  no_cache = 1
  additionalParams = &type=123&uid
  ATagBeforeWrap = 1
  wrap = | <br>
}
temp.PDFGEN.stdWrap.postUserFunc = tx_pdfgenerator->makePdfLink
temp.PDFGEN.postUserFunc.target = _new
temp.PDFGEN.postUserFunc.include_post_vars = 1

page.7 >
page.7 < temp.PDFGEN

JensA: Du hast hier eine erklärung abgegeben, die ich nicht ganz kapiere,

Das Problem bei Dir könnte sein, daß USER_INT Objekte (d.h. dynamische Plugin-Inhalte die nach dem cachen eingesetzt werden) z.Zt. noch nicht dargestellt werden.

kannst Du mir hier etwas auf die Sprünge helfen, falls mein Fehler hier daheim ist?

Vielen Dank
Outdoor

timzim ·

Also ich habe nun ein anderes Problem, das aber auch mit htmldoc zusammenhängt. Bei mir werden die deutschen Umlaute nicht dargestellt. Habe bei der Doku von htmldoc etwas von -charset gelesen, hab's ausporbiert, funktioniert aber nicht. Hat jemand eine Idee oder den ganeuen Befehl dafür?

outdoor ·

Hi Timzim:

Hast Du hierfür ein binary-pack verwendet, oder die source selber kompilliert? Welche Plattform benutzt Du?

Falls Du ein binary-Packet genommen hast und auf der Plattform auf der das Zeug seinerzeit kompiliert wurde keine deutsche Zeichensätze installiert waren, ist es gut möglich, dass diese bei Dir anschliessend nicht richtig dargestellt werden.

In diesem Falle empfehle ich Dir unter Linux/UNIX, das source.tar.gz runterzuladen und selber zu kompilieren. Unter Win kann ich Dir leider nicht helfen - sorry.

Der Aufruf aus dem Folder htmldoc-1.8.23 lautet folgendermassen:

./configure --prefix=/path/to/htmldoc --with-fltk-includes=/path/to/required/fltk_includes --with-fltk-
libs=/path/to/required/ftlt_lib 

make

make install

Die zwei Aufrufe --with-fltk-includes und --with-fltk-libs sind dabei optional, und nur notwendig, wenn du das zugehörige GUI miterstellen willst.

Gruss
outdoor

outdoor ·

Hmmm...kann mir bei meinem Task *wirklich* niemand helfen...weiss immer noch nicht, wo das Problem steckt. HTMLDOC funktioniert an sich wirklich prima, aber via Typo3 erhalte ich noch immer dieselbe Fehlermeldung

Gruss
Outdoor

crewler ·

schade das problem mit den ä, ö und ü habe ich auch

der befehl in htmldoc heißt zwar --charset, aber auch dann hat es nichts bei mir gebracht. #evil#

weiß keiner rat? :o

crewler

JensE ·

Falls noch jemand das Problem mit den Umlauten hat:
Das Problem scheint eine fehlerhafte/unvollständige htmldoc Installation zu sein, es tritt dann auf, wenn Teil von htmldoc fehlen die normalerweise in /usr/share/htmldoc/data angesiedelt sind.

Gruß, Jens

alibaba ·

Wie schon der JensE erwähnt hat, liegt das Problem an fehlerhafte HTMLDOC Installation.
Um HTMLDOC zu installieren braucht man keinen Root Zugriff, Shell Zugriff auf das Webspace schon. Wenn kein Shell möglich ist, konnte man PHP-Shell benutzen, dabei soll Safe-Mode local OFF sein.

1. Lade von der Seite http://www.easysw.com/htmldoc/software.php die Datei „htmldoc-1.8.23-source.tar.gz“ (für Linux)
2. Spiele diese Datei auf dein Webaccount auf.
3. Erstelle ein Verzeichnis innerhalb deines Webspaces z.B. MY-HTMLDOC. In dieses Verzeichnis wirst du später HTMLDOC-Software installieren. Um sicher zu gehen Chmode das Verzeichnis MY-HTMLDOC mit 777.
4. Shell Befehle

  • a. gunzip htmldoc-1.8.23-source.tar.gz ENTER
    b. tar xf htmldoc-1.8.23-source.tar ENTER
    c. cd htmldoc-1.8.23 ENTER
    d. configure -?prefix=/dein/pfad/vom/root/MY-HTMLDOC ENTER
    e. make; make install ENTER

5. Plugin PDF- Generator installieren als Pfad zum HTMLDOC- Interpreter folgendes eingeben: /dein/pfad/vom/root/MY-HTMLDOC/htmldoc/bin/htmldoc.
6. Fertig! Deutsche Umlaute sollen da sein.

outdoor ·

Hi Alibaba,

Erst mal: Danke für Deine Antwort.

Das einzige , dass bei mir anders war, waren die permissions (ich habe eine naturgegebene Abneigung executables auf 777 zu setzen)

Aber auch wenn ich das tue: der Effekt bleibt derselbe. Muss hinzufügen, dass ich nicht unter Linux, sondern unter solaris8 on sparc arbeite. Kompilliert habe ich den Kram mit gcc 3.3. Kann mir aber kaum vorstellen, dass die Plattform oder die ggc-version der Grund sein könnte.

Interessant ist, dass wenn ich htmldoc via terminal aufrufe, das ganze einwandfrei klappt. Das die htmldoc-install fehlerhaft arbeitet oder irgendwelche libs nicht findet, kann ich insofern ausschliessen. Ich frage mich, ob das Problem nicht beim gen_pdf.php script sitzt. Die Fehlermeldung zielt ja auch auf das hin.

However - und ich geb's ungern zu, aber ich weiss mittlerweile echt nicht mehr, wo ich noch ansetzen muss.

Gruss und good night
Outdoor

mcmz ·

Also ich hatte auch ein laufendes "PDF generator" jedöns wat probleme mit den umlauten (ä,ü,ö,ß usw.) hatte.

Hab dann nochmal alibabas schritte verfolgt und siehe da. das problem war behoben.

Hatte klug wie ich war vorher keinen ordner wie z.B. ("MY-HTMLDOC") angelegt und somit war die configuration mit --prefix auch für die katz.

das ganze geschah auf: nicht root -> linux.