Zum Inhalt springen

pdf_generator2 ignoriert css/stylesheets

Erstellt am 27. März 2007 · 4 Antworten · letzte Antwort am 16. Mai 2013

Tags: Frage

dwildt ·

Hallo,
ich habe das Problem, dass die Extension pdf_generator2 css/stylesheets ignoriert.
Die CSS-Angaben sind komplett in externen CSS-Dateien. Der Witz:
Im Referenzsystem - im Intranet - funktioniert alles (Typo 3.8-).
Daher habe ich den Verdacht, dass der Fehler nicht an der Extension liegt, sondern an Einstellungen von Apache oder PHP (Linux-Server).
Ich habe alle für mich nachvollziehbaren Konfigurationsmöglichkeiten geprüft, und finde keine Unterscheide zwischen Inter- und Intranet.
Hat jemand mal ein ähnliches Problem gehabt?

Viele Grüße
Dirk Wildt
think-visually.com

dwildt ·

Es scheint kein Problem des pdf_generators zu sein, sondern eher ein Problem der vom generator verwendeten Software html2ps und der Konfiguration des Apache-Webservers.
Für html2ps gibt es ein eigenes Forum. Ich habe mein Problem dort gehostet.
Siehe http://forum.tufat.com/showthread.php?t=33479
Sollte ich den Fehler lösen können, hinterlasse ich hier eine entsprechende Nachricht.

dwildt ·

Lösung: Falscher DNS-Server

Der pdf_generator2 bzw. html2ps ruft die als PDF zu generierende Seite und ihre Elemente wie Stylesheets und Bilder mehrfach per http:// auf.

Der Fehler lag in diesem Fall daran, dass die eingetragenen DNS-Server die Domain, auf der der pdf_generator2 genutzt wird, nicht kannten.

Nach dem Eintrag der "richtigen" DNS-Server funktioniert der pdf_generator2 fast einwandfrei - die Performance konnte verbessert werden.

Optimale Performance

Da der pdf_generator2 die als PDF zu generierende Seite und ihre Elemente mehrfach per http:// aufruft, sollten nach Möglichkeit gar keine DNS-Server angefragt werden, da dies unnötig Performance kostet.

Die Performance kann durch eine entsprechende Pflege der Datei /etc/hosts optimiert werden:

# cd /etc/
# pico hosts
...
127.0.0.2 www.meine-domain.de
...
# rcapache2 reload

Benjamecho ·

Da ich keinen direkten Zugriff auf /etc/hosts habe (hätte den Provider fragen müssen), habe ich soeben ausprobiert das CSS direkt über headerData einzubinden, was problemlos funktioniert hat. Vielleicht kann's ja mal jemand gebrauchen:

pdf_generator {
  headerData {
    1 = TEXT
    1.value (
	<style type="text/css">
		h1{ font-size:17px; }
		/* ... */
	</style>
    )
  }
}

:p