Zum Inhalt springen

Anmeldeproblem

Erstellt am 27. Februar 2007 · 1 Antwort · letzte Antwort am 28. Februar 2007

Tags: Frage

MrAbbey ·

Hallo

Ich habe folgendes Problem mit Version 3.7 und 3.81. (Als dummy, bzw als Quickstart).Ich will beides auf einem W2K3 Server mit IIS6.0 und MySQL zum laufen bringen.
PHP Version: 5.2.1
MySql Version: 5.1

Die Installation funktioniert auch wunderbar (zumindest bringt sie keinen Fehler und die Datenbank mit Tabellen wird angelegt).

Wenn ich mich dann aber im BE anmelden will, kommt:

"Your login attempt did not succeed. Make sure to spell your username and password correctly, including upper/lowercase characters.".

Über das Install-script will ich einen neuen admin User anlegen. Es kommt eine Fehlermeldung, wenn der User "admin" erneut angelegt ewerden soll, bei anderen kommt keine Fehlermeldung, es wird aber auch nichts angelegt.

In der sys_log Tabelle erscheinen folgende EInträge:

Login-attempt from %s (%s), username '%s' not foun...

Andere Scripte, die auf die Datenbank zugreifen, haben keinerlei Probleme.
Hat jemand eine Idee, woran das liegen könnte?

Thx vorab, Oliver

MrAbbey ·

Problem gelöst.

Es hängt an der MySql Version. In der my.ini

# Set the SQL mode to strict
Folgende Zeile muss auskommentiert werden
#sql-mode="STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"

und durch diese ersetzt werden
sql-mode="MYSQL4"

Dann gehts.