HILFE
Hab die Anleitung von http://www.typo3-media.com/blog/article/utf8-and-typo3.html zur Umstellung von Typo3 auf UTF 8 befolgt und bei dem Punkt bei dem man "SET NAMES utf8 SET CHARACTER SET utf8" in "setDBinit" im Install Tool einträgt hats mir irgendwas beim Templa Voila verschissen...
Ich bekomme seitdem ständig die Fehlermeldung
"Template Object could not be unserialized successfully.
Are you sure you saved mapping information into Template Object with UID "28"?"
Hilfe muss mit der Seite in 2 Tagen Online gehen und weiss jetzt nicht so ganz was ich machen soll
Hallo Schnitzlkloper,
vermutlich etwas zu spät, aber vielleicht hilft es ja wem anderen.
Ich hatte heute geanu dasselbe Problem. Die Umstellung von DBInit auf "set names..." hat dazugeführt, dass das Mapping nicht mehr gespeichert wurde und die Ausgabe der Seite nicht mehr funktioniert hat.
Geholfen hat schlußendlich das Entfernen von Umlauten aus dem Templatefile (hatte einen Sample-Eintrag: Hauptmenü).
Am DS und TO musste dann nichts weiter verändert werden!
Viele Grüße
Andreas
PS: Typo3 sollte imho in der Defaultkonfiguration forceUTF8 und set names... aktivieren, ansonsten gibt es jede Menge Probleme!
Hi,
vermutlich lag es eher an der Codierung der Templatedatei.
Klar es geht natürlich auch so wie _Andreas_ es beschrieben hat. Einfacher ist es jedoch mit iconv zu lösen.
Wenn Du ein HTML Template zb in Windoze erstellst wird sie wahrscheinlich als ISO-8859-1 oder 1250 codiert sein.
Mit iconv kannst du das zb so ändern:
bash#> iconv -f ISO8859-1 -t UTF-8 alteTemplateDatei.html > neueDatei.html
Danach hat TemplaVoila das Mapping auch speichern können.
bye bye baby,
madroot
den gleichen fehler habe ich auch ich weiß nicht wie ich den weg bekomme. wäre genial wenn mir einer helfen könnte
Hallo,
auch ich habe denselben Fehler, aber nur sporadisch.
D.h. es ist tagelang alles wunderbar und dann kommt plötzlich auf sämtlichen Seiten dieser Fehler.
Erst ein Restart (!) von MySQL führt dann wieder zu einer fehlerfreien Darstellung. Irgendeine Idee dazu?
Wir betreiben die Datenbank ebenfalls im UTF-8 Format.
Danke, Gruß
Andrej
Hallo Andrej,
wir haben genau das gleiche Problem, und es funktioniert auch die gleiche Lösung: MySQL neu starten.
Hast Du inzwischen eine bessere Lösung gefunden?
Viele Grüße,
Tom
Also ich hatte den gleichen Fehler und habe ihn nun gelöst!
Was das Problem war?
In meiner .html Temlate-datei (Vorlage für TV) Waren Kommentare (<!-- XYZ --->)
und in diesen Html-kommentaren waren Umalute...
Gaaaanz Pöse!
Umalute aus Kommentaren entfernt und es geht!!!
Gleiches Problem hier - bei mir reichte es mit hilfe von NotepadII die Datei utf-8 zu kodieren (buchstaben wie äöüáà usw. werden nicht konvertiert - das musste ich händisch nachtragen!
Gruß
Info
Eine weitere mögliche Ursache für diesen Fehler:
Mehrere Typo3-Installationen die denselben Datenbank-User benutzen.
Da Typo3 defaultmäßig persistente Datenbankverbindungen aufbaut, kann es vorkommen, dass die eine Installation die Verbindung auf UTF-8 Ausgabe stellt und eine andere, die eigentlich ISO-Ausgaben erwartet, diese Verbindung "übernimmt" und dann unerwarteterweise UTF-8 Output präsentiert bekommt.
Abilfe schafft hier, den Eintrag:
'no_pconnect' => 0,
im file t3lib/config_default.php auf 1 zu setzen.
Viele Grüße
Robert