Hallo Forum!
Ich versuche jetzt ToolsphpMyAdmin (phpmyadmin) 0.2.1 (global) zu installieren und kriege beim "Import/Update" folgende Fehlermeldung:
Error: The datatransfer did not succeed. The T3X file could not be fetched. Possible reasons: network problems, allow_url_fopen is off, curl is not enabled in Install tool.
MySQL 5.0.30
PHP 5.1.4 (allow_url_fopen: On/On)
TYPO3 4.0.4
Was läuft hier schief?
Danke
Beim zweiten Anlauf kriege ich schon eine andere Fehlermeldung:
SUCCESS: /ServerRootVerzeichnis/.../meinRootVerzeichnis/typo3cms/typo3projects/ProjektRootVerzeichnis/typo3/ext/phpmyadmin/
Error: Either TYPO3_MOD_PATH or $BACK_PATH was not found in the "/ServerRootVerzeichnis/.../meinRootVerzeichnis/typo3cms/typo3projects/ProjektRootVerzeichnis/typo3/ext/phpmyadmin/modsub/conf.php" file. You must manually configure that!
ext_emconf.php: /ServerRootVerzeichnis/.../meinRootVerzeichnis/typo3cms/typo3projects/ProjektRootVerzeichnis/typo3/ext/phpmyadmin/ext_emconf.php
Type: G
Was soll das alles? Hat jemand eine Ahnung?
automatix schrieb
SUCCESS: /ServerRootVerzeichnis/.../meinRootVerzeichnis/typo3cms/typo3projects/ProjektRootVerzeichnis/typo3/ext/phpmyadmin/
Error: Either TYPO3_MOD_PATH or $BACK_PATH was not found in the "/ServerRootVerzeichnis/.../meinRootVerzeichnis/typo3cms/typo3projects/ProjektRootVerzeichnis/typo3/ext/phpmyadmin/modsub/conf.php" file. You must manually configure that!
ext_emconf.php: /ServerRootVerzeichnis/.../meinRootVerzeichnis/typo3cms/typo3projects/ProjektRootVerzeichnis/typo3/ext/phpmyadmin/ext_emconf.php
Type: G
Nun schauen wir mal in /typo3/ext/phpmyadmin/modsub/conf.php:
// Almost regular configuration of the module. Only if $MCONF['extModInclude']
// is set, then phpMyAdminSubDir is prepended to the TYPO3_MOD_PATH and '../'
// to BACK_PATH. If this is not correct, init.php will exit!
$BACK_PATH='../../../' . ($MCONF['extModInclude'] ? '../' : '');
// Check if PMA is installed and executed in local context, if true modify paths
if (substr_count($_SERVER['SCRIPT_FILENAME'], 'typo3conf') > 0) {
define('TYPO3_MOD_PATH', '../typo3conf/ext/phpmyadmin/modsub/' . ( $MCONF['extModInclude'] ? $MCONF['phpMyAdminSubDir'] : '' ));
$BACK_PATH='../../../../' . ($MCONF['extModInclude'] ? '../' : '') . 'typo3/';
} else {
define('TYPO3_MOD_PATH', 'ext/phpmyadmin/modsub/' . ($MCONF['extModInclude'] ? $MCONF['phpMyAdminSubDir'] : ''));
}
OK, da stimmt was nicht mit den Standardpfaden... Was aber genau? Und wie soll es wieder in Ordnung gebracht werden?