Zum Inhalt springen

Login-error or session timed-out

Erstellt am 18. Oktober 2006 · 5 Antworten · letzte Antwort am 10. Dezember 2008

Tags: Frage

lennard ·

Hallo,

ich habe beim Einrichten der BE-Benutzergruppe das Problem, dass ich beim Setzen der Allowed excludefields: immer mit der im Betreff genannten Fehlermeldung rausfliege und mich dann immer wieder neu am BE anmelden muss.

Hat dieses Problem schon mal wer gehabt? Woran kann das liegen?

Die Fehlermeldung:

Login-error or session timed-out

No user logged in! Sorry, I can't proceed then!

(You must have cookies enabled!)

If your session has just timed-out, you may
click here to re-login.


Cookies sind erlaubt, könnte ja die vielen anderen Dinge nicht machen.

Michael

McPringle ·

Genau dieses Problem habe ich auch mit der aktuellen Typo3 Version 4.1.1. Das ist jetzt sehr kritisch, da meine User meckern und ich die gruppenrechte nicht korrekt setzen kann...

Hat jemand einen Tip?

McPringle

BazenPe ·

Hi!
Ich habe genau das gleiche Problem! mit 4.1.2.
Der Fehler wird auch hier beschrieben:
http://bugs.typo3.org/view.php?id=4693
aber die beiden Lösungsvorschläge dort haben mich nicht weitergebracht, weil auch die tables.sql, die dort zum download angeboten wird für die Version 4.0.4 ist.

Unser Server ist Suse Linux, PHP 5.2 und MySQL 5
Hat jemand noch eine Idee?

Sjoeren ·

Fals jemand dem Problem genauer auf den Zahn fühlen will. Ich hab folges raußgefunden.
Es scheint das der SQL-String auf eine Krittische Länge wächst.
Das Problem scheint bei einer Länge > 3600 Zeichen auftauchen.

Leider weiß ich nicht ganz genau wo ich mir den SQL-Ausgeben kann bevor ich die Fehlermeldung bekomme.

typonegative ·

Hi lennard,

ich hatte das gleiche Problem und habe es für mich gelöst.

Ich habe im log die Fehlermeldung "configured request variable limit exceeded" gesehen und danach gegurgelt. Dabei bin ich auf folgendes gestossen:

http://www.bitweaver.org/forums/index.php?t=8501

Daraufhin habe ich die folgenden Einstellungen in suhosin.ini geändert (jeweils verdoppelt vom Default-Wert):

suhosin.request.max_vars = 400
suhosin.get.max_vars = 200
suhosin.post.max_vars = 400

Nach Restart des Apache klappt es jetzt.

Viele Grüße,
Markus

helmet ·

Hallo Markus,
ich hatte das Problem im Kickstarter, als ich eine eigene, ca. 2 Jahre alte Extension bearbeiten wollte, bei allen Tabellen hat's funktioniert, nur bei der umfangreichen bin ich permanent rausgeflogen. Nun läuft's!

DANKE
helmet