Zum Inhalt springen

loginusertrack kaputt

Erstellt am 13. September 2006 · 7 Antworten · letzte Antwort am 25. September 2006

Tags: Frage

PlankTom ·

Hi,
ich hab' "Login User Tracking loginusertrack 1.1.0" eingebunden. Lief auch bereits. Zwischenzeitlich erfolgte eine Umstellung auf 4.0. Nach längerer Zeit wollte ich mal wieder meine Logins begutachten, aber...ätsch:

Warning: main(../../../init.php): failed to open stream: No such file or directory in /html/typo3conf/ext/loginusertrack/mod1/index.php on line 35

Warning: main(../../../init.php): failed to open stream: No such file or directory in /html/typo3conf/ext/loginusertrack/mod1/index.php on line 35

Fatal error: main(): Failed opening required '../../../init.php' (include_path='.:/usr/share/php/pear:./usr/share/php/pear/PEAR') in /html/typo3conf/ext/loginusertrack/mod1/index.php on line 35

Kommt bereits wenn ich im BE auf "User Track" klicke, den Sysordner kann ich gar nicht mehr auswählen.
Ob das Problem seit der Umstellung auf 4.0 besteht kann ich leider nicht eingrenzen.
Eine Neuinstallation des Moduls brachte auch keine Änderung.
Danke, schon mal, für jeden Tipp!
Ciao
Tom

FordPrefect ·

Hoi,

in Typo3 40 hat sich der Standort der ordners für tslib geändert, möglicherweise is der Pfad in der Extension hardcoded. Schau mal in der Ext. nach.

gRüsse

PlankTom ·

Hi Ford,
meinst du das:
ext_localconf.php

<?php
if (!defined ("TYPO3_MODE")) die ("Access denied.");

$TYPO3_CONF_VARS["FE"]["XCLASS"]["tslib/class.tslib_fe.php"]=t3lib_extMgm::extPath("loginusertrack")."class.ux_tslib_fe.php";

?>

Meine Typo3 liegt unter /html/..., tslib liegt auf der gleichen Ebene /tslib

Ciao
Tom

PS.:

Code warnings:
(developer-relevant) Configured TYPO3_MOD_PATH "ext/loginusertrack/mod1/" different from "../typo3conf/ext/loginusertrack/mod1/"

finde ich im Ext.Manager. Will uns das was sagen?

PlankTom ·

Die in der Fehlermeldung angemotzte Zeile
/html/typo3conf/ext/loginusertrack/mod1/index.php on line 35
lautet:

35: require ($BACK_PATH.'init.php');

$BACK_PATH enthält ../../../

[/quote]

PlankTom ·

Ich hab' jetzt mal den $BACK_PATH verbogen auf:
$BACK_PATH='../../../../typo3/';
Jetzt findet das Modul die init.php und gibt folgende Fehlermldung aus:

Error in init.php: Path to TYPO3 main dir could not be resolved correctly.

This happens if the last 6 characters of this path, /html/typo3conf/, (\$temp_path) is NOT "typo3/" for some reason.
You may have a strange server configuration. Or maybe you didn't set constant TYPO3_MOD_PATH in your module?
If you expect any help from anybody on this issue, you should save this page as an html document and send it along with your request for help!

Array
(
[TYPO3_OS] =>
[PATH_thisScript] => /html/typo3conf/ext/loginusertrack/mod1/index.php
[php_sapi_name()] => cgi
[TYPO3_MOD_PATH] => ext/loginusertrack/mod1/
[PATH_TRANSLATED] => /html/typo3conf/ext/loginusertrack/mod1/index.php
[SCRIPT_FILENAME] => /html/typo3conf/ext/loginusertrack/mod1/index.php
)

gefolgt von einer phpinfo()-Ausgabe

Ich glaube ich hab' langsam genügend 'rumgepfuscht.