Hallo,
habe foldendes Problem.
Habe die Extension AWstats installiert und im
Setup und localconf.php den entsprechenden Eintrag
gemacht.
Ich bekomme jedoch im BE keine Auswertung, d. h.
alle Werte zeigen Null an.
In der von mir angelegten Logdatei ist kein Inhalt,
sie ist völlig leer.
Kann mir jemand helfen?
Xenon
Hallo Xenon1950,
tja, ist nicht ganz einfach, hast nicht genug Infos dazugeschrieben.
Der Loghile muss manuell angelegt werden. Das macht TYPO3 nicht für dich. Wenn du also den Pfad, z.B. fileadmin/ für die Logfiles verwendest, musst du hierunter ein leeres Logfile anlegen. Das Logfile muss 755 in der Berechtigung haben, damit es funktioniert.
Im setup musst du dann noch folgenden Eintrag machen:
config.stat_apache = 1
config.stat_apache_logfile = meinlogfile.log
config.stat = 1
You can use this if you want database logging also but it is not needed.
config.stat_mysql = 1
Konnte ich helfen?
Gruß
Andrea
Hallo Andrea,
den Eintrag habe ich im Setup schon.
Ich habe auch das LOGFILE erstellt und im Installtool den entsprechenden Verweis zum LOGFILE gemacht.
Das LOGFILE müsste mit jedem Besucher der Seite einen Eintrag erhalten, tut es aber nicht. D. h. die Datei ist immer leer. Ein Fehlermeldung, dass die Datei nicht gefunden wird, gibt es auch nicht. Die Berechtigung ist auch auf 755.
hast du noch eine Idee?
Hallo Xenon1950,
tja, hast du in der localconf.php den Eintrag vorgenommen? Sieht so aus:
$TYPO3_CONF_VARS["FE"]["logfile_dir"] = meinlogfile_dir/
Hast du in der awstats.pl geschaut, ob der chmod auf 755 steht?
Kontrolliere noch mal alle möglichen Schreibfehler.
Cache löschen und testen.
Gruß
Andrea
Du wirst es nicht glauben, aber ich sehe keine Schreibfehler oder sonstiges.
Es kann aber nicht sein, dass es garnichts registriert.
Du wirst es nicht glauben, aber ich sehe keine Schreibfehler oder sonstiges.
Es kann aber nicht sein, dass es garnichts registriert.
hm,....
schlag mich auch gerade mit diesem thema rum.
auch bei mir ist alles so, wie es sein muss.
AWStats funktioniert im BE. nur keine einträge
in die logfile.txt....
sollte dieses problem gelöst worden sein, dann
bitte ich um kurze nachricht.
danke,
chris
Salut zusammen,
habe auch das selbe Problem wie ihr.
Awstats ist grundsätzlich eingerichtet, nur bleiben alle Werte auf Null gesetzt.
Es werden also keine Daten ins Logfile geschrieben.
Ich habe hier im Forum daher auch schon einen Eintrag dazu geschrieben:
#559411
Habe im Internet eine Seite gefunden, auf welcher etliche, und eben auch dieser Fehler, beschrieben sind.
http://awstats.sourceforge.net/docs/awstats_faq.html
Lösen konnte ich das Problem aber noch nicht.
Gruss Marc