Zum Inhalt springen

Installationsproblem.....

Erstellt am 6. Juli 2004 · 10 Antworten · letzte Antwort am 10. Juli 2004

Tags: Frage

k.​h.​ ·

Hallo zusammen...

jetzt muss ich doch um ein wenig Hilfe bitten...

Ich versuche herauszufinden, ob typo3 das richtige CMS für uns ist...

Ich habe mir die aktuelle Version von Typo 3 (3.6.1 als Quickstart-Package) heruntergeladen und lokal entpackt...anschliessend die Ordner per FTP hochgeladen und die Installation versucht...

Das Ergebnis ist immer dasselbe:

Warning: mysql_pconnect() [function.mysql-pconnect]: Access denied for user: 'web18@localhost' (Using password: YES) in /srv/www/htdocs/web18/html/typo3/t3lib/class.t3lib_db.php on line 776

Warning: mysql_list_tables(): supplied argument is not a valid MySQL-Link resource in /srv/www/htdocs/web18/html/typo3/t3lib/class.t3lib_db.php on line 836

Warning: mysql_pconnect() [function.mysql-pconnect]: Access denied for user: 'web18@localhost' (Using password: YES) in /srv/www/htdocs/web18/html/typo3/t3lib/class.t3lib_db.php on line 776

 
TYPO3 3.6.0 Install Tool
Site: QuickStart

 


Database

 There is no connection to the database!
(Username: web18, Password: NALv9ZZQ, Host: localhost).

Go to Step 1 and enter a proper username/password! 


--------------------------------------------------------------------------------
NOTICE: Install Tool is running in '123' mode. Click here to disable.

Das Spiel macht mir allmählich nicht mir allzuviel Spass, da der 4. Versuch nun wieder kläglich gescheitert ist...

Lustigerweise habe ich letztes Jahr bereits einmal eine Installation ohne Schwierigkeiten hinbekommen...Auch wenn ich sicherlich nicht der größte Held bin, was MySQL und PHP usw. angeht, so war ich doch bisher der Meinung, dass ich eigentlich alles was lauffähig ist, auch zum Laufen bringe... :o

Kann es vielleicht sein, dass ich das völlig falsche Package gezogen habe? Oder was gibt es sonst noch für Fehlerquellen?

Mein (eigener) Server läuft auf Apache bzw. Linux ...Probleme mit der Datenbak glaube ich ausschliessen zu können, da alle bisherigen Installationen, egal ob Newssystem oder Forum immer sofort lauffähig waren...

Vielleicht weiss jemand von Euch Rat... #paralyzed#

c4c ·

Hallo!

Welche Site rufst du denn da auf, dass diese Fehlermeldung erscheint ? http://yourhostname.de/quickstart/ ?

Bin mir noch nicht ganz sicher was diese Message genau zu bedeuten hat, eventuell das du unter diesem jenem User keinen Zugriff auf den MySQL - Server hast, oder ob er noch überhaupt keine DB ausgewählt hat, (oder ob der MySQL noch nicht gestartet ist .. muss zugeben so genau kenne ich mich auch nicht aus 😉 ) ..

Teste doch einmal ob du über yourhostname.de/quickstart/ install/ ins InstallTool kommst.

PWD ist standardmässig joh316

dann kannst du unter Pkt 1 neue DB's erstellen, und entsprechende MySQL-Server Einstellungen tätigen.

Eventuell sagt dir das InstallTool auch was für Probleme du hast, (falscher User für MySQL oder whatever)

hth

stEvo

k.​h.​ ·

Welche Site rufst du denn da auf, dass diese Fehlermeldung erscheint ? http://yourhostname.de/quickstart/ ?

Nein - ich rufe die Domain ohne weitere Zusätze auf...ich habe für Typo 3 keinen estra Ordner "Quickstart o.ä." angelegt...

Mir kommt es auch so vor, als ob es irgendein Problem mit der Datenbank geben würde. Allerdings ist das nicht die erste Datenbank, die ich (auch auf diesem Server...) anlege und derartige Problem hatt ich noch nie, bzw. war immer dazu in der Lage, diese zu beheben (waren meist falsch vergebene Rechte...) Aber in diesem Fall wird ja sogar die localconf...richtig geschrieben...

Mir persönlich kommt es ja so vor, als ob der Aufruf der Datenbank lokal stattfinden soll. Kann es vielleicht sein, dass beim Entpacken der Dateien bereits eine entsprechende Veränderung irgendwelcher Dateien stattfindet? (Während dem Unzippen lief im Hintergrund noch mein lokaler Apache-Testserver auf meinem PC...)

tomww ·

kommst Du von Deinem webserver aus mit diesen Daten auf die Datenbank ?:

(Username: web18, Password: NALv9ZZQ, Host: localhost).

Falls Du ein phpMyAdmin installiert hast, kannst Du es ja mal da testen ?
Hast Du den MySQL-User selbst und neu angelegt ?
Hast Du anschl. ein flush-priviledges gemacht ?

Falls die Daten falsch erfasst sind, kannst Du diese auch in Deiner localconf.php im typo3conf-Verzeichnis anpassen - einfacher wäre aber dann wohl die Daten gleich richtig zu erfassen ;-)

Beim Kopieren der Daten von einem localen Rechner auf einen Server musst Du beachten, dass der Webserver ausreichend Rechte auf alle Dateien hat ... (ist in der Install-Anleitung irgendwo genau beschrieben ...)

Tom

c4c ·
k.h. schrieb

Nein - ich rufe die Domain ohne weitere Zusätze auf...ich habe für Typo 3 keinen estra Ordner "Quickstart o.ä." angelegt...

..wie? Keinen Ordner angelegt? Du musst EINMAL den Source entpacken UND ein zugehöriges Package. In deinem Fall wäre es ja Quickstart. Diese beiden Verzeichnisse liegen ja in deinem WebServer-Root (z.B.),
wahrscheinlich sind das dann typo3_src-3.6.1 und quickstart-3.6.1 .. Sind die bei dir so vorhanden? Falls nicht, weiss ich nicht ob du da eventuell auch Probleme mit den SymLinks bekommst usw usw ..

k.h. schrieb

Mir kommt es auch so vor, als ob es irgendein Problem mit der Datenbank geben würde. Allerdings ist das nicht die erste Datenbank, die ich (auch auf diesem Server...) anlege und derartige Problem hatt ich noch nie, bzw. war immer dazu in der Lage, diese zu beheben (waren meist falsch vergebene Rechte...) Aber in diesem Fall wird ja sogar die localconf...richtig geschrieben...

Hmm .. Im Grunde sieht das schwer danach aus, haste recht. Aber falls noch keine DB für Typo vorhanden sein sollte (welche allerdings, wenn ich mich richtig erinnere, beim Quickstart Package gleich mit Installiert wird), und man ruft den WebServer + PackageName auf, sollte eigentlich das 1-2-3 Install Tool anspringen.

k.h. schrieb

Mir persönlich kommt es ja so vor, als ob der Aufruf der Datenbank lokal stattfinden soll.

Hmm..??? ..

k.h. schrieb

Kann es vielleicht sein, dass beim Entpacken der Dateien bereits eine entsprechende Veränderung irgendwelcher Dateien stattfindet? (Während dem Unzippen lief im Hintergrund noch mein lokaler Apache-Testserver auf meinem PC...)

Du darfst bei den Unix / Linux Systemen auf keinen Fall den Fehler machen, die Packages lokal zu entpacken und diese dann via FTP zu verschieben. Das sollte alles erst auf dem WebServer geschehen, ich glaube weil FTP die SymLinks nicht richtig mitkopiert .. soviel dazu..

Nur weil dein Apache lokal läuft, gibt das eigentlich keine Probs!

k.​h.​ ·

Hallo tomww,

du hast mich mit der Nase auf den Fehler gestossen...das Passwort war das falsche...ich habe das Webspace Paket an dem Abend so oft neu angelegt, dass ich die Passwörter durcheinandergebracht habe...

An euch beide tomww und c4c

Vielen Dank an euch beide für eure prompte Hilfe...

@ c4c

prinzipiell sehe ich keine Schwierigkeiten, warum es ohne übergeordneten Ordner nicht auch funktionieren sollte...meinst du, dass es zu ernsdthaften Schwierigkeiten führen kann, wenn ich die Dateien einfach so auf meinen Webspace lade?

@all

ein Problem habe ich noch...wenn ich das FE aufrufe, bekomme ich anstatt des Menüs folgende Fehlermeldung:

Fatal error: Call to undefined function: imagegif() in /srv/www/htdocs/web18/html/t3lib/class.t3lib_stdgraphic.php on line 2316

beim Aufruf des Backends kommt folgendes:

Warning: fopen(/srv/www/htdocs/web18/html/typo3temp/charset_iso-8859-1.tbl) [function.fopen]: failed to create stream: Permission denied in /srv/www/htdocs/web18/html/typo3/t3lib/class.t3lib_div.php on line 2012

Warning: Cannot modify header information - headers already sent by (output started at /srv/www/htdocs/web18/html/typo3/t3lib/class.t3lib_div.php:2012) in /srv/www/htdocs/web18/html/typo3/template.php on line 596

Ich könnte mir vorstellen, dass es sich tatsächlich wieder um ein Rechteproblem handelt...aber welche Ordner sind betroffen?

Nochmal...vielen Dank schon jetzt an alle, die solchen Nieten wie mir hier so bereitwillig helfen...

c4c ·
k.h. schrieb

Hallo tomww,

du hast mich mit der Nase auf den Fehler gestossen...das Passwort war das falsche...ich habe das Webspace Paket an dem Abend so oft neu angelegt, dass ich die Passwörter durcheinandergebracht habe...

😃

k.h. schrieb

An euch beide tomww und c4c

Vielen Dank an euch beide für eure prompte Hilfe...

no problem

k.h. schrieb

@ c4c

prinzipiell sehe ich keine Schwierigkeiten, warum es ohne übergeordneten Ordner nicht auch funktionieren sollte...meinst du, dass es zu ernsdthaften Schwierigkeiten führen kann, wenn ich die Dateien einfach so auf meinen Webspace lade?

Auszug aus dem INSTALL.TXT aus einem der Packages

IMPORTANT NOTE
==============

Please be aware of the fact that the file transfer protocol (FTP) does not
support Symlinks. You cannot unpack these archives locally and copy them
to your server using FTP, even if the target server actually is a Unix
server.
k.h. schrieb

@all

ein Problem habe ich noch...wenn ich das FE aufrufe, bekomme ich anstatt des Menüs folgende Fehlermeldung:

Fatal error: Call to undefined function: imagegif() in /srv/www/htdocs/web18/html/t3lib/class.t3lib_stdgraphic.php on line 2316

beim Aufruf des Backends kommt folgendes:

Warning: fopen(/srv/www/htdocs/web18/html/typo3temp/charset_iso-8859-1.tbl) [function.fopen]: failed to create stream: Permission denied in /srv/www/htdocs/web18/html/typo3/t3lib/class.t3lib_div.php on line 2012

Warning: Cannot modify header information - headers already sent by (output started at /srv/www/htdocs/web18/html/typo3/t3lib/class.t3lib_div.php:2012) in /srv/www/htdocs/web18/html/typo3/template.php on line 596

Ich könnte mir vorstellen, dass es sich tatsächlich wieder um ein Rechteproblem handelt...aber welche Ordner sind betroffen?

Hmm .. da hast du glaube ich wirklich Recht mit den Rechten.

Hier noch ein weiterer Auszug aus der INSTALL.TXT

4 Set permissions (as root): There are at least two options.
  These steps will make typo3conf/ typo3temp/ etc. writable for the
  webserver.

	4.a (recommended)
	    Run these commands as root:
	    # chgrp -R <wwwserver> typo3_src-3.6.0/ <sitedir>/
	    # chmod -R g+w,o-rwx typo3_src-3.6.0/ <sitedir>/
	    
	    ...where <wwwserver> is the name of the user your webserver
	    is running as and <sitedir> is the name of the directory
	    inside of this archive

	4.b (insecure but easy to apply)
	    I repeat: This is insecure!
	    Do not use this method if you are working on a shared server!
	    
	    Simply run this command:
	    $ chmod -R a+w typo3_src-3.6.0/ <sitedir>/

Vielleicht hilft dir das weiter

😉

Much Respect

werkraum.stEvo

Unbekannter Benutzer ·

also ich entpacke das paket immer auf nem win rechner und uppe das dann per ftp auf nen pinguin, hatte noch nie probs damit.
und NEIN, es macht gar nix aus ob du nen unterordner für dein t3 anlegst oder nicht.

c4c ·
Daniel_S schrieb

also ich entpacke das paket immer auf nem win rechner und uppe das dann per ftp auf nen pinguin, hatte noch nie probs damit.
und NEIN, es macht gar nix aus ob du nen unterordner für dein t3 anlegst oder nicht.

.. für die ZIP files gilt das auch! Weil's da keine SymLinks gibt.

In den Linux Packages aber sehr wohl .. und da das hier die Linux / Unix Section ist, nahm ich mal an das es ein solchiges ist 😉

Ausserdem ist es natürlich jedermanns eigene Sache wie er Ordner und Struktur anlegt, klar! ..

k.​h.​ ·

In den Linux Packages aber sehr wohl .. und da das hier die Linux / Unix Section ist, nahm ich mal an das es ein solchiges ist

Nun, darin könnte ein grundsätzliches Missverständnis liegen...ichdachte Unix/Linux würde sich auf den Webserver beziehen...

Ich habe das quickstart-package für Windows heruntergeladen und entpackt...und dann per FTP auf meinen Linux-Webserver "geuppt"...

Deswegen muß ich dann auch alle notwendigen User-Rechte per FTP manuell setzen....

Ich hoffe, es kommen nicht noch mehr derartige Problemchen...

Ich werde wohl lieber mal das Dummy-Package probieren...das dauert dann vielleicht auch nicht so lange beim uppen...

k.​h.​ ·

Also jetzt habe ich das Problem lösen können...

Es handelte sich tatsächlich um nicht ausreichende Rechtevergabe zweier Ordner...

typo3temp und typo3conf.

Nochmals vielen Dank an alle freundlichen Helfer... 😃