Hallo Zusammen,
ich habe ein kleines Problem mit dem Upload von größeren Daten so ca ab 1,5-2,8 MB und aufwärts.
Nach dem ich im Backend bereich bei Media->File Dateien/Bilder usw. uploaden will kommt nach einer gewissenzeit ein diese Fehlermeldung:
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, service@webmailer.de and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Ich bin bei Strato und hab schon einiges über diesen Fehler gelesen, nur ich kann ihn nicht lösen. Es gibt einen Lösungesweg bezüglich php.ini, jedoch geht das auch nicht da Strato die php.ini nicht im Hauptverzeichnis akzeptiert sondern ich muss die Datei direkt in dem Verzeichnis legen wo das Script auch ausgeführt ist, wisst ihr wo das ist?
Oder habt ihr eine Lösung für mich?
Ich brauche echt Hilfe, ich bekomm das Problem nicht gelöst!
Viele Grüße
viktor
hat nicht jemand eine Idee?
lg
Hallo,
ohne die error.log Datei zu sehen, kann man nur vermuten. Wahrscheinlich ist die post_max_size bzw. upload_max_filesize in der php.ini auf max. 2MB begrenzt. Wenn Du PHP 4 nutzt und BasicWeb XL bzw. PowerPlus hast, dann ist das laut FAQ zumindest der Fall.
Bei manchen Hostern ist es möglich, die PHP Konfiguration in der .htaccess zu überschreiben:
php_value post_max_size 10MB
php_value upload_max_filesize 10MB
VG,
LuP
Hallo LuP,
ich danke dir, bezüglich deiner Antwort.
Ich teste das mal aus.
Wo genau muss ich dann eigentlich die php.ini bzw. die .htaccess um das Upload script zu erwischen reinlegen? Da strato ja keine globalen änderungen zu lässt, sondern nur im jeweiligen (script)verzeichnis.
lg
Logfile von Wordpress wenn ich eine Datei-Uploade:
03.05.2012 16:39:00 xxx.xxxx-xxx.de [client 84.174.6.25] (70014)End of file found: Error reading request entity data
03.05.2012 16:41:36 xxx.xxxx-xxx.de [client 84.174.6.25] Premature end of script headers: async-upload.php
Logfile von Typo3 wenn ich eine Datei-Uploade:
03.05.2012 16:46:46 xxx.xxxx-xxx.de [client 84.174.6.25] Premature end of script headers: index.php, referer: http://xxx-xxxxxxx.de/typo3conf/ext/dam/mod_file/index.php
Hallo,
im Root-Verzeichnis der TYPO3-Website findest Du eine .htaccess. Die wirkt rekursiv auf alle Unterverzeichnisse. Darin steht folgende Sektion:
### Begin: PHP optimisation ###
# If you do not change the following settings, the default values will be used.
# TYPO3 works fine with register_globals turned off.
# This is highly recommended, if your web server has it turned on.
#php_flag register_globals off
### End: PHP optimisation ###
Nach #php_flag register_globals off hängst Du nun folgendes an:
php_value post_max_size 10MB
php_value upload_max_filesize 10MB
VG,
LuP
Hallo LuP,
ich danke dir.
Jedoch wenn ich das in der .htaccess ändere dann kommt auf der kompletten Internet Seite einne Internal Server Error Message.
Meine .htaccess beinhaltet auch:
RewriteEngine On
RewriteBase /
RewriteRule ^typo3$ - [L]
RewriteRule ^typo3/.*$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l
RewriteRule .* index.php [L]
Ich kenn mich mit php.ini und .htaccess nicht so gut aus und muss ganz dringend das Problem lösen.
lg =)
Hallo,
leider fällt mir im moment nichts anderes ein.
VG,
LuP