Hi Leute,
ich hab mir gerade ein VM eingerichtet mit openSuSE 11.4 und möchte nun FLOW3 installieren, allerdings hab ich da ein kleines Problem.
Ich hab soweit den Webserver eingerichtet und die Berechtigungen mit
./flow3 core:setfilepermissions root wwwrun www
eingerichtet.
In der Apache Config hab ich das DocumentRoot auf das ../Web verzeichnis gelegt.
Wenn ich jetzt FLOW3 aufrufen möchte erscheint der Welcome Bildschirm, allerdings ohne dem CSS File und es JS Files. das _Resources Verzeichnis ist vorhanden.Wenn ich das ganze mir FireBug o.Ä. prüfe erhalte ich Failed to load resource: the server responded with a status of 403 (Forbidden).
Ich hab die Rechte mehrmals geprüft usw. da passt alles, hat jemand eine Idee woran das liegen könnte?
Gruß Leibnitz
Hallo lebnitz,
konntest du oder jemand anderes eine Lösung für das Problem finden? Ich steh bei meinem Ubuntu 11.04 vor dem gleichen Problem und bin kurz davor aufzugeben.
So langsam macht sich der Frust breit. :-(
Bitte um Hilfe.
Beste Grüsse,
Aldarin
Schein ein Fehler in euer vhosts config zu sein.
Ich habe es unter CentOS/Ubuntu/Debian laufen.
Alles OK.
Poste doch mal deine Config.
Hi,
nein war kein VHost-Fehler.
Jedenfalls nicht Primär.
1. Musste in der Apache Einstellung die Option MULTIVIEWS deaktiviert werden.
2. Kam es danach weiterhin zu ähnlichen Fehlern, das lag dann aber an fehlerhaften Filepermissions, da das Script "./flow3 core:setfilepermissions ....." nicht richtig gegriffen hat und nur teilweise die Berechtigung setzen konnte, aber auch keine Fehlermeldung ausgegeben hat, das es nicht zugreifen konnte.
Beste Grüße,
Daniel
Hallo zusammen
Ich hab das gleichen Problem. Nur hilft bei mir die Lösung von Aldarin nicht.
Ich hab Multiviews deaktiviert. /etc/apache2/sites-enabled/alpha.neos:
<VirtualHost *:80>
DocumentRoot "/var/www/alpha.neos/TYPO3-Neos-1.0-alpha7/Web/"
# skip the following line for development
SetEnv FLOW_CONTEXT Production
ServerName neos.demo
Options -MultiViews
</VirtualHost>
Ich hab anschliessend setfilepermissions durchlaufenlassen, obwohl das bei der Alpha7 eigentlich nicht notwendig ist und den apache neu gestartet.
Leider ist im Web/_Resources noch immer kein CSS vorhanden.
Ich arbeite mit einer Vagrant box auf Port 8081, hab im lokalen Host file alpha.neos auf 127.0.0.1 eingetragen und greife mit alpha.neos:8081/setup darauf zu. Das Setup wird geladen, nur eben die _Resources/static/Packages und _Resources/Persistent und bleiben leer.
Hat jemand eine Idee?
Hallo,
ich verwende Ubuntu-Server 12.04 und habe das gleiche Problem mit dem Befehl
./flow core:setfilepermissions benutzername www-data www-data
für TYPO3 Flow 2.0.
Die anschließende, rekursive Besitzeränderung mittels
benutzername@server:~/dein/flow/verzeichnis/sudo chown -Rv benutzername:www-data ./*
führte bei mir zum gewünschten Ergebnis. Oder Kombinationen der beiden Befehle. Ein Schema ließ sich dabei allerdings nicht erkennen.
Viel Erfolg!