Hallo Norman2k,
danke für die schnelle Antwort.
Ich hab in der php.ini eingestellt, dass ich Errors angezeigt bekomme, aber es werden keine angezeigt. Nach wie vor bekomme ich eine leere Seite zu sehen.
Ausschnitt php.ini:
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
; Error handling and logging ;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
; error_reporting is a bit-field. Or each number up to get desired error
; reporting level
; E_ALL - All errors and warnings (doesn't include E_STRICT)
; E_ERROR - fatal run-time errors
; E_WARNING - run-time warnings (non-fatal errors)
; E_PARSE - compile-time parse errors
; E_NOTICE - run-time notices (these are warnings which often result
; from a bug in your code, but it's possible that it was
; intentional (e.g., using an uninitialized variable and
; relying on the fact it's automatically initialized to an
; empty string)
; E_STRICT - run-time notices, enable to have PHP suggest changes
; to your code which will ensure the best interoperability
; and forward compatibility of your code
; E_CORE_ERROR - fatal errors that occur during PHP's initial startup
; E_CORE_WARNING - warnings (non-fatal errors) that occur during PHP's
; initial startup
; E_COMPILE_ERROR - fatal compile-time errors
; E_COMPILE_WARNING - compile-time warnings (non-fatal errors)
; E_USER_ERROR - user-generated error message
; E_USER_WARNING - user-generated warning message
; E_USER_NOTICE - user-generated notice message
;
; Examples:
;
; - Show all errors, except for notices and coding standards warnings
;
;error_reporting = E_ALL & ~E_NOTICE
;
; - Show all errors, except for notices
;
;error_reporting = E_ALL & ~E_NOTICE | E_STRICT
;
; - Show only errors
;
;error_reporting = E_COMPILE_ERROR|E_ERROR|E_CORE_ERROR
;
; - Show all errors except for notices and coding standards warnings
;
error_reporting = E_ALL
; Print out errors (as a part of the output). For production web sites,
; you're strongly encouraged to turn this feature off, and use error logging
; instead (see below). Keeping display_errors enabled on a production web site
; may reveal security information to end users, such as file paths on your Web
; server, your database schema or other information.
display_errors = On
; Even when display_errors is on, errors that occur during PHP's startup
; sequence are not displayed. It's strongly recommended to keep
; display_startup_errors off, except for when debugging.
display_startup_errors = On
; Log errors into a log file (server-specific log, stderr, or error_log (below))
; As stated above, you're strongly advised to use error logging in place of
; error displaying on production web sites.
log_errors = On
; Set maximum length of log_errors. In error_log information about the source is
; added. The default is 1024 and 0 allows to not apply any maximum length at all.
log_errors_max_len = 1024
; Do not log repeated messages. Repeated errors must occur in same file on same
; line until ignore_repeated_source is set true.
ignore_repeated_errors = Off
; Ignore source of message when ignoring repeated messages. When this setting
; is On you will not log errors with repeated messages from different files or
; sourcelines.
ignore_repeated_source = Off
; If this parameter is set to Off, then memory leaks will not be shown (on
; stdout or in the log). This has only effect in a debug compile, and if
; error reporting includes E_WARNING in the allowed list
report_memleaks = On
; Store the last error/warning message in $php_errormsg (boolean).
track_errors = Off
; Disable the inclusion of HTML tags in error messages.
; Note: Never use this feature for production boxes.
html_errors = On
; If html_errors is set On PHP produces clickable error messages that direct
; to a page describing the error or function causing the error in detail.
; You can download a copy of the PHP manual from http://www.php.net/docs.php
; and change docref_root to the base URL of your local copy including the
; leading '/'. You must also specify the file extension being used including
; the dot.
; Note: Never use this feature for production boxes.
;docref_root = "/phpmanual/"
;docref_ext = .html
; String to output before an error message.
error_prepend_string = "<font color=ff0000>"
; String to output after an error message.
error_append_string = "</font>"
; Log errors to specified file.
error_log = "C:\xampp\apache\logs\phperror.log"
; Log errors to syslog (Event Log on NT, not valid in Windows 95).
;error_log = syslog
In den Error Logs unter xampp\apache\logs steht folgendes für heute:
[Sun Sep 26 08:44:57 2010] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sun Sep 26 08:44:57 2010] [notice] Digest: generating secret for digest authentication ...
[Sun Sep 26 08:44:57 2010] [notice] Digest: done
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\xampp\\php\\ext\\php_imagick.dll' - The specified module could not be found.\r\n in Unknown on line 0
[Sun Sep 26 08:45:06 2010] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i PHP/5.2.9 configured -- resuming normal operations
[Sun Sep 26 08:45:06 2010] [notice] Server built: Dec 10 2008 00:10:06
[Sun Sep 26 08:45:06 2010] [notice] Parent: Created child process 3500
[Sun Sep 26 08:45:13 2010] [notice] Digest: generating secret for digest authentication ...
[Sun Sep 26 08:45:13 2010] [notice] Digest: done
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\xampp\\php\\ext\\php_imagick.dll' - The specified module could not be found.\r\n in Unknown on line 0
[Sun Sep 26 08:45:18 2010] [notice] Child 3500: Child process is running
[Sun Sep 26 08:45:18 2010] [notice] Child 3500: Acquired the start mutex.
[Sun Sep 26 08:45:18 2010] [notice] Child 3500: Starting 250 worker threads.
[Sun Sep 26 08:45:18 2010] [notice] Child 3500: Starting thread to listen on port 80.
[Sun Sep 26 08:45:18 2010] [notice] Child 3500: Starting thread to listen on port 443.
[Sun Sep 26 10:18:05 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/7xampp
Woher nimmt der das hier: C:/xampp/htdocs/7xampp ?
Ich habe im Magento Plugin jetzt die Usergroup zugelassen, die ich im Typo3 Connector im Magento Backend unter "Group uid TYPO3 Frontend Users" angegeben habe. Wenn ich jetzt den Code mit "includeLibs.user_tx_fbmagento_pi1 =..." einfüge, dann wird mir nichts angezeigt, also weiß. Ohne diesen Code wird mir allerdings die Unterseite angezeigt, allerdings ohne das Magento Plugin.
So weit war ich noch nie, hehe.
Ich denke also, dass es etwas mit dem Typoskript Code ("includeLibs.user_tx_fbmagento_pi1 =...") zu tun haben muss. Aber ich kenne mich da nicht so gut aus, als dass ich den Fehler erkennen könnte.
Hast du eine Idee was es sein könnte?