Checkout (Bestellung) leer... [Gelöst]

  • MsvP MsvP
    T3PO
    0 x
    13 Beiträge
    0 Hilfreiche Beiträge
    18. 03. 2010, 23:56

    Ich verzweifle gerade einwenig.

    Commerce Version: 0.12.2
    Typo Version: 4.3.1

    Ich richte seit einigen Tagen einen Webshop mit commerce ein.
    Soweit funktioniert alles, nur das wichtigste leider nicht.

    Wenn ich auf "Zur Kasse" egal ob aus dem Warenkorb oder aus der Übersicht heraus klicke erscheint nur der Text für der Seite "leere Bestellung".

    Komischerweise wird aber der Mini-Warenkorb, auf eben dieser Seite vollkommen korrekt dargestellt.

    PIDs sollten eigentlich richtig eingerichtet sein (habe sie jetzt mehrere Male kontrolliert).

    Hat jemand eine Idee?


  • 1
  • MsvP MsvP
    T3PO
    0 x
    13 Beiträge
    0 Hilfreiche Beiträge
    19. 03. 2010, 11:52

    Ich habe gerade einmal die Datenbank bezüglich der Sessions beobachtet, ist es richtig, dass dort nicht nur ein Eintrag in "tx_commerce_baskets" sondern gleich drei entstehen?

    Ich benutze den Simple Mode und es handelt sich um folgenden Artikel:

    Artikel id = 10
    Produkt id = 3
    Price id = 3
    Price = 30 Euro

    Datenbankeintrag 1:

    uid = 5
    pid = 111
    pos = 1
    tstamp = 1268995089
    crdate = 1268995089
    cruser_id = 0
    sid = 219e2db19bc4e70b1436c1e583a7b02b
    finished_time = 0
    article_id = 5
    price_id = 9
    price_gross = 300
    price_net = 300
    quantity = 1
    readonly = 0

    Datenbankeintrag 2:

    uid = 4
    pid = 111
    pos = 0
    tstamp = 1268995089
    crdate = 1268995089
    cruser_id = 0
    sid = 219e2db19bc4e70b1436c1e583a7b02b
    finished_time = 0
    article_id = 10
    price_id = 3
    price_gross = 3000
    price_net = 3000
    quantity = 1
    readonly = 0

    Datenbankeintrag 3:

    uid = 6
    pid = 111
    pos = 2
    tstamp = 1268995089
    crdate = 1268995089
    cruser_id = 0
    sid = 219e2db19bc4e70b1436c1e583a7b02b
    finished_time = 0
    article_id = 1
    price_id = 0
    price_gross = 0
    price_net = 0
    quantity = 1
    readonly = 0

  • MsvP MsvP
    T3PO
    0 x
    13 Beiträge
    0 Hilfreiche Beiträge
    19. 03. 2010, 12:20

    Habe das Problem gelöst.

    Für all diejenigen, die das gleiche Problem haben hier meine Lösung:

    Ich musste für die Bezahlarten und den Versand Preise anlegen (egal ob diese eigentlich bei 0 Euro liegen, oder nicht). Durch den Simple-Modus legt Commerce anscheinend nicht automatisch Preise an, sondern man muss extra in die Zahloptionen / Versandart wechseln und dort unter Artikel erzeugen - Preis einen Preis erzeugen.

    Liebe Grüße

  • nevelle nevelle
    Typ im Roten Hemd
    0 x
    2 Beiträge
    0 Hilfreiche Beiträge
    19. 08. 2012, 17:23

    Auch wenn der Thread hier uralt ist: DANKE DANKE DANKE.

    An den nicht erstellten preisen für die Bezahloption hing es bei mir auch! #angry#

  • 1