Typo3 4.3 Popup "Open and Recently Used Documents" abschalten

  • iphar iphar
    Padawan
    0 x
    52 Beiträge
    0 Hilfreiche Beiträge
    16. 03. 2010, 07:41

    Seit Version 4.3 erscheint im Backend permanent ein Popup in dem Geöffnete und Zuletzt verwendete Dokumente (Seiten) angezeigt werden.

    Wie kann man das unterbinden?

    Ich möchte nicht die Extension User>Open Documents (opendocs) an sich deaktivieren, da ich den Zugriff über das obere Menü sinnvoll finde - lediglich das permanente nerven per popup finde ich störend.

    Vielen Dank


  • schaule1 schaule1
    Typ im Roten Hemd
    0 x
    2 Beiträge
    0 Hilfreiche Beiträge
    24. 06. 2010, 09:37

    Hallo zusammen,

    Das Problem tritt nur bei uns im Geschäft auf. Unsere Firewall wenden eine Default Rule auf die eingehenden Ajax Response an und killt die CR LF Zeichen (true\x0d\x0a) somit kommt immer das nervige Popup.

    Gruss
    Roland

  • Backdraft007 Backdraft...
    Sternenflotten-Admiral
    0 x
    165 Beiträge
    0 Hilfreiche Beiträge
    19. 10. 2010, 08:56

    Ich möchte mich mal anschließen.

    Ich selber habe dieses Pop-Up nicht. Bei keinem meiner Typo3-Umgebungen.
    Ein weiterer Redakteur (mit Admin-Rechten) hat dieses Problem schon. Es kam von heute auf morgen, und zwar auf verschiedenen Typo3-Umgebungen.

    Hat hier einer nochmal einen Tipp?

    Typo3 4.4.4

  • gnorzer gnorzer
    T3PO
    0 x
    17 Beiträge
    0 Hilfreiche Beiträge
    26. 01. 2011, 14:03

    [quote="schaule1"]
    Hallo zusammen,

    Das Problem tritt nur bei uns im Geschäft auf. Unsere Firewall wenden eine Default Rule auf die eingehenden Ajax Response an und killt die CR LF Zeichen (true\x0d\x0a) somit kommt immer das nervige Popup.

    Gruss
    Roland
    [/quote]

    Das kommt mir aber mal sehr plausibel vor. Bei derselben Installation kommt einmal das popup und beim Zugang von einem anderem Standort kommt das Popup nicht.
    Einzig deaktivierung von opendocs hilft.

  • sauvage7 sauvage7
    T3PO
    0 x
    14 Beiträge
    0 Hilfreiche Beiträge
    30. 08. 2011, 23:13

    Bei einem Kunden von mir ist dasselbe passiert und das einzige was sich geändert hat über Nacht waren die Firewall-Regeln... könnte also wirklich Ajax/Firewall sein... wie auch immer, [b]das hier könnte funktionieren:
    [/b]
    Jedes mal wenn eine Seite verschoben, kopiert oder gelöscht wird oder der Type geändert wird, erscheint ein Popup Fenster mit einer Warnmeldung. Das kann manchmal stören und lässt sich einfach abstellen.

    In den UserTSconfig wird z.B. folgendes eingetragen:

    options.alertPopups = 254

    Was bedeutet die Zahl 254?

    Die Standardeinstellung ist 255. Es werden alle Warnungen angezeigt.

    Folgende Änderungen haben diese Zahlenwerte:

    1 – onTypeChange
    2 – copy / move / paste
    4 - delete
    8 – FE editing

    Wenn also keine Warnung erscheinen soll, wenn der Typ geändert wird, muss gerechnet werden:

    255(alle Warnungen) - 1(onTypeChange) = 254

    options.alertPopups = 254

    Keine Warnung bei Typänderung und verschieben/kopieren:

    255 - 1 - 2 = 252

    gefunden bei Onkel google auf jweiland.net

    Cheers
    Gabe

  • Ram3000 Ram3000
    T3PO
    0 x
    9 Beiträge
    0 Hilfreiche Beiträge
    20. 12. 2012, 08:07

    Hallo,
    gibt es hier eigtlich schon eine Lösung für das Problem "Open and Recently Used Documents"?

    Ich bekomme seit einiger Zeit auch dieses nervige Popup Fenster
    und das nervt ungemein wenn man viele Seite bearbeiten muss :(

    Mir würde es helfen, wenn man das Popup abschalten könnte,
    ohne die OpenDocs zu deinstallieren.

    Der Eintrag options.alertPopups hat bei mir leider keine Wirkung gezeigt :/

  • fuss fuss
    Jedi-Meister
    0 x
    375 Beiträge
    0 Hilfreiche Beiträge
    26. 11. 2014, 14:27

    Auch wenn es schon ein sehr alter Thread ist:

    Vor einiger Zeit dieses Problem bei einer älteren TYPO3-Installation gehabt.
    Ursache war, wie bereits schon von schaule1 erwähnt - danke hierfür :), eine personal desktop-firewall.

    gruss, fuss

    my system:
    C-64 I, 65816@20mhz, 16mb ram, 4x 6581r4 (12 channel fm-sound), 384mb scsi hd
    go sixtyfour! go!