felogin & Statusmeldung (Marker??)

  • Skullriper Skullripe...
    TYPO3-Anwärter
    0 x
    6 Beiträge
    0 Hilfreiche Beiträge
    16. 02. 2010, 11:25

    Hi,

    ich versuche gerade das FELogin Modul einzurichten und bin soweit auch ganz zufrieden. Jetzt habe ich nur ein Problem bezüglich einer kleinen Statusmeldung des angemeldetem Benutzer.

    Man muss sich das so Vorstellen. Ich habe einen Menüpunkt Kundenlogin, da kann ich mich anmelden und werde dann automatisch auf eine andere Seite weitergeleitet. Wenn der Kunde nun aber wieder auf den Menüpunkt Kundenlogin klickt, sieht man das er angemeldet ist mit dem User soundso und ob er sich abmelden will.

    Genau auf dieser Seite möchte ich jetzt zb. noch Firma, Adresse usw. angeben. Kurzgesagt eine kleine Datenausgabe über den angemeldeten User. Ich denke das ich dazu die im FELogin enthaltene Template.html anpassen muss. Allerdings kenne ich die Marker nicht mit denen die von mir geforderten Werte ausgelesen werden. (Falls es die überhaupt gibt)
    ###NAME### habe ich herausgefunden, ###USERNAME### ist ja schon von Haus aus dabei aber sowas wie ###COMPANY### gibts nicht auch die anderen habe ich leider nicht gefunden.

    Vieleicht kann mir das jemand etwas näher erläutern, bzw. mich an einen Link weiterverweisen.

    lg


  • 1
  • Rookie Rookie
    Padawan
    0 x
    41 Beiträge
    0 Hilfreiche Beiträge
    16. 02. 2010, 12:03

    Hallo Skullriper,

    ich habe es noch nicht ausprobiert, aber versuch doch mal eigene Marker zu setzen und diese dann per Typoscript zu füllen:
    [TS]markers{
    # Firma wird mit Daten aus FE-Benutzer-Feld Firma ausgefüllt.
    value_company = TEXT
    value_company.data = TSFE:fe_user|user|company
    }[/TS]

    Viele Grüße
    Ulf

  • Skullriper Skullripe...
    TYPO3-Anwärter
    0 x
    6 Beiträge
    0 Hilfreiche Beiträge
    16. 02. 2010, 13:40

    Ich danke dir vielmals für deine schnelle Antwort, allerdings hat mir das so nicht geholfen. (Warscheinlich habe ich es nicht richtig eingetragen)

    Allerdings habe ich in der class.tx_felogin_pi1.php selbst im Unterbereich showlogoutForm gefunden wo der Username an die Seite übergeben wird und habe da zusätzlich nun die benötigten Daten angefügt.

    1. $markerArray['###COMPANY###'] = htmlspecialchars($GLOBALS['TSFE']->fe_user->user['company']);

    Trotzdem danke für die Hilfe.

    lg

  • 99grad 99grad
    T3PO
    0 x
    19 Beiträge
    1 Hilfreiche Beiträge
    29. 07. 2017, 15:27

    Hatte ein ähnliches Problem – dabei ging es unter Typo3 8 LTS um die Erweiterung von fe_login um eigene Marker. Hier die Lösung zu finden unter: http://labor.99grad.de/?p=1238

  • 1