4.2.11 - 500 Internal Server Error

  • Gernott Gernott
    Jedi-Meister
    0 x
    271 Beiträge
    3 Hilfreiche Beiträge
    17. 01. 2010, 15:10

    Hallo,

    seit dem Update von 4.2.10 auf 4.2.11 kommt im Backend bei allen Modulen unter Web und Datei im rechten Bereich (statt Seitenbaum und Arbeitsframe) eine Serverfehler 500 Meldung. Wenn ich wieder die vorige TYPO3-Version einspiele klappt es wieder.
    Kennt jemand das Problem? Oder hat wer eine Idee woran das liegen könnte?

    Das tritt übrigens nur bei einem Server auf, bei allen anderen klappt es. Irgendwas scheint hier falsch konfiguriert zu sein.

    Es handelt sich um:
    PHP Version 5.2.8
    System Linux server 2.6.16.21-0.25-default x86_64
    Apache Version Apache/2.2.0 (Linux/SUSE)
    mysql Client API version 5.0.26


  • 1
  • Norman2k Norman2k
    Jedi-General
    0 x
    1657 Beiträge
    80 Hilfreiche Beiträge
    17. 01. 2010, 16:04

    Berechtigungen? Symlinks? Fehlerhafte oder nicht vorhandene Datei? Irgendwas falsches in der .htaccess?

    Was sagen denn die Apache-Logs?

  • Gernott Gernott
    Jedi-Meister
    0 x
    271 Beiträge
    3 Hilfreiche Beiträge
    17. 01. 2010, 16:41

    Berechtigungen passen (laut installtool)
    Symlinks gibts keine (hab nur FTP Zugriff und die Ordner direkt zusammenkopiert)
    Package habe ich sicherheitshalber schon zwei Mal hochgeladen - ohne erfolg

    Log:
    [Sun Jan 17 14:31:01 2010] [error][client 85.127.170.240] PHP Fatal error: Call to undefined function filter_var() in XXX/t3lib/class.t3lib_div.php on line 1555, referer: http://www.XXX/typo3/backend.php

    Das hilft schon weiter um das Problem zu finden. Zeile 1555 ist die return Zeile...

    1. /**
    2. * Checks if a given string is a Uniform Resource Locator (URL).
    3. *
    4. * @param string $url: The URL to be validated
    5. * @return boolean Whether the given URL is valid
    6. */
    7. public static function isValidUrl($url) {
    8. return (filter_var($url, FILTER_VALIDATE_URL, FILTER_FLAG_SCHEME_REQUIRED) !== false);
    9. }

    Aber was nun?

  • tandem tandem
    Jedi-General
    0 x
    1053 Beiträge
    1 Hilfreiche Beiträge
    17. 01. 2010, 17:01

    Hallo Gernott,

    ich habe exakt das gleiche Problem!

    PHP Version 5.2.11
    FreeBSD
    MySQL Client API version 5.0.83
    Apache/2.2.13 (FreeBSD) mod_ssl/2.2.13

    Log konnte ich noch nicht prüfen.

    Gruss


  • 0 x
    17. 01. 2010, 19:57

    Ihr müsst für PHP pecl-fliter installieren. Dann sollte es gehen.

    Dass TYPO3 4.3 das benötigt, steht auch in der mitgelieferten [url=http://forge.typo3.org/repositories/entry/typo3v4-core/tags/TYPO3_4-3-0/INSTALL.txt]INSTALL.txt[/url].

  • tandem tandem
    Jedi-General
    0 x
    1053 Beiträge
    1 Hilfreiche Beiträge
    18. 01. 2010, 17:37

    Hallo Chrissitopher,

    danke für den Hinweis!

    Habe folgende Liste überprüfen lassen:
    - PHP 5.2.0 or newer with the following extensions
    > - cURL
    > - filter
    > - GD2
    > - JSON
    > - mbstring
    > - mysql
    > - pcre
    > - session
    > - SPL
    > - standard
    > - xml

    Nun ist alles installiert und es funktioniert.
    Ein weiteres Update auf TYPO3 4.3.1 hat nun ebenfalls problemlos geklappt.

    Gruss

  • 1