Uumstellung auf TYPO3 4.3 + Löschen des Inhalts von typo3temp

  • inu inu
    Jedi-Ratsmitglied
    0 x
    694 Beiträge
    0 Hilfreiche Beiträge
    04. 12. 2009, 15:08

    Hallo Leute,

    ich habe testweise eine Umstellung auf TYPO3 4.3.0 durchgeführt, alle Caches gelöscht und auch alle Dateien aus dem Verzeichnis /typo3temp entfernt.

    Danach werden im Internetauftritt keine Bilder mehr dargestellt und auch die Thumbnails sind nicht mehr verfügbar.

    Kennt jemand eine Lösung?

    Gruß
    David


  • 1
  • inu inu
    Jedi-Ratsmitglied
    0 x
    694 Beiträge
    0 Hilfreiche Beiträge
    04. 12. 2009, 17:25

    Nachtrag:

    Das Problem scheint von ImageMagic herzukommen. Wenn ich über das InstallTool und ImageProcessing gehe und anschließend auf "Write..." klicke, so erhalte ich überall Fehler. Diese treten auch schon bei "Read ..." auf.

    hier die dargestellte Befehlszeile in TYPO3 4.3:
    /usr/local/IM4/bin/convert +profile '*' -geometry 170x136! '/www/testumgebung43/typo3/sysext/install/imgs/jesus.gif[0]' '/www/testumgebung43/typo3temp/pics/install_write_gif.gif'

    unter TYPO3 4.2 (produktiv) erscheint dieses hier:
    /usr/local/IM4/bin/convert -geometry 170x136! '/www/produktion/typo3/sysext/install/imgs/jesus.gif[0]' '/www/produktion/typo3temp/pics/install_write_gif.gif'

    Zum einen wundert mich die "[0]" im Dateinamen und zum anderen ist jetzt zusätzlich im Befehl ein "+profile '*'"

    :'(

  • quernetz quernetz
    Jar Jar Binks
    0 x
    1 Beiträge
    0 Hilfreiche Beiträge
    27. 12. 2009, 02:58

    Auch wenn die Antwort etwas spät ist:

    Bei mir war es sehr ähnlich. Es gibt 2 mögliche Fehlerursachen:

    1) Version 4.3.0 hat zwei neue Werte in der Basiskonfiguration, die per Default auf einen ungünstigen Wert gesetzt sind und das "+profile '*'" erzeugen.

    In
    - im_stripProfileCommand steht der String "+profile '*'"
    - im_useStripProfileByDefault wird die Benutzung des Strings eingeschaltet.

    2) Ich verwende als Standard eine lokale Installation von ImageMagick 4.2.9, da ich häufig auf unterschiedlichen Servern installiere und mich eigentlich nicht lange mit IM beschäftigen will. Dabei werden die Parameter über Shellscripts übergeben. In den Scripts convert, combine und identify habe ich festgestellt, dass die rechteckigen Klammern mit der 0 am Ende des Dateinamens escaped werden und dies auch dazu führt, dass IM mit diesen Dateien nichts anfangen kann. Es wurde "... jesus.gif\[0\]" statt "... jesus.gif[0]" übergeben.

    Das habe ich abgefangen, indem ich in der Übergabe der Parameter an IM die Backslashes lösche.

    Datei convert, combine und identify, aus:
    # Absolute program path
    $(im_path)/bin/`basename $0`.bin "$@"

    wird:
    # Absolute program path
    $(im_path)/bin/`basename $0`.bin $(echo "$@" | sed 's,\\,,g'}

    Danach zeigte auch 4.3.0 wieder Bilder an.

    Es liegt also nicht wirklich an ImageMagick, sondern eher an einer etwas unbedachten Wahl der Default-Werte und einem völlig unnötigen Escapen von den rechteckigen Klammern in TYPO3 4.3.0.

  • riffrömer riffröme...
    TYPO3-Anwärter
    0 x
    6 Beiträge
    0 Hilfreiche Beiträge
    20. 01. 2010, 13:02

    [quote="quernetz"]
    Auch wenn die Antwort etwas spät ist:

    Bei mir war es sehr ähnlich. Es gibt 2 mögliche Fehlerursachen:

    1) Version 4.3.0 hat zwei neue Werte in der Basiskonfiguration, die per Default auf einen ungünstigen Wert gesetzt sind und das "+profile '*'" erzeugen.

    In
    - im_stripProfileCommand steht der String "+profile '*'"
    - im_useStripProfileByDefault wird die Benutzung des Strings eingeschaltet
    [/quote]

    Hallo und danke,

    bei mir war es genau dieser Parameter. Nach Update von 4.2.9 auf 4.3.1.
    Parameter "im_useStripProfileByDefault" im Installtool deaktiviert, Bilder Cache geleert und Thumbnails werden dargestellt. Ebenso im Frontend.

    Robert

  • 1