feeditadvanced - Probleme mit IE und FF

  • CEssl CEssl
    T3PO
    0 x
    9 Beiträge
    0 Hilfreiche Beiträge
    03. 12. 2009, 10:38

    Hallo,

    Ich arbeite momentan mit der aktuellsten Typo3-Installation und möchte nun die neue Extension "feeditadvanced" anwenden. Laut Installationsbeschreibung genügt es, die Extension über den Erweiterungs-Manager zu installieren.

    Das klappt auch bereits in den Browsern [b]Safari[/b], [b]Opera [/b]und [b]Google Chrome[/b]. Die Feedit-Bar erscheint so, wie sie es soll und funktioniert auch.

    Allerdings bekomme ich gerade in den zwei wichtigsten Browsern, [b]IE [/b](Version 7 und 8 ) und [b]Firefox [/b](Version 3), nichts zustande. Während im Firefox GAR KEINE Feedit-Bar eingeblendet wird, schmeißt mir der Internet Explorer diverse Javascript-Fehler zurück, wie "';' erwartet", "getStyle() ist NULL oder kein Objekt", aus der feEdit.js entgegen, die Funktionen in der Bar lassen sich ebensowenig anwenden.

    In der entsprechenden Forge-Seite zu feeditadvanced ist nichts, aber auch gar nichts zu Inkompatibilitäten mit diesen Browsern zu finden, weshalb ich jetzt nicht weiter weiß.

    Hat jemand eine Ahnung, woran das liegen könnte? Diverse Javascripts anderer Extensions, die ev. kollidieren hatte ich auch testweise rausgenommen, ohne jede Änderung.

    Gruß,
    CEssl


  • 1
  • kolki kolki
    Jedi-General
    0 x
    1044 Beiträge
    5 Hilfreiche Beiträge
    03. 12. 2009, 11:50

    Ich hab's nur mal mit dem berüchtigten IE6 getestet und auch JS-Fehler angezeigt bekommen. Möchte ich dann einen Inhalt editieren, schmiert mir der IE komplett ab. Gleiches tut er übrigens auch, wenn ich im BE mit dem RTE arbeiten möchte.
    Achja, ich benutze Typo3 4.3.

    Was ebenfalls ärgerlich ist, dass ich bei aktiviertem "feeditadvanced" nach dem Login im Frontend (IE, FF) via "simulatebe" wieder das blanke Login-Formular bekomme, so dass mir die Möglichkeit fehlt, mich im FE auszuloggen und somit die Session nicht beenden kann. Die Session kann ich dann nur mittels BE-Logout beenden. Dann allerdings ist mir das nächste FE-Login mit FE-Editiermöglichkeit nur dann möglich, wenn ich zuvor die Cookies gelöscht habe. Tu ich das nicht, gibt es nach dem FE-Login kein Admin-Panel und auch kein Editierwerkzeug. Also an "simulatebe" liegt es m.E. nicht.

    Ist der Fehler bei "feeditadvanced" zu suchen? Wer hat einen Plan?

  • codo codo
    R2-D2
    0 x
    87 Beiträge
    0 Hilfreiche Beiträge
    04. 01. 2010, 23:19

    Hi
    ich bekomme auch kein logout mehr über frontend login.
    zusätzlich bleibt bei mir die lightbox einfach schwarz nix mit editing...
    hab jetzt wieder die extensioon feedit installiert und alle klappt wie gewohnt

  • codo codo
    R2-D2
    0 x
    87 Beiträge
    0 Hilfreiche Beiträge
    06. 01. 2010, 19:29

    sodala jetzt bin ich auch soweit dass ich diese fehler bestätigen kann:)
    siehe [url]http://www.typo3.net/forum/list/list_post//95618/?page=1#pid348786[/url]
    aber zumindest bei der installation von beide frontend editing modulen klappts einigermaßen
    fehlermeldung lautet:
    Details zum Fehler auf der Webseite

    Benutzer-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; Tablet PC 2.0; OfficeLiveConnector.1.4; OfficeLivePatch.1.3; InfoPath.1)
    Zeitstempel: Wed, 6 Jan 2010 18:29:20 UTC

    Meldung: 'getStyle(...)' ist Null oder kein Objekt
    Zeile: 1628
    Zeichen: 3
    Code: 0
    URI: http://skoda-oldtimer.at/typo3conf/ext/feeditadvanced/res/js/feEdit.js

    zeile 1628 ist bei mir
    backgroundPosition = body.getStyle('background-position').split(' ');

  • 1