Problem beim Einspielen eines SQL-Dumps - Typo 3.8.1

  • realmatrix realmatri...
    Typ im Roten Hemd
    0 x
    3 Beiträge
    0 Hilfreiche Beiträge
    24. 11. 2009, 15:40

    Hallo liebe Typo3-Community,

    habe ein Problem mit dem Rückspielen eines sql-Backups...wurde unter typo3 3.8.1 mit folgender extension erstellt:

    Title: Typo3_backup
    Description: Create backups from the database and files to secure.
    Author: Peter Bartels <peter.bartels@inconel.nl+>

    Bei Versuch, den SQL-Dump in phpmyadmin einzuspielen, erhalte ich folgende Fehlermeldung (die File ist nicht größer als 20 MB):

    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '02-04-2009 11:17
    bakchos
    be_groups
    DROP TABLE IF EXISTS be_groups' at line 1

    => habe in den ersten Zeilen schon diverse Versuche mit neuen/weggelassenen Semikolons usw. gemacht, dann die tauchen die fehler ein paar zeilen später auf. Wer weiß Rat?

    Teste das ganze mit einer typo3.3.8.1 installation local auf dem notebook, kann das irgendwie mit einer anderen php.version meines Providers zusammen hängen? Dort bin ich auf einen neuen Server umgezogen...das Backup habe ich noch vom alten (nicht mehr verfügbaren) Server gemacht.

    Vielen Dank für Eure Bemühungen

    newbie
    realmatrix :o


  • 1
  • realmatrix realmatri...
    Typ im Roten Hemd
    0 x
    3 Beiträge
    0 Hilfreiche Beiträge
    24. 11. 2009, 15:47

    Nachtrag: Die extension scheint beim sql generell nicht zu funktionieren. Habe sie gerade an einer frischen 3.8.1 local getestet, der einspiel-fehler taucht auch beim zuvor erstellten backup der standard (nach der local angelegeten installation) DB auf...

    Muss die SQL-Datei irgendwie konvertiert werden? Probleme beim überschreiben? Habe leider k.A. von SQL.

    Gruß
    flatbeat23 #paralyzed#

  • realmatrix realmatri...
    Typ im Roten Hemd
    0 x
    3 Beiträge
    0 Hilfreiche Beiträge
    24. 11. 2009, 15:49

    Anfang meiner Datei...

    02-04-2009 11:17
    bakchos
    be_groups
    DROP TABLE IF EXISTS be_groups;
    CREATE TABLE be_groups (
    uid int(11) unsigned NOT NULL auto_increment,
    pid int(11) unsigned DEFAULT '0' NOT NULL,
    tstamp int(11) unsigned DEFAULT '0' NOT NULL,
    title varchar(20) NOT NULL,
    non_exclude_fields blob NOT NULL,
    db_mountpoints varchar(40) NOT NULL,
    pagetypes_select tinyblob NOT NULL,
    tables_select blob NOT NULL,
    tables_modify blob NOT NULL,
    crdate int(11) unsigned DEFAULT '0' NOT NULL,
    cruser_id int(11) unsigned DEFAULT '0' NOT NULL,
    groupMods tinyblob NOT NULL,
    file_mountpoints varchar(40) NOT NULL,
    hidden tinyint(3) unsigned DEFAULT '0' NOT NULL,
    inc_access_lists tinyint(3) unsigned DEFAULT '0' NOT NULL,
    description text NOT NULL,
    lockToDomain varchar(50) NOT NULL,
    deleted tinyint(3) unsigned DEFAULT '0' NOT NULL,
    TSconfig blob NOT NULL,
    subgroup tinyblob NOT NULL,
    hide_in_lists tinyint(4) DEFAULT '0' NOT NULL,
    explicit_allowdeny blob NOT NULL,
    allowed_languages tinyblob NOT NULL,
    custom_options blob NOT NULL,
    tx_clbecache_pagecache tinyint(3) unsigned DEFAULT '0' NOT NULL,
    PRIMARY KEY (uid),
    KEY parent (pid)
    );
    insert into be_groups (uid,pid,tstamp,title,non_exclude_fields,db_mountpoints,pagetypes_select,tables_select,tables_modify,crdate,cruser_id,groupMods,file_mountpoints,hidden,inc_access_lists,description,lockToDomain,deleted,TSconfig,subgroup,hide_in_lists,explicit_allowdeny,allowed_languages,custom_options,tx_clbecache_pagecache) VALUES ('1','0','1142959616','gruene-kirchhain.de','tt_news:hidden,tt_news:datetime,tt_news:image,tt_news:imagecaption,tt_news:related,tt_news:links,tt_news:category,tt_news:news_files,tt_calender:hidden,tt_calender:date,tt_calender:time,tt_calender:link','5,6','254','tt_news,tt_calender','tt_news,tt_calender','1142703703','1','web_list','','0','1','','','0','options.clearCache.pages = 1
    options.clearCache.all = 1','','0','','','','0');
    insert into be_groups (uid,pid,tstamp,title,non_exclude_fields,db_mountpoints,pagetypes_select,tables_select,tables_modify,crdate,cruser_id,groupMods,file_mountpoints,hidden,inc_access_lists,description,lockToDomain,deleted,TSconfig,subgroup,hide_in_lists,explicit_allowdeny,allowed_languages,custom_options,tx_clbecache_pagecache) VALUES ('2','0','1145738643','gj-marburg.de','tt_news:hidden,tt_news:datetime,tt_news:image,tt_news:imagecaption,tt_news:related,tt_news:links,tt_news:category,tt_news:news_files','41','254','tt_news','tt_news','1145738422','1','web_list','','0','1','','','0','options.clearCache.pages = 1
    options.clearCache.all = 1','','0','','','','0');

    ...

  • tandem tandem
    Jedi-General
    0 x
    1053 Beiträge
    1 Hilfreiche Beiträge
    24. 11. 2009, 18:26

    Hallo realmatrix,

    die ersten drei Zeilen:
    02-04-2009 11:17
    bakchos
    be_groups

    löschen.

    Gruss

  • 1