Kann bestimmte html Dateine nicht mehr bearbeiten

  • Nowi Nowi
    Padawan
    0 x
    61 Beiträge
    0 Hilfreiche Beiträge
    05. 11. 2009, 16:58

    Mahlzeit!

    Habe heute folgendes festgestellt. Ich wollte eine Template Datei (html) für feuser_register bearbeiten. Habe die in meinem fileadmin Ordner. Wenn ich nun in dieser Datei etwas ändere speichert er das nicht und gibt mir die alte Variante der Seite wieder aus. Dachte liegt an irgendwelchen Schreibrechten der html Datei, da es bei anderen Datein im selben Ordner problemlos geht (habe nur kleine Änderungen versucht). Habe dann eine neue Datei über TYPO3 angelegt, einen Namen vergeben (das ging) und wollte dann dort den Inhalt der anderen Datei (Template Datei von feuser_register) einfügen.

    War nix. Ich kann die neue Datei mit dem Inhalt der feuser_register Templatedatei nicht speichern. Schreibe ich in die neue Datei einfach nur ein paar Zeichen, lässt er mich speichern. Füge ich aber den Inhalt der Templatedatei ein, speichert er einfach nicht.

    Hatte sowas noch nie. Hab auch nix dazu gefunden. Vielleicht hat ja hier jemand eine Lösung.

    TYPO3 4.2.10


  • 1
  • Nowi Nowi
    Padawan
    0 x
    61 Beiträge
    0 Hilfreiche Beiträge
    06. 11. 2009, 09:25

    Mahlzeit!

    Habe nach einschalten der Fehlermeldungen folgende Fehlermeldung oben am Rand, wenn ich eine html /txt Datei speichern will.

    1. Warning: Invalid argument supplied for foreach() in /home/www/web24/html/t3/typo3conf/ext/mm_forum/includes/cache/class.tx_mmforum_cache_file.php on line 141

    Weiß zwar nicht was das mit dem mm_forum zu tun haben soll, aber die Meldung kommt wenn ich die Templatedatei speichern will.
    Wenn diese Fehlermeldung auftaucht, wird die Änderung an der Datei komischerweise gespeichert. Wenn die Fehlermeldung nicht kommt, wird auch nicht gespeichert!?
    Mmh... :o versteh gard gar nix mehr.

    Habe hier noch etliche CodeWarnungen in der Extensionbeschreibung gefunden:

    1. (developer-relevant) No XCLASS inclusion code found in file "pi1/class.tx_srfeuserregister_pi1.php"
    2. No XCLASS inclusion code found in file "pi1/class.tx_srfeuserregister_pi1_adodb_time.php"
    3. No XCLASS inclusion code found in file "pi1/class.tx_srfeuserregister_pi1_base.php"
    4. No XCLASS inclusion code found in file "pi1/class.tx_srfeuserregister_pi1_urlvalidator.php"
    5. No XCLASS inclusion code found in file "control/class.tx_srfeuserregister_control.php"
    6. No XCLASS inclusion code found in file "control/class.tx_srfeuserregister_control_main.php"
    7. No XCLASS inclusion code found in file "control/class.tx_srfeuserregister_setfixed.php"
    8. No XCLASS inclusion code found in file "lib/class.tx_srfeuserregister_auth.php"
    9. No XCLASS inclusion code found in file "lib/class.tx_srfeuserregister_email.php"
    10. No XCLASS inclusion code found in file "lib/class.tx_srfeuserregister_lang.php"
    11. No XCLASS inclusion code found in file "lib/class.tx_srfeuserregister_lib_tables.php"
    12. No XCLASS inclusion code found in file "lib/class.tx_srfeuserregister_passwordmd5.php"
    13. No XCLASS inclusion code found in file "lib/class.tx_srfeuserregister_tca.php"
    14. No XCLASS inclusion code found in file "marker/class.tx_srfeuserregister_marker.php"
    15. No XCLASS inclusion code found in file "hooks/class.tx_srfeuserregister_hooksHandler.php"
    16. No XCLASS inclusion code found in file "hooks/class.tx_srfeuserregister_hooks_cms.php"
    17. No XCLASS inclusion code found in file "view/class.tx_srfeuserregister_display.php"
    18. No XCLASS inclusion code found in file "model/class.tx_srfeuserregister_controldata.php"
    19. No XCLASS inclusion code found in file "model/class.tx_srfeuserregister_data.php"
    20. Class filename "model/class.tx_srfeuserregister_model_conf.php" did NOT contain the class "tx_srfeuserregister_model_conf"!
    21. No XCLASS inclusion code found in file "model/class.tx_srfeuserregister_model_conf.php"
    22. No XCLASS inclusion code found in file "model/class.tx_srfeuserregister_model_feusers.php"
    23. No XCLASS inclusion code found in file "model/class.tx_srfeuserregister_model_setfixed.php"
    24. No XCLASS inclusion code found in file "model/class.tx_srfeuserregister_model_table_base.php"
    25. No XCLASS inclusion code found in file "model/class.tx_srfeuserregister_url.php"
    26. No XCLASS inclusion code found in file "model/field/class.tx_srfeuserregister_model_field_base.php"
    27. No XCLASS inclusion code found in file "model/field/class.tx_srfeuserregister_model_field_usergroup.php"

    Habe eben noch probiert den Inhalt der Templatedatei zu löschen. Das geht problemlos. Nur den Inhalt aus der Vorlage der Extension bekomm ich nun nicht mehr da rein. Es wird einfach nichts gespeichert.

  • Nowi Nowi
    Padawan
    0 x
    61 Beiträge
    0 Hilfreiche Beiträge
    06. 11. 2009, 10:14

    Mahlzeit!

    Hab noch etwas entdeckt. Wenn ich auf "Speichern und Schließen" klicke, dann speichert TYPPO3 weder die Datei noch wird sie geschlossen. Es kommt einfach der alte Inhalt wieder und die Datei ist halt immer noch offen. Obwohl ich ja auf "Speichern und Schließen" gegangen bin.

  • Nowi Nowi
    Padawan
    0 x
    61 Beiträge
    0 Hilfreiche Beiträge
    06. 11. 2009, 10:44

    Mahlzeit!

    So langsam arbeite ich mich heran. Habe jetzt durch probieren herausgefunden, dass ich Dateien bis max 63kb bearbeiten und speichern kann. Egal ob .txt oder .html. Alles was drüber liegt (bei 64kb hat er nicht mehr gespeichert) funktioniert nicht. Gibt es eine Begrenzung im TYPO3, bzw. kann ich das irgendwo einstellen?
    Im Install Tool hab ich dazu nichts gefunden.

    PS: Kann vielleicht ein Admin mal mein Thema ändern und diesen Vertipper korrigieren? 8-)

  • 1